Posts: 2
Joined: Mon Mar 28, 2016 9:54 am

Re: Getting Brother-Printer drivers to work

Mon Mar 28, 2016 10:06 am

Just want to share an alternative solution (that isn't mentioned here)

After installing CUPS, setup your printer as a local raw printer.

Connect to the printer from your windows / mac clients using the path:

Code: Select all

http://<pi ip address>/printers/<printer name>:631
Then install the necessary brother drivers on the windows / mac client machine only.

And voila! Full-featured printing :)

Posts: 1
Joined: Mon Nov 16, 2015 9:43 pm

Re: Getting Brother-Printer drivers to work

Sun May 15, 2016 10:08 pm

piiteri wrote:I have a Brother DCP-1510. To get printing to work via cups all I had to do was to generate/download the "HL-1250" ( go here: ) and supply that PPD to cups when selecting the driver. In no time it had a test page printed after that...
I used this method with a Brother HL2240 and it worked. Thanks a lot.

Posts: 1
Joined: Mon Aug 07, 2017 7:42 am

Re: Getting Brother-Printer drivers to work

Mon Aug 07, 2017 7:51 am

I used this method with a Brother HL2240 and it worked. Thanks a lot.
This also worked for me - thanks very much to piiteri.
Brother HL-1230
Raspberry pi model B rev 1
Raspbian Jessie Lite (July 2017)
Cups 2.2.4

Posts: 1
Joined: Fri Sep 29, 2017 9:15 pm

Re: Getting Brother-Printer drivers to work

Fri Sep 29, 2017 9:19 pm

Hi, I know this is an old thread, but none of the solutions here worked for me and I have one that is working not mentioned here. I have HL2170W and MFC9130CW both from brother.

For the HL-2170W I use the cups driver for 1870N that comes with cups. It works fine but you have to switch defaults from A4 paper to letter.

For the MFC9130CW this one is harder. None of the brother drivers work. I tried a lot of drivers and I found that "HP Color LaserJet CM3530 MFP PDF" that also comes with the cups install works well with this printer. It's actually super fast to print and prints in 600DPI color.

Hope that helps someone.

Posts: 3
Joined: Wed Feb 17, 2016 1:08 am

Re: Getting Brother-Printer drivers to work

Sun Oct 01, 2017 6:04 pm

I have been experimenting with this on my rPi2 (Raspbian Stretch), with a Brother MFC-J6710DW printer.

I do know Cups is functional on the pi2 because I can do a test-print to my IBM Network Printer 12 (on ethernet), so the service is functional and is able to communicate to a networked printer. Cups even sees the MFC printer under "Find New Printers" (both under DNSSD and LPD). I had to point it to the MFC-J6710DW PPD on my Linux machine (installed through the x86 DEB drivers downloaded from Brother), although Cups was showing an error that it couldn't find /usr/lib/cups/filter/brother_lpdwrapper_mfcj6710dw, so I copied that over and restarted cups.

Figured I'd also see if it needed filter files, so copied over the ones in /opt/brother over to Raspbian. As an aside: I had to edit the "lpd://" line for the MFC printer in Cups to show the IP number (since it defaults to using the serial number of the printer, which DNS won't see).

If I go into "Printers" and send a Test Print page to the Brother printer, Cups will say it has already been sent/printed, but nothing actually gets printed. Confirmed the printer works by printing from my Linux system, so it is online and receiving data. So somewhere Cups on the pi2 is sending the print job into the fathomless void rather than the printer.

I tried to cross-compile from the source code from Brother's website (currently at ... &type3=576 , although next week it could be in a completely different location). Cross compiled on my laptop (Linux Mint 18.2, 64bit) because the rPi2 is also my "jumpbox", and I don't want things like compilers on it. Don't think I have the right command string, or perhaps not the right packages, because the output was just another text file.

Specifically trying to make this work here so that I can then set it up to handle Google Cloud Print (for when my daughter is using a Chromebook at home for schoolwork). The "local print" functionality supposedly included with ChromeOS 59 & up looks like it won't support the printers I have either, and I don't have a setup to verify that from anyway.

Posts: 13
Joined: Fri Jan 20, 2017 4:24 am

Re: Getting Brother-Printer drivers to work

Tue Jan 30, 2018 8:17 pm

I stumbled onto this thread tyring to get the Brother MFC-8710 printer operational with the Pi B 2. Following the posts above that mention the HL-1250 driver ... I went to the cups config at localhost:631 and manually pointed cups to the static IP of my printer, and then it asked me to pick from one of it's included drivers... I picked the HL-1250 and test page printed fine. The driver file it's using is STP01410.ppd (Brother HL-1250 - CUPS + Gutenprint v5.2.10). The driver works for duplex printing, etc. Hats off to derPhil!

Posts: 2
Joined: Mon Feb 26, 2018 5:42 pm

Re: Getting Brother-Printer drivers to work

Tue Feb 27, 2018 4:19 am

Looks like Brother does currently have at least generic drivers for the armhf architecture and Raspbian: ... rppx2.html

I got my HL-1110 printer to work with the driver: ... .armhf.deb
First I removed the installed generic printer and installed HL-1110 as a shared printer with the CUPS interface. After that I could use the CUPS interface to print a test page. Printing from Mac and Windows computers in the same WLAN worked as well. I haven't tested the print quality yet.

Posts: 1
Joined: Sat Jun 30, 2012 5:09 pm

Re: Getting Brother-Printer drivers to work

Mon Dec 24, 2018 4:48 am

I got my MFC-7340 working on the RPi 1 using the generic drivers mentioned by @zifban. Thanks.

Return to “Troubleshooting”