Page 1 of 1

LED strip on USB hub

Posted: Tue Jun 14, 2016 7:27 am
by wemarch
Not quite sure which board to use for posting this issue, so I try here.

I'm trying to power a 5V led strip using a powered USB hub (to which my Pi is also connected to).
However, it works with one hub (goobay 4 port) but it doesn't work with the other one (D-Link 4 port) and I'm not sure why.

This are the specs I could find out:

led strip:
voltage: 5V, power: 3,6W, so current should be 3,6W/5V = 720 mA

goobay hub (works):
no specs found

D-Link hub (doesn't work):
max current of 500 mA per port. It has a fast charging port for mobile devices but i couldn't find out it's max current.
I should mention that the hub works fine with the Pi and all other devices.

I would at least expect a weak glowing of the led strip with 500 mA but it doesn't.

Any idea why it works with the goobay hub but not with the D-Link hub?

Re: LED strip on USB hub

Posted: Tue Jun 14, 2016 2:16 pm
by penguintutor
Could the LED strip be trying to pull more than the 720mA?

I've seen other types of LED bulbs where they have quoted the amount of power used by the LED bulbs, but not included power lost in the resistors included in the lights. This could mean that it is pulling more power than the USB hub is able to deliver (perhaps 1A or more). The hub may include overload protection and so could be cutting the power supply to the LED strip.

Also the LED strip includes it's own circuitry to control the LEDs, so if the voltage is dropping significantly (due to the amount of current) then the voltage may have dropped below the working threshold of the circuitry and so it doesn't turn any of them on.

Have you tried connecting just the LED strip to the fast charging port with nothing else connected? The fast charging port should be able to provide 2A so that should light the LEDs.

In any case it sounds like you need a USB power supply with a higher rating than the 500mA from the standard ports on that hub.

Re: LED strip on USB hub

Posted: Tue Jun 14, 2016 4:27 pm
by wemarch
I already tried to use the fast charging port without any other devices, no result.

Is there an easy way to measure the max current of the usb port and the power consumption of the led strip?

It would be pretty interesting to compare the max current of both hubs.

Edit: I managed to measure the current of the strip. It needs nearly 1A when all LEDs light up (=white). There is a small controller attached to the strip. By bypassing this controller the strip works with both hubs (even at the regular 500 mA ports and with white light).