oKieran
Posts: 11
Joined: Wed Feb 11, 2015 9:54 am

Cannot SSH over WIFI (wlan0 not configured)

Wed Jun 08, 2016 9:32 am

Hi, I have read a number of forum posts regarding Wifi issues (inc. viewtopic.php?f=28&t=40426) but none seem to come to any kind of resolution. I have a RPI2 and RPI3 both experiencing similar issues.
RPI2: Will not SSH but can connect to browser etc. Route -n returns:

Code: Select all

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
0.0.0.0         192.168.1.1     0.0.0.0         UG    303    0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     303    0        0 wlan0
ifconfig wlan0 returns:

Code: Select all

wlan0     Link encap:Ethernet  HWaddr 40:a5:ef:07:2e:a1  
          inet addr:192.168.1.155  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::42a5:efff:fe07:2ea1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2021 errors:0 dropped:0 overruns:0 frame:0
          TX packets:59 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:330366 (322.6 KiB)  TX bytes:11075 (10.8 KiB)

interfaces file contains:

Code: Select all

auto lo

iface lo inet loopback
iface eth0 inet dhcp

auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
	wpa-ssid "SSID_here"
	wpa-psk "Password_here"
RPI3: Will not SSH but connects to internet, first boot cannot find wlan0 and have written script to reboot when wifi disconnects. After a number of reboots the wifi will be found and will connect but will drop off shortly after. Here I am using wpa_supplicant:

Code: Select all

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=GB

network={
    ssid="SSID_here"
    psk="Password_here"
    key_mgmt=WPA-PSK
}
Starting to give up with wifi completely.. Any help would be appreciated.
Thanks in advance!
To assume makes an a*s out of you and me.

epoch1970
Posts: 5144
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Cannot SSH over WIFI (wlan0 not configured)

Wed Jun 08, 2016 11:08 am

Are your trying to ssh TO the Pis or FROM them?
How does the same action work when using ethernet?
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

oKieran
Posts: 11
Joined: Wed Feb 11, 2015 9:54 am

Re: Cannot SSH over WIFI (wlan0 not configured)

Wed Jun 08, 2016 11:13 am

epoch1970 wrote:Are your trying to ssh TO the Pis or FROM them?
How does the same action work when using ethernet?

I am connecting to them using PuTTY on windows connecting to the Pis. Ethernet works as normal (which is how I retrieved the output code above).
Difference with ethernet is that I get a 10.xx.xx address instead of a 192.168.x.x
To assume makes an a*s out of you and me.

dgordon42
Posts: 788
Joined: Tue Aug 13, 2013 6:55 pm
Location: Dublin, Ireland

Re: Cannot SSH over WIFI (wlan0 not configured)

Wed Jun 08, 2016 12:07 pm

Are your Pi's running Raspbian Jessie? You can check with:

Code: Select all

cat /etc/os-release
Since the introduction of Raspbian Jessie about a year ago, the "/etc/network/interfaces" file should not be modified.
Try restoring yours to the original:

Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    wireless-power off

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    wireless-power off
Your "/etc/wpa_supplicant/wpa_supplicant.conf" file looks OK.
oKieran wrote:RPI3: Will not SSH but connects to internet
Many people have found that adding the line:

Code: Select all

IPQoS cs0 cs0
to the end of the "/etc/ssh/sshd_config" file gets SSH (and NTP) working over the Pi 3B's built in WiFi.

Reboot.
oKieran wrote:have written script to reboot when wifi disconnects
This should not be necessary!

Hope this helps,
Dave.

oKieran
Posts: 11
Joined: Wed Feb 11, 2015 9:54 am

Re: Cannot SSH over WIFI (wlan0 not configured)

Wed Jun 08, 2016 12:46 pm

Thanks for the reply Dave.
Are your Pi's running Raspbian Jessie?
Sorry, forgot to mention they are both running Jessie!
Try restoring yours to the original
I have replaced the interface file with the same affect, the RPI2 still boots connected to wifi but cannot SSH to it.
Many people have found that adding the line:
IPQoS cs0 cs0
to the end of the "/etc/ssh/sshd_config" file gets SSH (and NTP) working over the Pi 3B's built in WiFi.
The RPI3 is slightly different as the wlan0 only shows after a 'sudo reboot'. Though even when I do this, the SSH config change still doesn't allow me to SSH to it.

I have used SSH many many times before without error, though something seems to have changed recently to not allow it. Is it possible that our IT guys (at work) could have done something?
To assume makes an a*s out of you and me.

oKieran
Posts: 11
Joined: Wed Feb 11, 2015 9:54 am

Re: Cannot SSH over WIFI (wlan0 not configured)

Wed Jun 08, 2016 12:51 pm

Also - does the wifi drop out on the RPI3 due to the strength of the built in wifi? The RPI2 uses WiPi and the strength seems to be fine...
To assume makes an a*s out of you and me.

User avatar
dasmanul
Posts: 502
Joined: Wed Sep 30, 2015 10:20 am
Location: Frankfurt, Germany

Re: Cannot SSH over WIFI (wlan0 not configured)

Wed Jun 08, 2016 1:03 pm

oKieran wrote:Difference with ethernet is that I get a 10.xx.xx address instead of a 192.168.x.x
To me this sounds like your LAN and your WLAN are actually separate networks. In that case, it's no wonder that you can't reach your Pis from your (presumably LAN-connected)Windows machines. Have you tried whether you can ping a) your Pis from your Windows machines and b) vice versa?

Could you describe your network setup in more detail? What kind of router, how is it set up, where are you running your DHCP server, how is it configured, what is connected to what?

oKieran
Posts: 11
Joined: Wed Feb 11, 2015 9:54 am

Re: Cannot SSH over WIFI (wlan0 not configured)

Wed Jun 08, 2016 1:36 pm

I have just been informed by our IT guys that it is a seperate network and have asked for some more information. Im not network guy so the only information I can give you is that my windows machine is connected to LAN and the raspberry pi's to WLAN, hence there may be some kind of comms issue (and may not be the pi?), though I have never had issues before (I have been sending data to a SQL server).
I have just tried to ping from both ends with no luck.
I will let you know what the IT team say (if they ever answer...) :roll:
To assume makes an a*s out of you and me.

oKieran
Posts: 11
Joined: Wed Feb 11, 2015 9:54 am

Re: Cannot SSH over WIFI (wlan0 not configured)

Thu Jun 09, 2016 9:22 am

dasmanul wrote:To me this sounds like your LAN and your WLAN are actually separate networks.
You are completely correct. Turns out that I have been spending 2 days on an issue that has been caused by the IT guys.They have recently separated the networks as they didn't realise anyone was using the WLAN I had been connected to.. Thanks for the help!

So with that out of the way, I am still faced with a RPI3 that, on first boot, doesn't find 'wlan0' (not configured). A stab in the dark would say this is something related to the modifications I may have made to try and configure UART (mods to cmdline.txt and config.txt to include overlays etc).
To assume makes an a*s out of you and me.

epoch1970
Posts: 5144
Joined: Thu May 05, 2016 9:33 am
Location: Paris, France

Re: Cannot SSH over WIFI (wlan0 not configured)

Thu Jun 09, 2016 9:52 am

oKieran wrote:A stab in the dark would say this is something related to the modifications I may have made to try and configure UART (mods to cmdline.txt and config.txt to include overlays etc).
I have used an Edimax wifi-n 150mbps USB wifi adapter and the card in the Pi 3 to setup APs. I, for one, am satisfied with the way internal wifi works on the Pi 3: better support from wireless tools and better coverage. The only configuration options I have ever fiddled with are related to leds behavior.

Make sure you upgrade the system (apt-get update && apt-get upgrade) though. The initial distribution of raspbian for Pi 3 offered mild wifi performance. The current version (kernel 4.4.11) is, I think, working quite well.
"S'il n'y a pas de solution, c'est qu'il n'y a pas de problème." Les Shadoks, J. Rouxel

oKieran
Posts: 11
Joined: Wed Feb 11, 2015 9:54 am

Re: Cannot SSH over WIFI (wlan0 not configured)

Tue Jun 14, 2016 9:38 am

epoch1970 wrote:Make sure you upgrade the system (apt-get update && apt-get upgrade) though. The initial distribution of raspbian for Pi 3 offered mild wifi performance. The current version (kernel 4.4.11) is, I think, working quite well.
I have updated/graded with no luck. On first boot after a shutdown I get no wifi (wlan0 not configured) and after reboot it comes back.

Maybe I should just leave the script running to reboot when it cannot ping the server.. but this is a plaster rather than a solution!

Thanks for the help.
To assume makes an a*s out of you and me.

User avatar
dasmanul
Posts: 502
Joined: Wed Sep 30, 2015 10:20 am
Location: Frankfurt, Germany

Re: Cannot SSH over WIFI (wlan0 not configured)

Tue Jun 14, 2016 11:24 am

I think the Kernel only gets upgraded with "apt-get dist-upgrade" - have you done that? What does "uname -a" give you?

oKieran
Posts: 11
Joined: Wed Feb 11, 2015 9:54 am

Re: Cannot SSH over WIFI (wlan0 not configured)

Wed Jun 15, 2016 10:48 am

I have updated the kernel using rpi-update (dist-upgrade would not work) which uname -a shows as:
Linux raspberrypi 4.4.13-v7+ #894 SMP Mon Jun 13 13:13:27 BST 2016 armv7l GNU/Linux
Still the same issue :(

Edit:
I have also reinstalled the OS (and ofc upgraded and updated)..
To assume makes an a*s out of you and me.

User avatar
bleep42
Posts: 176
Joined: Wed Mar 07, 2012 12:43 pm
Location: Sussex

Re: Cannot SSH over WIFI (wlan0 not configured)

Wed Jun 15, 2016 12:57 pm

I'm getting similar problems on a Pi2 with wireless dongles (several makes).
From the desktop if I click on the network icon, it shows my network, but won't reliably connect to it, at random it will connect and just as randomly it'll disconnect it's showing 3 bars of strength, so that's not a problem and I'm using the latest update 4.4.11, though I started to have problems a few weeks ago.
I've trawled the forums but there seems to be so much noise that it's difficult to pick out the good advice from the chaff.
Regards Kevin.

oKieran
Posts: 11
Joined: Wed Feb 11, 2015 9:54 am

Re: Cannot SSH over WIFI (wlan0 not configured)

Wed Jun 15, 2016 1:10 pm

Is the Power Management OFF? Use

Code: Select all

iwconfig
to confirm.
To assume makes an a*s out of you and me.

User avatar
bleep42
Posts: 176
Joined: Wed Mar 07, 2012 12:43 pm
Location: Sussex

Re: Cannot SSH over WIFI (wlan0 not configured)

Wed Jun 15, 2016 1:28 pm

oKieran wrote:Is the Power Management OFF? Use

Code: Select all

iwconfig
to confirm.

Code: Select all

iwconfig
wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.447 GHz  Access Point: Not-Associated   
          Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

eth0      no wireless extensions.

oKieran
Posts: 11
Joined: Wed Feb 11, 2015 9:54 am

Re: Cannot SSH over WIFI (wlan0 not configured)

Wed Jun 15, 2016 2:18 pm

It does sound like your issue is power related. Is it powered through a hub? Here is a list of working/problem hubs http://elinux.org/RPi_Powered_USB_Hubs

Also read here: http://elinux.org/RPi_USB_Wi-Fi_Adapter ... i_Adapters as it details that you may need a hub and details a list of working/problem adapters.
To assume makes an a*s out of you and me.

User avatar
bleep42
Posts: 176
Joined: Wed Mar 07, 2012 12:43 pm
Location: Sussex

Re: Cannot SSH over WIFI (wlan0 not configured)

Wed Jun 15, 2016 3:07 pm

oKieran wrote:It does sound like your issue is power related. Is it powered through a hub? Here is a list of working/problem hubs http://elinux.org/RPi_Powered_USB_Hubs

Also read here: http://elinux.org/RPi_USB_Wi-Fi_Adapter ... i_Adapters as it details that you may need a hub and details a list of working/problem adapters.
Yes, I've already gone down the power route, can't find any problems, but that's not to say there aren't any, difficult to isolate.
This dongle is using the Realtek RTL8188CUS chip, which should be fine.
One thing I have noticed and it may be my imagination, if I have the eth0 connected as well, the WiFi is much more likely to connect and stay connected, I've just managed to watch all of Ebans latest video, apparently over WiFi, though with the eth0 also connected.
Next boot, with no eth0, no WiFi associated again, then 3 mins after connecting the eth0, WiFi connects???
Regards, Kevin.

oKieran
Posts: 11
Joined: Wed Feb 11, 2015 9:54 am

Re: Cannot SSH over WIFI (wlan0 not configured)

Wed Jun 15, 2016 3:53 pm

Well, in my case I have exhausted many options and therefore everything now points to a hardware issue. I have a new RPi 3 on order and will try again. Maybe yours is the same (unless there's more for you to look at - I.E are your interface and wpa_supplicant files correct? Follow https://wiki.archlinux.org/index.php/WPA_supplicant to ensure correct configuration. When wifi has been disconnected, what does lsmod show? Has it loaded the brcmfmac module?)
To assume makes an a*s out of you and me.

User avatar
bleep42
Posts: 176
Joined: Wed Mar 07, 2012 12:43 pm
Location: Sussex

Re: Cannot SSH over WIFI (wlan0 not configured)

Wed Jun 15, 2016 4:15 pm

oKieran wrote:Well, in my case I have exhausted many options and therefore everything now points to a hardware issue. I have a new RPi 3 on order and will try again. Maybe yours is the same (unless there's more for you to look at - I.E are your interface and wpa_supplicant files correct? Follow https://wiki.archlinux.org/index.php/WPA_supplicant to ensure correct configuration. When wifi has been disconnected, what does lsmod show? Has it loaded the brcmfmac module?)
Yes unfortunately I've been all through those as well, though what is 'brcmfmac' module I haven't seen mention of that before, and no I don't seem to have it in my lsmod, either when connected via WiFi or not?

Code: Select all

cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    wireless-power off

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    wireless-power off

Code: Select all

sudo cat /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=GB

network={
	ssid="xxxx"
	psk="xxxx"
	key_mgmt=WPA-PSK
}

Code: Select all

lsmod
Module                  Size  Used by
bnep                   10340  2 
bluetooth             326105  5 bnep
8192cu                560049  0 
cfg80211              427855  1 8192cu
rfkill                 16037  4 cfg80211,bluetooth
joydev                  9024  0 
evdev                  11396  6 
sg                     18319  0 
snd_bcm2835            20511  1 
snd_pcm                75698  1 snd_bcm2835
snd_timer              19160  1 snd_pcm
snd                    51844  5 snd_bcm2835,snd_timer,snd_pcm
bcm2835_gpiomem         3040  0 
bcm2835_wdt             3225  0 
uio_pdrv_genirq         3164  0 
uio                     8000  1 uio_pdrv_genirq
i2c_dev                 5859  0 
fuse                   83461  3 
ipv6                  347530  48

dgordon42
Posts: 788
Joined: Tue Aug 13, 2013 6:55 pm
Location: Dublin, Ireland

Re: Cannot SSH over WIFI (wlan0 not configured)

Wed Jun 15, 2016 5:19 pm

bleep42, from lsmod wrote:8192cu 560049 0
On the Pi, this WiFi driver does not respond to the normal "wireless-power off" line in '/etc/network/interfaces', and 'iwconfig' always shows "Power Management: off".

To turn off power management you must create the file "/etc/modprobe.d/8192cu.conf", and add the line:

Code: Select all

options 8192cu rtw_power_mgnt=0 rtw_enusbss=0
The file should be owned by root

Reboot.
bleep42 wrote:what is 'brcmfmac' module
It's the driver for the Pi 3B's built in WiFi. You wont have it on a Pi 2 (unless you are using a Broadcom WiFi dongle).

Hope this helps,
Dave.

User avatar
bleep42
Posts: 176
Joined: Wed Mar 07, 2012 12:43 pm
Location: Sussex

Re: Cannot SSH over WIFI (wlan0 not configured)

Thu Jun 16, 2016 5:17 pm

dgordon42 wrote:
bleep42, from lsmod wrote:8192cu 560049 0
On the Pi, this WiFi driver does not respond to the normal "wireless-power off" line in '/etc/network/interfaces', and 'iwconfig' always shows "Power Management: off".

To turn off power management you must create the file "/etc/modprobe.d/8192cu.conf", and add the line:

Code: Select all

options 8192cu rtw_power_mgnt=0 rtw_enusbss=0
The file should be owned by root

Reboot.
bleep42 wrote:what is 'brcmfmac' module
It's the driver for the Pi 3B's built in WiFi. You wont have it on a Pi 2 (unless you are using a Broadcom WiFi dongle).

Hope this helps,
Dave.
Hi Dave,
Thanks for the explanation, that all makes perfect sense and at least I now know why I need 8192cu.conf I had seen mention of it, but it wasn't clear why it might be needed.
Unfortunately this hasn't really helped, I've tried with two different WiFi dongles RT5370 & RTL8188CUS, both giving similar results, ie failure to associate, even though the relevant WiFi network is displayed in the drop down when you click on the network configuration icon. The RT5370 is slightly better at occasionally associating, so from that I've found that if I use an unpowered USB hub between the Pi2 an the WiFi dongle, it will always connect and associate? So then I tried to see what was different and I found.
Without Hub.

Code: Select all

iwconfig
wlan0     IEEE 802.11bgn  ESSID:"AXIMX50V"  
          Mode:Managed  Frequency:2.447 GHz  Access Point: E8:FC:AF:37:3A:B0   
          Bit Rate=52 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=51/70  Signal level=-59 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:28  Invalid misc:2563   Missed beacon:0

lo        no wireless extensions.

eth0      no wireless extensions.
I got this number of 'invalid misc' simply reloading the Raspberry pi blog 3 times.
Now the same with the unpowered hub.

Code: Select all

iwconfig
wlan0     IEEE 802.11bgn  ESSID:"AXIMX50V"  
          Mode:Managed  Frequency:2.447 GHz  Access Point: E8:FC:AF:37:3A:B0   
          Bit Rate=65 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=49/70  Signal level=-61 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:16  Invalid misc:161   Missed beacon:0

lo        no wireless extensions.

eth0      no wireless extensions.
I positioned the dongle as close as possible to the same position in both the above, I still don't think it's power as the WiFi connection improves when I add the unpowered hub, which in theory would make a power problem worse. I have tried another different hub and that didn't improve things at all, it gave the same results as having no hub.
I'm stumped. Kevin.

dgordon42
Posts: 788
Joined: Tue Aug 13, 2013 6:55 pm
Location: Dublin, Ireland

Re: Cannot SSH over WIFI (wlan0 not configured)

Fri Jun 17, 2016 1:45 am

@bleep42,
I think you have a very different problem to the OP (oKieran), and probably should be on a different thread, but anyway.
bleep42 wrote:though I started to have problems a few weeks ago.
Did your WiFi work normally until a few weeks ago, when there was a sudden change in performance?
bleep42 wrote: I've already gone down the power route, can't find any problems, but that's not to say there aren't any, difficult to isolate.
A Pi 2 should be able to power a WiFi dongle provided it's power supply is, and it's also not trying to feed a lot of other hungry devices. If the red power LED stays on constantly, and there is no small "rainbow" square on the top right of your monitor, then your power supply is OK.
If you have several USB devices plugged into your Pi, or you are worried that your dongle is not getting enough power from your Pi add the line:

Code: Select all

max_usb_current=1
to /boot/config.txt.
Link Quality=49/70 Signal level=-61 dBm
These figures, from one of your 'iwconfig' postings look low to me. They seem to be taken when you had your RT5370 plugged in. The 8188 driver gives a sightly different format readout. Here's mine, from ifconfig & iwconfig with an Edimax EN7811Un dongle (RTL8188CUS chipset):

Code: Select all

wlan0     Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx
          inet addr:192.168.8.105  Bcast:192.168.8.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:33822 errors:0 dropped:1 overruns:0 frame:0
          TX packets:16426 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:12287541 (11.7 MiB)  TX bytes:3321923 (3.1 MiB)

pi@raspberrypi ~ $ iwconfig
wlan0     IEEE 802.11bgn  ESSID:"HUAWEI-E5372-A218"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:2.437 GHz  Access Point: xx:xx:xx:xx:xx:xx
          Bit Rate:72.2 Mb/s   Sensitivity:0/0
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=100/100  Signal level=95/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Can you improve your signal by moving things around like your Pi, your WIfI router, other computers or devices that can generate RF interference?
Can you change the channel your WiFi router operates on?
I have noticed that, with the Edimax, once Link Quality starts to drop, performance drops rapidly as well.
bleep42 wrote: it's showing 3 bars of strength, so that's not a problem
WiFi drivers have so many ways of reporting signal strength that I don't trust the GUI's signal bars. Put a few mobile phones beside each other, and they will all disagree about signal strength.

Hope this helps,
Dave.

Return to “Troubleshooting”