akehrli
Posts: 6
Joined: Wed May 25, 2016 9:38 am

[Solved] impossible to install something

Wed May 25, 2016 10:01 am

Hello,

I am a real newbie, so sorry to my ignorance, but I am completely stuck to install something on Raspbian. Indeed, here is what i have done :

Code: Select all

sudo apt-get update // that's works
sudo apt-get install tightvncserver

I have :

Code: Select all

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  nodered xfonts-base
Suggested packages:
  tightvnc-java
The following NEW packages will be installed:
  tightvncserver xfonts-base
The following packages will be upgraded:
  nodered
1 upgraded, 2 newly installed, 0 to remove and 7 not upgraded.
1 not fully installed or removed.
Need to get 0 B/12.0 MB of archives.
After this operation, 9,895 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Reading changelogs... Done
(Reading database ... 117963 files and directories currently installed.)
Preparing to unpack .../nodered_0.13.4-1_armhf.deb ...
Unpacking nodered (0.13.4-1) over (0.13.4) ...
it is stuck at this position during a while and I have :

Code: Select all

dpkg: error processing archive /var/cache/apt/archives/nodered_0.13.4-1_armhf.deb (--unpack):
 unable to securely remove '/usr/lib/node_modules/node-red/node_modules/when/unfold/list.js.dpkg-new': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/LICENSE.txt': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/es6-shim/Promise.browserify-es6.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/es6-shim/Promise.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/es6-shim/Promise.min.js.map': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/es6-shim/Promise.min.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/es6-shim/Promise.js.map': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/pipeline.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/guard.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/dist/browser/when.js.map': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/dist/browser/when.debug.js.map': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/dist/browser/when.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/dist/browser/when.debug.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/dist/browser/when.min.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/dist/browser/when.min.js.map': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/delay.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/generator.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/parallel.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/monitor.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/cancelable.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/poll.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/keys.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/sequence.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/function.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/when/package.json': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/window-size/LICENSE-MIT': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/window-size/index.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/window-size/package.json': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/brace-expansion/index.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/brace-expansion/package.json': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/xml2js/lib/bom.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/xml2js/lib/processors.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/xml2js/lib/xml2js.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/xml2js/LICENSE': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/xml2js/package.json': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/commander/LICENSE': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/commander/index.js': Read-only file system
dpkg: error while cleaning up:
 unable to restore backup version of `/usr/lib/node_modules/node-red/node_modules/commander/package.json': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/lodash.keys/LICENSE': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/lodash.keys/index.js': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/lodash.keys/package.json': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/getpass/lib/index.js': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/getpass/LICENSE': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/getpass/node_modules/assert-plus/AUTHORS': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/getpass/node_modules/assert-plus/assert.js': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/getpass/node_modules/assert-plus/package.json': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/getpass/package.json': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bindings/bindings.js': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bindings/package.json': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/etag/LICENSE': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/etag/index.js': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/etag/package.json': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/once/LICENSE': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/once/package.json': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/once/once.js': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/jodid25519/lib/core.js': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/jodid25519/lib/curve255.js': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/jodid25519/lib/utils.js': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/jodid25519/lib/eddsa.js': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/jodid25519/lib/dh.js': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/jodid25519/LICENSE': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/jodid25519/almond.1': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/jodid25519/AUTHORS.md': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/jodid25519/jsdoc.json': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/jodid25519/index.js': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/jodid25519/almond.0': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/jodid25519/package.json': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/type-is/LICENSE': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/type-is/index.js': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/type-is/package.json': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/build/Release/.deps/Release/bcrypt_lib.node.d': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/build/Release/.deps/Release/obj.target/bcrypt_lib.node.d': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/build/Release/.deps/Release/obj.target/bcrypt_lib/src/blowfish.o.d': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/build/Release/.deps/Release/obj.target/bcrypt_lib/src/bcrypt.o.d': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/build/Release/.deps/Release/obj.target/bcrypt_lib/src/bcrypt_node.o.d': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/build/Release/obj.target/bcrypt_lib/src/bcrypt_node.o': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/build/Release/obj.target/bcrypt_lib/src/blowfish.o': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/build/Release/obj.target/bcrypt_lib/src/bcrypt.o': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/build/Release/obj.target/bcrypt_lib.node': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/build/Release/bcrypt_lib.node': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/build/bcrypt_lib.target.mk': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/build/binding.Makefile': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/build/Makefile': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/build/config.gypi': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/binding.gyp': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/LICENSE': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/bcrypt.js': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/werker.yml': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/Makefile': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/src/blowfish.cc': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/src/node_blf.h': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/src/bcrypt.cc': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/src/bcrypt_node.cc': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/bcrypt/package.json': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/mime-types/LICENSE': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/mime-types/index.js': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/mime-types/package.json': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/caseless/LICENSE': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/caseless/index.js': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/caseless/package.json': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/destroy/LICENSE': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/destroy/index.js': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/destroy/package.json': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/basic-auth/LICENSE': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/basic-auth/index.js': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/node_modules/basic-auth/package.json': Input/output error
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/lib/node_modules/node-red/package.json': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/bin/node-red-stop': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/bin/node-red-start': Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/usr/bin/update-nodejs-and-nodered': Read-only file system
dpkg: error while cleaning up:
 unable to securely remove '/var/lib/dpkg/tmp.ci': Read-only file system
dpkg: error while cleaning up:
 unable to securely remove '/var/lib/dpkg/reassemble.deb': Read-only file system
dpkg: error processing archive /var/cache/apt/archives/tightvncserver_1.3.9-6.5_armhf.deb (--unpack):
 cannot access archive: No such file or directory
dpkg: error processing archive /var/cache/apt/archives/xfonts-base_1%3a1.0.3_all.deb (--unpack):
 cannot access archive: No such file or directory
Processing triggers for gnome-menus (3.13.3-6) ...
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
dpkg: unrecoverable fatal error, aborting:
 unable to flush updated status of `gnome-menus': Read-only file system
E: Sub-process /usr/bin/dpkg returned an error code (2)
E: Problem executing scripts DPkg::Post-Invoke '/usr/bin/test -e /usr/share/dbus-1/system-services/org.freedesktop.PackageKit.service && /usr/bin/test -S /var/run/dbus/system_bus_socket && /usr/bin/gdbus call --system --dest org.freedesktop.PackageKit --object-path /org/freedesktop/PackageKit --timeout 4 --method org.freedesktop.PackageKit.StateHasChanged cache-update > /dev/null; /bin/echo > /dev/null'
E: Sub-process returned an error code
And I have to restart Pi, and do

Code: Select all

sudo dpkg --configure -a
But this problem appears each time I have to install something so I really need your help!

many thanks

Antoine
Last edited by akehrli on Wed Jun 01, 2016 2:05 pm, edited 1 time in total.

andreasko
Posts: 1
Joined: Wed May 25, 2016 6:04 pm

Re: impossible to install something

Wed May 25, 2016 6:27 pm

Hi Antoine,

Don't know if my approach is correct...
But here is what I did....
Force removed nodered (That is the package that makes all the fuzz)

Code: Select all

sudo dpkg --force-all -P nodered
It will probably through some warnings that some directories are not empty, so dpkg will not delete them.

As I type now, I am doing an "apt-get upgrade" and so far I haven't had any problems.
I hope it finishes smoothly.

best regards,

Andreas

akehrli
Posts: 6
Joined: Wed May 25, 2016 9:38 am

Re: impossible to install something

Thu May 26, 2016 7:23 am

Hello Andreas,

Thanks for your reply, I thought something was wrong with this file but I didn't dare (and know) how to proceed to remove such file. So many thanks for your explanations.
I add I forgot to mention but I had done an apt-get upgrade, but as soon as Raspbian needs to open a packet, same problem occured, a bit like i was in a vicious cycle...

So it is solved now, thanks again

Cheers

Antoine

akehrli
Posts: 6
Joined: Wed May 25, 2016 9:38 am

Re: impossible to install something

Thu May 26, 2016 1:24 pm

Hi all,

Sorry to be back in this post, but I get everytime same problem to install something, I am not far to throw my RPi to bin !!
here is my actions :

Code: Select all

[email protected]:~ $ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libraspberrypi-bin libraspberrypi-dev libraspberrypi-doc libraspberrypi0
  raspberrypi-bootloader
The following packages will be upgraded:
  libraspberrypi-bin libraspberrypi-dev libraspberrypi-doc libraspberrypi0
  raspberrypi-bootloader
5 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
2 not fully installed or removed.
Need to get 0 B/35.9 MB of archives.
After this operation, 1,024 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Reading changelogs... Done
(Reading database ... 111010 files and directories currently installed.)
Preparing to unpack .../libraspberrypi-dev_1.20160512-1_armhf.deb ...
Unpacking libraspberrypi-dev (1.20160512-1) over (1.20160506-1) ...
dpkg: error processing archive /var/cache/apt/archives/libraspberrypi-dev_1.20160512-1_armhf.deb (--unpack):
 unable to clean up mess surrounding `./opt/vc/include/VG/vgext.h' before installing another version: Read-only file system
dpkg: error while cleaning up:
 unable to remove newly-extracted version of `/opt/vc/include/bcm_host.h': Read-only file system
dpkg: error while cleaning up:
 unable to securely remove '/var/lib/dpkg/tmp.ci': Read-only file system
dpkg: error while cleaning up:
 unable to securely remove '/var/lib/dpkg/reassemble.deb': Read-only file system
dpkg: error processing archive /var/cache/apt/archives/libraspberrypi-doc_1.20160512-1_armhf.deb (--unpack):
 cannot access archive: No such file or directory
dpkg: error processing archive /var/cache/apt/archives/libraspberrypi-bin_1.20160512-1_armhf.deb (--unpack):
 cannot access archive: No such file or directory
dpkg: error processing archive /var/cache/apt/archives/libraspberrypi0_1.20160512-1_armhf.deb (--unpack):
 cannot access archive: No such file or directory
dpkg: error processing archive /var/cache/apt/archives/raspberrypi-bootloader_1.20160512-1_armhf.deb (--unpack):
 cannot access archive: No such file or directory
dpkg: error: unable to create new file '/var/lib/dpkg/status-new': Read-only file system
E: Sub-process /usr/bin/dpkg returned an error code (2)
E: Problem executing scripts DPkg::Post-Invoke '/usr/bin/test -e /usr/share/dbus-1/system-services/org.freedesktop.PackageKit.service && /usr/bin/test -S /var/run/dbus/system_bus_socket && /usr/bin/gdbus call --system --dest org.freedesktop.PackageKit --object-path /org/freedesktop/PackageKit --timeout 4 --method org.freedesktop.PackageKit.StateHasChanged cache-update > /dev/null; /bin/echo > /dev/null'
E: Sub-process returned an error code
each it appears it is unable to overwrite on present version of files, and it talks about read only file system...

Impossible to do anything, knowing I want just to install vnc, with tightvncserver package.
i re-install several times NOOBS, or RaspBian on my SD which is OK with the list, so, I am a bit lost...

Thanks for your help,

Antoine

SkyRise
Posts: 179
Joined: Tue Jan 24, 2012 1:20 pm

Re: impossible to install something

Thu May 26, 2016 1:35 pm

Have you got enough space left on your SD card? Has the filesystem been expanded to the full size of the card?
It looks more like filesystem corruption though, which is why the filesystem is getting mounted Read Only.

After a reboot, can you post the output of:

Code: Select all

mount
and

Code: Select all

df -h

akehrli
Posts: 6
Joined: Wed May 25, 2016 9:38 am

Re: impossible to install something

Thu May 26, 2016 6:50 pm

Hello Skyline

Thanks for your reply I will test it tomorrow morning ( in Switzerland) but I guess something wrong with installation. I precise I extended partition via sudo raspi-config. I let you know

Cheers

Antoine

User avatar
scruss
Posts: 2893
Joined: Sat Jun 09, 2012 12:25 pm
Location: Toronto, ON
Contact: Website

Re: impossible to install something

Thu May 26, 2016 6:55 pm

Have you tried a different card? The read-only filesystem message usually means a corrupted card.
‘Remember the Golden Rule of Selling: “Do not resort to violence.”’ — McGlashan.

akehrli
Posts: 6
Joined: Wed May 25, 2016 9:38 am

Re: impossible to install something

Fri May 27, 2016 7:54 am

Hello SkyLine ans Scruss,

Please find here result of mount command:

Code: Select all

[email protected]:~ $ mount
/dev/mmcblk0p2 on / type ext4 (rw,noatime,data=ordered)
devtmpfs on /dev type devtmpfs (rw,relatime,size=469544k,nr_inodes=117386,mode=755)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=22,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
mqueue on /dev/mqueue type mqueue (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
/dev/mmcblk0p1 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=94776k,mode=700,uid=1000,gid=1000)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
[email protected]:~ $
and for ressources with df -h command, here is result:

Code: Select all

[email protected]:~ $ df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root        15G  3.4G   11G  25% /
devtmpfs        459M     0  459M   0% /dev
tmpfs           463M     0  463M   0% /dev/shm
tmpfs           463M  6.4M  457M   2% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           463M     0  463M   0% /sys/fs/cgroup
/dev/mmcblk0p1   63M   21M   43M  33% /boot
tmpfs            93M     0   93M   0% /run/user/1000

but As Cruss said, perhaps SD is bad, but I have not a one availble right now....

Thanks for your help,

Antoine

akehrli
Posts: 6
Joined: Wed May 25, 2016 9:38 am

Re: impossible to install something

Wed Jun 01, 2016 8:19 am

Hello,

Just to say my problem coming from my kingston SD card, even if it was compliant with Raspberry, now it is working well with my SanDisk ultra. I find it's a bit a pity to be annoying by such problem, because all memory support, compliant in terms of size, class, read/write ops should work. On my opinion this problem doesn't help Raspberry if we consider a newbie can be easily discouraged, and then will give up this fantastic support to quickly. but it's only my opinion.

Thanks for your help

Antoine

PS: I don't now where I can set this topic as solved...

blaablaaguy
Posts: 623
Joined: Sun Sep 27, 2015 3:26 pm

Re: impossible to install something

Wed Jun 01, 2016 1:02 pm

akehrli wrote:Hello,

Just to say my problem coming from my kingston SD card, even if it was compliant with Raspberry, now it is working well with my SanDisk ultra. I find it's a bit a pity to be annoying by such problem, because all memory support, compliant in terms of size, class, read/write ops should work. On my opinion this problem doesn't help Raspberry if we consider a newbie can be easily discouraged, and then will give up this fantastic support to quickly. but it's only my opinion.

Thanks for your help

Antoine

PS: I don't now where I can set this topic as solved...
Just edit yourp posts title with [Solved] in front of the name
This signature intentionally left blank.

Return to “Troubleshooting”