Bee_Steward
Posts: 7
Joined: Sun Apr 17, 2016 6:22 pm

SD Card Copier failure

Thu May 19, 2016 3:54 pm

Happy to see latest-version Raspian's new entry in MENU|Accessories:SD Card Copier utility. :D
But it doesn't work on my RasPi3. :(

Using either a NOOB Samsung 16gb EVO SD card or a freshly SDFormatted disk, I've repeatedly failed to make a copy of my Raspian OS card via the new CardCopier app.

Each time, the app seems to run normally and has completed its task. The app builds five partitions and then reports its progress as it copies data into each one. So far, so good....

Then it presents a “Copy complete” message with an “OK” button. The button is inactive and won’t respond either to clicking or simply pressing keyboard <Enter>.


After about 5 minutes, the “Copy complete” message disappears and is replaced by an error message saying CardCopier isn’t responding. If I leave THAT message up on the screen without responding to it, this message will eventually disappear and I’m returned to the Desktop. Rasbian OS now appears to be running normally.

So I issue a Shutdown command and then turn off RasPi 3B.

Then I insert the “duplicated” card into RasPi and turn it back on.

It runs and immediately presents an unexpected/unwelcome NOOBS v1.8 installation screen. So I select <Exit> from the NOOBS menu and then must pull RasPi’s power to regain control of the Pi (there is no apparent-elegant way to turn off Pi from the NOOBS Installation Menu).

There's no evidence that my source disk has been duplicated to the destination SD Card. :cry:

Any ideas (besides returning to Win32DiskImager for making duplicate SD cards...)?

Many thanks!

Rick

DavidMS
Posts: 139
Joined: Fri May 25, 2012 8:48 pm
Contact: Website

Re: SD Card Copier failure

Sat May 21, 2016 6:52 am

Sounds like you have got further than me I have been trying it on a PiZero this morning and it seem to have hung on 'Preparing Partitions' for the last half and hour, think maybe I will go back to rpi-clone
http://meanderingpi.wordpress.com/
11 Raspberry Pi's and counting....

davehiggins2170
Posts: 6
Joined: Fri May 13, 2016 5:22 pm

Re: SD Card Copier failure

Sun May 22, 2016 6:16 pm

I've been trying to use the SD card copier on a new copy of Jessie. I'm using 2 brand new 8Gb cards and the script ran for a long time on my B+ (I wasn't watching but well over an hour) before failing with a message saying there wasn't enough space. The card I'd copied to wouldn't boot so I sdformatted it and then copied it with Win32 Disk Imager which worked fine and booted up OK. The card has 4.5Gb free so there's plenty of space.

Is there a known problem with the program as I can't find anything wrong with my setup.

Dave

stderr
Posts: 2178
Joined: Sat Dec 01, 2012 11:29 pm

Re: SD Card Copier failure

Sun May 22, 2016 7:29 pm

davehiggins2170 wrote:The card has 4.5Gb free so there's plenty of space.Is there a known problem with the program as I can't find anything wrong with my setup.
I don't understand what has 4.5gig free means, usually when you copy an image, it's the entire drive which you claimed was 8gig.

gordon77
Posts: 4934
Joined: Sun Aug 05, 2012 3:12 pm

Re: SD Card Copier failure

Sun May 22, 2016 7:43 pm

The SD copier only seems to copy the files not the entire card. I copied a 32GB card with 4.5GB used to a 8GB card OK.

davehiggins2170
Posts: 6
Joined: Fri May 13, 2016 5:22 pm

Re: SD Card Copier failure

Sun May 22, 2016 9:55 pm

Sorry I meant there was 4.5gb free after copying it so there shouldn't have been a space issue.

texy
Forum Moderator
Forum Moderator
Posts: 5161
Joined: Sat Mar 03, 2012 10:59 am
Location: Berkshire, England

Re: SD Card Copier failure

Mon May 23, 2016 7:58 am

gordon77 wrote:The SD copier only seems to copy the files not the entire card. I copied a 32GB card with 4.5GB used to a 8GB card OK.
...another bonus feature then ;)
Various male/female 40- and 26-way GPIO header for sale here ( IDEAL FOR YOUR PiZero ):
https://www.raspberrypi.org/forums/viewtopic.php?f=93&t=147682#p971555

Return to “Troubleshooting”