no1453
Posts: 7
Joined: Sat Jul 13, 2013 10:30 pm

R Pi 3, no sound through HDMI

Fri May 06, 2016 4:44 pm

I've been working on this for a few hours; got a new Raspberry Pi 3, just installed the newest release of Raspian Jessie yesterday, but no sound through HDMI. I've tried adding "hdmi_drive=2" to /boot/config.txt, I've tried using raspi-config to force audio output to HDMI, I've even tried a different television set to be sure it was the pi.

I'm using a wav file to test with "aplay" (though I've tried a handful of programs that produce sound). If I'm in the desktop environment, I can use the speaker icon to switch between analog and HDMI, the analog output is fine, I can hear the wav playing. But switch to HDMI, no error with aplay, but silence.

Anyone else run into sound problems with the Pi 3? Any ideas of something else to try? I have also gone through

Code: Select all

apt-get update; apt-get upgrade; apt-get dist-upgrade; rpi-update
, so it's updated.

User avatar
Rive
Posts: 586
Joined: Sat Mar 26, 2016 5:21 pm
Location: USA

Re: R Pi 3, no sound through HDMI

Fri May 06, 2016 4:46 pm

You probably broke something. Are you using an HDTV/HDMI Monitor w/ built in for sound? or are you using the audio jack (analog)?

First mistake

Code: Select all

rpi-update
Second mistake (IMHO)

Code: Select all

dist-upgrade
Better off sticking with this only (and doing it every week or so, or as needed):

Code: Select all

sudo apt-get update
sudo apt-get upgrade
Last edited by Rive on Fri May 06, 2016 5:40 pm, edited 2 times in total.
DNPNWO

DirkS
Posts: 10670
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: R Pi 3, no sound through HDMI

Fri May 06, 2016 4:49 pm

Can you post the output of 'lsmod'?
There should be a module 'snd_bcm2835'

leiptrstormr
Posts: 60
Joined: Mon May 18, 2015 12:33 pm

Re: R Pi 3, no sound through HDMI

Fri May 06, 2016 5:15 pm

I have issues with no HDMI audio when using rpi-update to 4.4.8 as well. Forcing it through raspi-config doesn't work either. I understand you must have dtparam=audio=on enabled because of device tree. I have reverted back to 4.1.19 for the time being.

no1453
Posts: 7
Joined: Sat Jul 13, 2013 10:30 pm

Re: R Pi 3, no sound through HDMI

Fri May 06, 2016 10:21 pm

Thanks for the replies, all good advice. I did a fresh install of Jessie on a spare card, and confirm HDMI audio works fine out of the box. I think I'm just going to start over with the pi. Edit: 'lsmod' does list the sound module on the non-working installation.

Return to “Troubleshooting”