Page 1 of 1

Unable to login to GUI

Posted: Mon Aug 13, 2012 10:46 pm
by rock_rebel
When I first created my SD Card image of Raspbian I was never asked for a password for both the "pi" and "root" accounts. Today however I noticed that some applications refused to work, so upon restarting I was prompted with a login window instead of booting straight to the GUI. When I put in the password for the "pi" acoount, it seems to be logging in by showing a black screen, but a few seconds later it brings me back to the login window. The root account works without entering a password. I've changed the password to the "pi" account using raspi-config but still have the same issue. Is there some configuration I need to change to allow login using the "pi" account? I don't want to have to format and start from scratch as I've changed a lot of configuration settings and had to compile some programs from scratch. Thanks for your assistance.

Re: Unable to login to GUI

Posted: Tue Aug 14, 2012 6:21 pm
by rock_rebel
Really? No one knows a solution to this?

Re: Unable to login to GUI

Posted: Tue Aug 14, 2012 7:01 pm
by hibol
Normally when you boot your Pi, it asks you to login and you have to type "pi" for the username ans "raspberry" for the password.
If it is correct, it will then let you type whatever command you like (like "startx" to start the GUI for example). If it is wrong, it will just tell you to login again.

Usually the raspbian OS won't boot directly to the GUI, except if you once told it to do so.

Re: Unable to login to GUI

Posted: Tue Aug 14, 2012 8:00 pm
by Jim JKla
If you have a spare card even one as small as a 2gig you could put Wheezy onto it and look at the way it handles startx.

There's Wheezy info in the wiki and some of it is noob level (I do not know if thats your level) but there may be info there that can help. ;)

Re: Unable to login to GUI

Posted: Fri Aug 24, 2012 8:57 pm
by lines
Hello,

i had the same problem.
It seemed that there was a problem in the file /home/pi/.Xauthority that was blocked by something and was not unblocked after usage.
that helped for me:
stop Xserver or login as root and execute:

Code: Select all

cp /home/pi/.Xauthority /home/pi/.Xauthority_backup
to keep the old one as backup

Code: Select all

rm /home/pi/.Xauthority
and confirm that you want to remove the blocked file.
A new file .Xauthority is created automatically after the next startx.

same problem was here:
http://www.raspberrypi.org/phpBB3/viewt ... ty#p134756