rock_rebel
Posts: 22
Joined: Wed Aug 08, 2012 1:43 am

Unable to login to GUI

Mon Aug 13, 2012 10:46 pm

When I first created my SD Card image of Raspbian I was never asked for a password for both the "pi" and "root" accounts. Today however I noticed that some applications refused to work, so upon restarting I was prompted with a login window instead of booting straight to the GUI. When I put in the password for the "pi" acoount, it seems to be logging in by showing a black screen, but a few seconds later it brings me back to the login window. The root account works without entering a password. I've changed the password to the "pi" account using raspi-config but still have the same issue. Is there some configuration I need to change to allow login using the "pi" account? I don't want to have to format and start from scratch as I've changed a lot of configuration settings and had to compile some programs from scratch. Thanks for your assistance.

rock_rebel
Posts: 22
Joined: Wed Aug 08, 2012 1:43 am

Re: Unable to login to GUI

Tue Aug 14, 2012 6:21 pm

Really? No one knows a solution to this?

User avatar
hibol
Posts: 33
Joined: Thu Jul 26, 2012 9:44 am
Location: Switzerland

Re: Unable to login to GUI

Tue Aug 14, 2012 7:01 pm

Normally when you boot your Pi, it asks you to login and you have to type "pi" for the username ans "raspberry" for the password.
If it is correct, it will then let you type whatever command you like (like "startx" to start the GUI for example). If it is wrong, it will just tell you to login again.

Usually the raspbian OS won't boot directly to the GUI, except if you once told it to do so.

User avatar
Jim JKla
Posts: 2218
Joined: Sun Jan 29, 2012 11:15 pm
Location: Newcastle upon Tyne UK

Re: Unable to login to GUI

Tue Aug 14, 2012 8:00 pm

If you have a spare card even one as small as a 2gig you could put Wheezy onto it and look at the way it handles startx.

There's Wheezy info in the wiki and some of it is noob level (I do not know if thats your level) but there may be info there that can help. ;)
Noob is not derogatory the noob is just the lower end of the noob--geek spectrum being a noob is just your first step towards being an uber-geek ;)

If you find a solution please post it in the wiki the forum dies too quick

lines
Posts: 7
Joined: Fri Aug 24, 2012 8:48 pm
Location: DE

Re: Unable to login to GUI

Fri Aug 24, 2012 8:57 pm

Hello,

i had the same problem.
It seemed that there was a problem in the file /home/pi/.Xauthority that was blocked by something and was not unblocked after usage.
that helped for me:
stop Xserver or login as root and execute:

Code: Select all

cp /home/pi/.Xauthority /home/pi/.Xauthority_backup
to keep the old one as backup

Code: Select all

rm /home/pi/.Xauthority
and confirm that you want to remove the blocked file.
A new file .Xauthority is created automatically after the next startx.

same problem was here:
http://www.raspberrypi.org/phpBB3/viewt ... ty#p134756

Return to “Troubleshooting”