Rainbow Screen

6 posts
by juiceforfun » Thu Aug 09, 2012 4:17 pm
Hello all,

First off, I know people don't like new threads but I have gone two weeks now searching threads and not getting any results, so I figured it was time.

What is happening is that I turn the RPi on (I have the raspbian wheezy OS) and the rainbow screen appears and then nothing happens. I have tried downloading a different start.elf file since that is what the wiki recommends. I use windows and I just copied and pasted the new one in there, renamed it, and deleted the old one. I wasn't sure if I had to use the windiskbinary thing just for one file. Anyways, I know the power supply is fine since on occasion I get the linux dialogue screen. I am using a 16GB PNY class 6 card. Please help. And please be clear because I don't really understand a lot of the technical stuff.

Posts: 5
Joined: Thu Aug 09, 2012 4:10 pm
by dom » Fri Aug 10, 2012 1:11 am
Forum Moderator
Forum Moderator
Posts: 4459
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge
by juiceforfun » Fri Aug 10, 2012 9:32 pm
Ya I looked there but I don't understand where to get the new kernel.img or how to properly install it on the sd card....
Posts: 5
Joined: Thu Aug 09, 2012 4:10 pm
by Jim JKla » Fri Aug 10, 2012 9:43 pm
Re-name your downloaded file and try again also look for the earlier Wheezy image the Beta.

The fact that you sometimes get the dialogue does not rule out a power supply issue although it is less likely.

There is some stuff aimed at noob support in the wiki the following link should help


Consider the blind login with your RPi connected only to power and ethernet (no screen).

I have tried to keep these wiki pages as noob friendly as I can to the point where they may seem to be patronising. ;)
Noob is not derogatory the noob is just the lower end of the noob--geek spectrum being a noob is just your first step towards being an uber-geek ;)

If you find a solution please post it in the wiki the forum dies too quick
User avatar
Posts: 2201
Joined: Sun Jan 29, 2012 11:15 pm
Location: Newcastle upon Tyne UK
by BenWiley4000 » Sun Aug 12, 2012 8:10 pm
Hey! I've been using Debian Squeeze for several months and I just got this issue for the first time. I think it was a firmware update.

So I replaced the kernel.img with the one from an older backup I had which works. But I still have the same rainbow screen.

What else could be wrong?

Posts: 100
Joined: Sun Jun 24, 2012 1:36 am
by BenWiley4000 » Sun Aug 12, 2012 9:07 pm
Not sure which file did the trick, and it might be that I downloaded the latest kernel.img and not the old one (shouldn't have made a difference I don't think, but ok...). I replaced arm192_start.elf, arm224_start.elf, start.elf, kernel.img, and kernel_cutdown.img with the latest versions. works
Posts: 100
Joined: Sun Jun 24, 2012 1:36 am