BeeryChisels
Posts: 18
Joined: Sat Apr 13, 2013 7:00 pm

Which java(script) do I need?

Sat Mar 19, 2016 6:55 pm

Hello all. I have several Raspberry Pi's and have had very little success with any of the browsers supplied. I could see some internet pages on my screen, but it was never long before I got the error "No support for Java" or "Java required" or some such. It might have been Javascript that was missing, not Java, its been so long since I last tried that I've forgotten. I'd like to use RISC-OS as well as Raspbian, but I'd be happy if just one of them worked to be going on with!
I've read loads of stuff on here, trying to find out what is wrong, what I need, and where I get it from, but to no avail. Most of the questions and answers seem to be about programming instead of just using it as some kind of operating system bolt-on to enable browsers to work. I'd have thought there'd be something in the Beginners section with a topic called "How to get your browsers working properly" or some such.
Any help would be appreciated, but please keep it simple. I just want to use it like I do on the PC (spit), i.e. without knowing anything at all about it.
Regards, Beery Chisels

fruitoftheloom
Posts: 24553
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Which java(script) do I need?

Sat Mar 19, 2016 7:01 pm

BeeryChisels wrote:Hello all. I have several Raspberry Pi's and have had very little success with any of the browsers supplied. I could see some internet pages on my screen, but it was never long before I got the error "No support for Java" or "Java required" or some such. It might have been Javascript that was missing, not Java, its been so long since I last tried that I've forgotten. I'd like to use RISC-OS as well as Raspbian, but I'd be happy if just one of them worked to be going on with!
I've read loads of stuff on here, trying to find out what is wrong, what I need, and where I get it from, but to no avail. Most of the questions and answers seem to be about programming instead of just using it as some kind of operating system bolt-on to enable browsers to work. I'd have thought there'd be something in the Beginners section with a topic called "How to get your browsers working properly" or some such.
Any help would be appreciated, but please keep it simple. I just want to use it like I do on the PC (spit), i.e. without knowing anything at all about it.
Regards, Beery Chisels
In Raspbian - Iceweasel Browser
"IcedTeaPlugin is a web browser plugin to execute Java applets, supporting LiveConnect/JavaScript. It is targeted for xulrunner-1.9 and compatible browsers that support the NPAPI"

Code: Select all

sudo apt-get update
sudo apt-get install icedtea-7-plugin iceweasel


Regards Java installed http://www.javatester.org
Thinking outside the box is better than burying your head in the sand...

BeeryChisels
Posts: 18
Joined: Sat Apr 13, 2013 7:00 pm

Re: Which java(script) do I need?

Sun Mar 20, 2016 3:26 am

Cheers! I'll try it tomorrow!

User avatar
DougieLawson
Posts: 40228
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: Which java(script) do I need?

Sun Mar 20, 2016 8:34 am

First thing you need to understand is that Java is NOT the same as Javascript. They are not even remotely related except that you can call a Java applet from Javascript.

Javascript (aka ECMA script) only got that name because Java was the funky new thing that everyone wanted to use at the time that ECMA script was launched by the Netscape (later to become Mozilla) folks. It's the most stupid naming decision in the history of computing. Any other name (how about "ECMAscript (drop the blank)") would have been a better option.
Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All fake doctors are on my foes list.

Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

BeeryChisels
Posts: 18
Joined: Sat Apr 13, 2013 7:00 pm

Re: Which java(script) do I need?

Sun Mar 20, 2016 5:23 pm

Ah, that accounts for some of my confusion then. Definitely a bad choice of names, almost down to Gatesian standards! It looks as if icedtea is working, as this is me on a Raspberry Pi now. I've visited other sites too before coming here, its a case of so far so good.
Regards, Beery Chisels

BeeryChisels
Posts: 18
Joined: Sat Apr 13, 2013 7:00 pm

Re: Which java(script) do I need?

Sun Mar 20, 2016 5:31 pm

To fruitoftheloom, cheers, thanks a lot, the code you posted seems to have worked. I'm going to keep watching for a day or two in case any more interesting snippets arrive. Thanks again,
Regards, Beery Chisels (its an anagram)

Return to “Troubleshooting”