cosmicboy
Posts: 17
Joined: Mon Sep 03, 2012 9:25 am

RPI3 bluetooth Audio Sink not working

Sat Mar 05, 2016 10:12 pm

Hi,
I have been using a RPI 2 as a bluetooth audio sink successfully for quite some time now.
Today I tried the same setup with my new RPI3, however, the device only appears as a Telephony Service on my Android phone, although device class 0x20041C has been set.

Is it possible that this is due to the bluetooth chip in the RPI 3?
I followed exactly the steps in http://www.instructables.com/id/Enhance ... th-Blueto/


Thanks for any hint.

Marcel

cosmicboy
Posts: 17
Joined: Mon Sep 03, 2012 9:25 am

Re: RPI3 bluetooth Audio Sink not working

Fri Mar 11, 2016 4:05 am

Any ideas?

User avatar
Douglas6
Posts: 4671
Joined: Sat Mar 16, 2013 5:34 am
Location: Chicago, IL

Re: RPI3 bluetooth Audio Sink not working

Fri Mar 11, 2016 2:44 pm

Are you running OSMC or Raspbian? Are you sure you updated 'Class=0x20041C' in both /etc/bluetooth/main.conf and /var/lib/bluetooth/XX:XX:XX:XX:XX:XX/settings?

The latest (beta) version of OSMC has A2DP built in, you might give that a try.

cosmicboy
Posts: 17
Joined: Mon Sep 03, 2012 9:25 am

Re: RPI3 bluetooth Audio Sink not working

Fri Mar 11, 2016 8:02 pm

Yes. hciconfig -a shows the class is 0x20041c inderd. For services it lists audio only however.

I am running raspbian jessie

User avatar
Douglas6
Posts: 4671
Joined: Sat Mar 16, 2013 5:34 am
Location: Chicago, IL

Re: RPI3 bluetooth Audio Sink not working

Fri Mar 11, 2016 8:25 pm

A couple of others have succeeded with A2DP on Jessie using a guide mentioned in this post: viewtopic.php?p=923929#p923929

cosmicboy
Posts: 17
Joined: Mon Sep 03, 2012 9:25 am

Re: RPI3 bluetooth Audio Sink not working

Sun Mar 13, 2016 8:53 am

@Douglas6: thanks a lot. That link worked for me :-)

Return to “Troubleshooting”