User avatar
tadd
Posts: 15
Joined: Wed Dec 17, 2014 5:15 am
Location: Raleigh, NC
Contact: Website

NOOBS 1.8 intermittent ethernet? Ping not usable?

Fri Mar 04, 2016 9:13 pm

Raspberry PI 2 B w/keyboard, mouse, and HDMI display
MacOSX workstation
SDformater
8GB SDcard
NOOBS 1.8 lite
Ethernet network with DHCP provided.

I'm having a problem with NOOBS software, I think

I used SDformater on the Mac to wipe the SDcard. Copied NOOBS 1.8 lite onto the card. Inserted it into the Raspberry PI 2 B and powered it on. The display comes up and after telling me that it is making adjustments to the card it shows the selection-of-OS menu and a modal dialog in the foreground that says I need to have a wired connection to continue. I click ok. The list of OSs is fully populated so I chose the first entry, Raspbian Jessie, I think, and clicked on Install. When I finished installation of Jessie and started it I discovered that I couldn't use ping. When I tried ping I got this error
"ping: icmp open socket: Operation not permitted"
I found a fix on-line to cd /bin and then
sudo chmod u+s ping

That fixed the problem.
However, I'm testing and attempting to debug a written startup procedure and I wanted to get it right. So after testing the rest of the install procedure, I formatted the SDcard on my Mac, copied NOOBS_lite_v1_8 to the card and powered on the Raspberry PI 2 B. Once again I get the error telling me I must connect a wired network to the Raspberry PI. There is one. It works! It's DHCP. I clicked to close the modal dialog and again the list of OSs is fully populated. Again I select the first entry and it is off and installing.

Again, after install and boot the ping function does not work and needs to be fixed.

Is this a problem with NOOBS_lite_v1_8 ?? Are the two problems (complaining about the wired network and ping not working) related? Is it my Ethernet network?
I didn't have this problem the last time I worked with the Raspberry PI, I used NOOBS_lite_v1_5 at that time. BTW, other devices, including this Raspberry PI, are perfectly happy with the Ethernet except for these two quirks.


----- Below is the log of my PING issue including fixing it ----

Code: Select all

[email protected]:~ $ wget http://tarpn.net/2015oct/tarpn_start1.sh
--2016-03-04 13:45:17--  http://tarpn.net/2015oct/tarpn_start1.sh
Resolving tarpn.net (tarpn.net)... failed: Name or service not known.
wget: unable to resolve host address ‘tarpn.net’
[email protected]:~ $ uptime
 13:45:54 up 1 min,  3 users,  load average: 0.19, 0.15, 0.06
[email protected]:~ $ ping 8.8.8.8
ping: icmp open socket: Operation not permitted
[email protected]:~ $ ifconfig
eth0      Link encap:Ethernet  HWaddr b8:27:eb:f8:b8:78  
          inet addr:10.0.0.10  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::4ce2:4cde:c5d1:1df8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1796 errors:0 dropped:0 overruns:0 frame:0
          TX packets:277 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:100720 (98.3 KiB)  TX bytes:35413 (34.5 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:192 errors:0 dropped:0 overruns:0 frame:0
          TX packets:192 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:15552 (15.1 KiB)  TX bytes:15552 (15.1 KiB)

[email protected]:~ $ ping 10.0.0.1
ping: icmp open socket: Operation not permitted
[email protected]:~ $ ping
Usage: ping [-aAbBdDfhLnOqrRUvV] [-c count] [-i interval] [-I interface]
            [-m mark] [-M pmtudisc_option] [-l preload] [-p pattern] [-Q tos]
            [-s packetsize] [-S sndbuf] [-t ttl] [-T timestamp_option]
            [-w deadline] [-W timeout] [hop1 ...] destination
[email protected]:~ $ ping 127.0.0.1
ping: icmp open socket: Operation not permitted
[email protected]:~ $ sudo reboot
Connection to 10.0.0.10 closed by remote host.
Connection to 10.0.0.10 closed.
Octopussy:~ tadd$ ssh [email protected]
[email protected]'s password: 

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Fri Mar  4 13:47:49 2016
[email protected]:~ $ ping 8.8.8.8
ping: icmp open socket: Operation not permitted
[email protected]:~ $ ls -l 'which ping'
ls: cannot access which ping: No such file or directory
pi[email protected]:~ $ cd /bin
[email protected]:/bin $ ls
bash          dmesg          lessecho        netcat            red                             tempfile
bunzip2       dnsdomainname  lessfile        netstat           rm                              touch
bzcat         domainname     lesskey         nisdomainname     rmdir                           true
bzcmp         dumpkeys       lesspipe        ntfs-3g           rnano                           udevadm
bzdiff        echo           ln              ntfs-3g.probe     run-parts                       ulockmgr_server
bzegrep       ed             loadkeys        ntfs-3g.secaudit  sed                             umount
bzexe         egrep          login           ntfs-3g.usermap   setfacl                         uname
bzfgrep       false          loginctl        ntfscat           setfont                         uncompress
bzgrep        fbset          lowntfs-3g      ntfscluster       setupcon                        unicode_start
bzip2         fgconsole      ls              ntfscmp           sh                              vdir
bzip2recover  fgrep          lsblk           ntfsfallocate     sh.distrib                      wdctl
bzless        findmnt        lsmod           ntfsfix           sleep                           which
bzmore        fuser          machinectl      ntfsinfo          ss                              ypdomainname
cat           fusermount     mkdir           ntfsls            stty                            zcat
chacl         getfacl        mknod           ntfsmove          su                              zcmp
chgrp         grep           mktemp          ntfstruncate      sync                            zdiff
chmod         gunzip         modeline2fb     ntfswipe          systemctl                       zegrep
chown         gzexe          more            open              systemd                         zfgrep
chvt          gzip           mount           openvt            systemd-ask-password            zforce
con2fbmap     hciconfig      mountpoint      pidof             systemd-escape                  zgrep
cp            hostname       mt              ping              systemd-inhibit                 zless
cpio          ip             mt-gnu          ping6             systemd-machine-id-setup        zmore
dash          journalctl     mv              plymouth          systemd-notify                  znew
date          kbd_mode       nano            ps                systemd-tmpfiles
dd            kill           nc              pwd               systemd-tty-ask-password-agent
df            kmod           nc.openbsd      rbash             tailf
dir           less           nc.traditional  readlink          tar
[email protected]:/bin $ ls -l ping
-rwxr-xr-x 1 root root 38844 Feb 12  2014 ping
[email protected]:/bin $ ./ping 8.8.8.8
ping: icmp open socket: Operation not permitted
[email protected]:/bin $ sudo chmod u+s ping
[email protected]:/bin $ ls -l ping
-rwsr-xr-x 1 root root 38844 Feb 12  2014 ping
[email protected]:/bin $ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=52 time=31.1 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=52 time=38.4 ms
^C
--- 8.8.8.8 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 31.139/34.804/38.470/3.670 ms
[email protected]:/bin $ cd ~
[email protected]:~ $ wget http://tarpn.net/2015oct/tarpn_start1.sh
--2016-03-04 13:51:45--  http://tarpn.net/2015oct/tarpn_start1.sh
Resolving tarpn.net (tarpn.net)... 107.180.13.247
Connecting to tarpn.net (tarpn.net)|107.180.13.247|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 6113 (6.0K) [application/x-sh]
Saving to: ‘tarpn_start1.sh’

tarpn_start1.sh              100%[===============================================>]   5.97K  --.-KB/s   in 0s

Return to “Troubleshooting”