User avatar
Mettauk
Posts: 238
Joined: Mon Dec 10, 2012 12:40 pm
Location: Zarg

Pi 3 & disable_camera_led=1 = cam crash

Wed Mar 02, 2016 12:18 am

Testing out RPi Cam on the Pi3 and if I put

Code: Select all

disable_camera_led=1
within /boot/config.txt it causes the camera to fail in the RPi software.

Running Jessie with latest update & dist-upgrade as at 23.30 on 1 Mar 2016.
As humans we have been the same for a very very long time, technology changes how we do... not who we are as people.

tvjon
Posts: 715
Joined: Mon Jan 07, 2013 9:11 am

Re: Pi 3 & disable_camera_led=1 = cam crash

Wed Mar 02, 2016 8:58 am

Confirmed there's a problem.

Mine doesn't crash, just comes up with the usual problem error messages.

I'll post a link to this from the Q&A thread, as someone has a camera problem.

l_k3
Posts: 7
Joined: Tue Mar 01, 2016 11:05 pm

Re: Pi 3 & disable_camera_led=1 = cam crash

Wed Mar 02, 2016 10:47 am

Yesterday i reported a crash issue:
viewtopic.php?f=63&t=137932&p=917740&hi ... ra#p917740

I have set disable_camera_led=1 in my /boot/config.txt also.
When i am back at home this afternoon i will test if it works when the led parameter is not set in the config.txt

l_k3
Posts: 7
Joined: Tue Mar 01, 2016 11:05 pm

Re: Pi 3 & disable_camera_led=1 = cam crash

Wed Mar 02, 2016 6:33 pm

Just testet it and removed the line in my config.txt. The pi cam is working. Seems to be a Software BUG. Maybe GPIO related, due the cam led is controlled by a GPIO pin.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6084
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Pi 3 & disable_camera_led=1 = cam crash

Wed Mar 02, 2016 7:16 pm

Do you have firmware it works with? Because I've seen posts saying that it only happens on fake ebay clones.

gordon77
Posts: 4298
Joined: Sun Aug 05, 2012 3:12 pm

Re: Pi 3 & disable_camera_led=1 = cam crash

Wed Mar 02, 2016 7:19 pm

ShiftPlusOne wrote:Do you have firmware it works with? Because I've seen posts saying that it only happens on fake ebay clones.
I have a genuine pi camera, and the latest download of Jessie and it says it can't find the camera if you set it.

If this is the thread you refer to viewtopic.php?f=43&t=138290&p=917854#p917854
6by6 didn't say only clone cameras.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6084
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Pi 3 & disable_camera_led=1 = cam crash

Wed Mar 02, 2016 7:21 pm

Alright, I'll try it tomorrow.

l_k3
Posts: 7
Joined: Tue Mar 01, 2016 11:05 pm

Re: Pi 3 & disable_camera_led=1 = cam crash

Wed Mar 02, 2016 8:18 pm

All software/firmware i installed is from official raspberrypi/rasbian mirrors.
My PI3 and camera module was purchased from watterott.com (distributor of Farnell) and so it is also a genuine module and pi.
But i remember that i had a similar issue with the PI2 when it came out last year. And my
research ended up in some software related GPIO things, which were fixed a
couple of days later...
Last edited by l_k3 on Wed Mar 02, 2016 8:26 pm, edited 2 times in total.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6084
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Pi 3 & disable_camera_led=1 = cam crash

Wed Mar 02, 2016 8:22 pm

I don't know who watterott.com are. Are they a distributor of farnell or rs? If not, the camera may very well be a clone.

l_k3
Posts: 7
Joined: Tue Mar 01, 2016 11:05 pm

Re: Pi 3 & disable_camera_led=1 = cam crash

Wed Mar 02, 2016 8:27 pm

ShiftPlusOne wrote:Don't know who watterott.com are? Are they a distributor of farnell or rs? If not, the camera may very well be a clone.
I edited my post, they are a distributor of Farnell.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6084
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Pi 3 & disable_camera_led=1 = cam crash

Wed Mar 02, 2016 8:30 pm

Thanks, I will take a look.

ShiftPlusOne
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 6084
Joined: Fri Jul 29, 2011 5:36 pm
Location: The unfashionable end of the western spiral arm of the Galaxy

Re: Pi 3 & disable_camera_led=1 = cam crash

Thu Mar 03, 2016 10:04 am

Looks like 6by9 is already on it. viewtopic.php?f=43&t=138290&view=unread#p918523

Return to “Troubleshooting”