Barbieboy
Posts: 5
Joined: Mon Feb 08, 2016 10:03 pm
Location: london

HDMI only black screen

Fri Feb 12, 2016 7:19 pm

Hello, getting just black via HDMI, been into to config and it says to 'uncomment' the problem. I deleted the line and no difference, guess I wasn't supposed to do that and can no longer paste it back in :/

Help !

Pi 2 / Raspbian / NOOBS / 7" Official screen
Pi 2 / NOOBs 1.7 / Raspbian / 7" Screen / J.River Media Center 20 / ifi Micro iDAC-2 / HDMI out to projector

beta-tester
Posts: 1249
Joined: Fri Jan 04, 2013 1:57 pm
Location: de_DE

Re: HDMI only black screen

Fri Feb 12, 2016 7:56 pm

Barbieboy wrote:Hello, getting just black via HDMI, been into to config and it says to 'uncomment' the problem. I deleted the line and no difference, guess I wasn't supposed to do that and can no longer paste it back in :/

Help !

Pi 2 / Raspbian / NOOBS / 7" Official screen
those are the common config.txt options to work for most of the HDMI TV's

Code: Select all

hdmi_force_hotplug=1
config_hdmi_boost=4
hdmi_drive=2
but i don't know if it is applicable for 7" official screen.
do you have the problems just at booting (even no NOOBS screen) or only in Raspbian?
do you use the newest NOOBS 1.7.0? (or an old one that does not support official 7" screen)
{ I only give negative feedback }
RPi B (rev1, 256MB), B (rev2, 512MB), B+, 2B, 3B, 3B+, ZeroW, 4B (4GB), ...

Barbieboy
Posts: 5
Joined: Mon Feb 08, 2016 10:03 pm
Location: london

Re: HDMI only black screen

Sat Feb 13, 2016 12:27 pm

Thanks for pointing out there is a newer NOOBS :) Have installed that and makes no difference. 7" screen works fine apart from the black borders. HDMI still a black blank

Pi 2 / NOOBs 1.7 / Raspbian / 7" Screen / J.River Media Center 20 / ifi Micro iDAC-2
Pi 2 / NOOBs 1.7 / Raspbian / 7" Screen / J.River Media Center 20 / ifi Micro iDAC-2 / HDMI out to projector

beta-tester
Posts: 1249
Joined: Fri Jan 04, 2013 1:57 pm
Location: de_DE

Re: HDMI only black screen

Sat Feb 13, 2016 1:16 pm

Barbieboy wrote:Thanks for pointing out there is a newer NOOBS :) Have installed that and makes no difference. 7" screen works fine apart from the black borders. HDMI still a black blank
disable_overscan=1
Pi 2 / NOOBs 1.7 / Raspbian / 7" Screen / J.River Media Center 20 / ifi Micro iDAC-2
to disable the overscan (black borders), add to your config.txt

Code: Select all

disable_overscan=1
for the dual display, see dual display usage
{ I only give negative feedback }
RPi B (rev1, 256MB), B (rev2, 512MB), B+, 2B, 3B, 3B+, ZeroW, 4B (4GB), ...

Barbieboy
Posts: 5
Joined: Mon Feb 08, 2016 10:03 pm
Location: london

Re: HDMI only black screen

Sat Feb 13, 2016 7:56 pm

Thanks, I put that code in, but black borders are still there
Pi 2 / NOOBs 1.7 / Raspbian / 7" Screen / J.River Media Center 20 / ifi Micro iDAC-2 / HDMI out to projector

fruitoftheloom
Posts: 21056
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: HDMI only black screen

Sat Feb 13, 2016 8:18 pm

Barbieboy wrote:Thanks, I put that code in, but black borders are still there
NOOBS has an editor for config.text

https://github.com/raspberrypi/noobs/bl ... /README.md
Retired disgracefully.....
This at present is my daily "computer" https://www.asus.com/us/Chrome-Devices/Chromebit-CS10/

Spookywatson
Posts: 3
Joined: Sat Feb 13, 2016 8:19 pm

Re: HDMI only black screen

Sat Feb 13, 2016 8:45 pm

I suggest taking these actions
1. are both green and red light on and not flashing because if they are the os has not installed right reinstall it
2. change the hdmi cable it might be the problem
3. try a different tv or monitor because the tv/monitor might not be liking the resolution
if none of those help then i dont know what to say sorry :|

Return to “Troubleshooting”