MrEngman
Posts: 3849
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Sat Sep 10, 2016 9:04 am

amq wrote:Sorry, I am being unclear. I meant:

Drivers for

Linux osmc 4.4.16-4-osmc #1 SMP PREEMPT Fri Aug 26 00:22:10 UTC 2016 armv7l GNU/Linux

When I wrote 4.4.16 drivers. Or would this just be the same as the 4.4.13.v1 ones that I downloaded from you and depmod'ed?
OK. Understand now.

I would be rather surprised if my 4.4.13 driver is working with 4.4.16. It seems that osmc already includes several Realtek drivers including the 8812au driver so you may be using the driver included in the osmc image and not my driver. Depends on how you installed it and the wifi module you are using.

You could try command modinfo 8812au | grep v4 and see what it shows. The driver included with osmc is version v4.2.2_7502.20130517 and my driver is version v4.3.14_13455.20150212_BTCOEX20150128-51.

One thing that can help stop the wifi going down is disabling power management. For the 8812au driver create a file /etc/modprobe.d/8812au.conf and add the line

Code: Select all

options 8812au rtw_power_mgnt=0 rtw_enusbss=0


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

amq
Posts: 4
Joined: Fri Sep 09, 2016 6:01 pm

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Sat Sep 10, 2016 9:18 am

Well I guess I was rather persistent when I installed the driver ;-)

version: v4.3.14_13455.20150212_BTCOEX20150128-51

I backed up my old 8812ac, copied over yours and depmod -a'd

Anyway it does indeed work on the osmc 4.4.16 kernel...

I'll edit the settings and disable power management accords to your suggestion.

Thanks for the help!

killergames156
Posts: 2
Joined: Wed Aug 31, 2016 5:00 pm

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Sun Sep 11, 2016 5:37 pm

Hello , I need a driver for 8812ac raspberry mam new OS on a PC but has a different kernel here is information
Linux Kali 4.1.19-v7 #1

MrEngman
Posts: 3849
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Mon Nov 07, 2016 9:55 pm

killergames156 wrote:Hello , I need a driver for 8812ac raspberry mam new OS on a PC but has a different kernel here is information
Linux Kali 4.1.19-v7 #1
To download and install the 8812au driver try this

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/8812au-4.1.19-v7-kali.tar.gz
tar xzf 8812au-4.1.19-v7-kali.tar.gz
./install.sh
After command ./install.sh you should reboot the Pi.

I have not tried this driver myself with Kali but I would expect it to work as I use the same source for Raspbian which is similar to the Kali kernel.



MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

randyf1965
Posts: 2
Joined: Tue Aug 14, 2012 9:29 pm

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Wed Nov 16, 2016 1:17 am

Your current kernel revision = 4.4.27-2-osmc+
Your current kernel build = #1

Checking for a wifi module to determine the driver to install.

Your wifi module is Bus 001 Device 003: ID 7392:a812 Edimax Technology Co., Ltd

And it uses the 8812au driver.

Checking for a new 8812au wifi driver module for your current kernel.
A driver does not yet exist for this update.


My wifi adapter drops out every 3-5 minutes. Running bmon I see a large 30+ second gap in Rx data.

modinfo 8812au | grep v4
version: v4.2.2_7502.20130517

MrEngman
Posts: 3849
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Wed Nov 16, 2016 9:29 pm

randyf1965 wrote:Your current kernel revision = 4.4.27-2-osmc+
Your current kernel build = #1

Checking for a wifi module to determine the driver to install.

Your wifi module is Bus 001 Device 003: ID 7392:a812 Edimax Technology Co., Ltd

And it uses the 8812au driver.

Checking for a new 8812au wifi driver module for your current kernel.
A driver does not yet exist for this update.


My wifi adapter drops out every 3-5 minutes. Running bmon I see a large 30+ second gap in Rx data.

modinfo 8812au | grep v4
version: v4.2.2_7502.20130517
The script you are trying to use to install the 8812au driver is for use with Raspbian. I generally only compile drivers for Raspbian and don't have one for OSMC.

I tried OSMC myself earlier today using image 4.4.27-2-osmc and found no problems using the 8812au driver included in the image. However, one thing I did was create a file that disables power management on the 8812au driver.

You could try this and see if it makes any difference. Create a file /etc/modprobe.d/8812au.conf as an example using command

Code: Select all

sudo nano /etc/modprobe.d/8812au.conf
and add the line

Code: Select all

options 8812au rtw_power_mgnt=0 rtw_enusbss=0
I tried on a Pi 3B so I also disable the built in Broadcom wifi by including the line

Code: Select all

blacklist brcmfmac
as the first line in the /etc/modprobe.d/8812au.conf file. After creating the 8812au.conf file you will need to reboot to make it active.



MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

xphoto
Posts: 4
Joined: Thu Apr 16, 2015 7:16 pm

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Mon Nov 21, 2016 10:00 pm

Thanks MrEngman !
It worked for me with the https://dl.dropboxusercontent.com/u/802 ... 858.tar.gz version :D
I just updated my Pi2 from 3.x to 4.1.19
took your file, install, had to remove the "rtw_enusbss=0"
run :
ifdown wlan0
ifup wlan0
and now it's connected to the already saved wifi network :)

I'm using a DLInk dongle:
Bus 001 Device 004: ID 2001:3314 D-Link Corp.

MrEngman
Posts: 3849
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Mon Nov 21, 2016 10:28 pm

xphoto wrote:Thanks MrEngman !
It worked for me with the https://dl.dropboxusercontent.com/u/802 ... 858.tar.gz version :D
I just updated my Pi2 from 3.x to 4.1.19
took your file, install, had to remove the "rtw_enusbss=0"
run :
ifdown wlan0
ifup wlan0
and now it's connected to the already saved wifi network :)

I'm using a DLInk dongle:
Bus 001 Device 004: ID 2001:3314 D-Link Corp.
Glad to be able to help. However, why did you need to remove rtw_enusbss=0?

I use this in the conf file for all the different Realtek wifi modules I have, and have for several years now, and have no problems with it.



MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

kishandamani
Posts: 2
Joined: Wed Dec 14, 2016 6:52 am

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Thu Dec 29, 2016 7:22 am

Hi ,
I have installed raspbian on pi2 .
"uname -r" gives the following output : 4.4.34-v7+(kernal version)

I need a wifi driver for my following device :
Equipment : AC600 Wi-Fi Dual-Band USB Adapter
Model No : EW-7811UTC

Please help

Regards,
Kishan

MrEngman
Posts: 3849
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Thu Dec 29, 2016 11:53 am

kishandamani wrote:Hi ,
I have installed raspbian on pi2 .
"uname -r" gives the following output : 4.4.34-v7+(kernal version)

I need a wifi driver for my following device :
Equipment : AC600 Wi-Fi Dual-Band USB Adapter
Model No : EW-7811UTC

Please help

Regards,
Kishan
You can download and install the driver using commands

Code: Select all

wget https://dl.dropboxusercontent.com/u/80256631/8812au-4.4.34-v7-930.tar.gz
tar xzf 8812au-4.4.34-v7-930.tar.gz
./install.sh
if you are using Raspbian OS.

And FYI use command uname -a when showing your kernel version.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

imadaily
Posts: 12
Joined: Wed Mar 02, 2016 2:29 am

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Wed Jan 04, 2017 2:56 am

MrE
First of all thanks for your work on the install script that identifies and downloads the correct driver, it has worked well for me on a couple of pis.

I do however now have a problem on a Pi3B after installing the drivers.
I had previously set the internal WiFi (wlan0) up into AP mode according to:
https://frillip.com/using-your-raspberr ... h-hostapd/

I also wanted to install an Edimax 7811utc dongle as well as the internal wifi (for use on 5ghz), I plugged this in and used your script to load the driver.
Since rebooting the internal WiFi has disappeared

ifconfig -a shows only eth0, lo, and wlan0 (now the edimax dongle)

unplugging the wifi dongle and rebooting gives only eth0 and lo

Code: Select all

~ $ lsmod
Module                  Size  Used by
bnep                   10340  2
hci_uart               17943  1
btbcm                   5929  1 hci_uart
bluetooth             326105  22 bnep,btbcm,hci_uart
snd_bcm2835            20447  1
snd_pcm                75762  1 snd_bcm2835
snd_timer              19288  1 snd_pcm
snd                    51908  5 snd_bcm2835,snd_timer,snd_pcm
bcm2835_gpiomem         3040  0
bcm2835_wdt             3225  0
8812au               1673762  0
cfg80211              427855  1 8812au
rfkill                 16037  5 cfg80211,bluetooth
uio_pdrv_genirq         3164  0
uio                     8000  1 uio_pdrv_genirq
i2c_bcm2708             4834  0
i2c_dev                 5859  0
fuse                   84037  3
ipv6                  347594  58
8812au is the edimax driver and i think cfg80211 is the intergrated wifi driver so i don't really see where the problem is...

Any suggestions on where this may have gone wrong would be great!

MrEngman
Posts: 3849
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Wed Jan 04, 2017 9:13 am

imadaily wrote:MrE
First of all thanks for your work on the install script that identifies and downloads the correct driver, it has worked well for me on a couple of pis.

I do however now have a problem on a Pi3B after installing the drivers.
I had previously set the internal WiFi (wlan0) up into AP mode according to:
https://frillip.com/using-your-raspberr ... h-hostapd/

I also wanted to install an Edimax 7811utc dongle as well as the internal wifi (for use on 5ghz), I plugged this in and used your script to load the driver.
Since rebooting the internal WiFi has disappeared

ifconfig -a shows only eth0, lo, and wlan0 (now the edimax dongle)

unplugging the wifi dongle and rebooting gives only eth0 and lo

Code: Select all

~ $ lsmod
Module                  Size  Used by
bnep                   10340  2
hci_uart               17943  1
btbcm                   5929  1 hci_uart
bluetooth             326105  22 bnep,btbcm,hci_uart
snd_bcm2835            20447  1
snd_pcm                75762  1 snd_bcm2835
snd_timer              19288  1 snd_pcm
snd                    51908  5 snd_bcm2835,snd_timer,snd_pcm
bcm2835_gpiomem         3040  0
bcm2835_wdt             3225  0
8812au               1673762  0
cfg80211              427855  1 8812au
rfkill                 16037  5 cfg80211,bluetooth
uio_pdrv_genirq         3164  0
uio                     8000  1 uio_pdrv_genirq
i2c_bcm2708             4834  0
i2c_dev                 5859  0
fuse                   84037  3
ipv6                  347594  58
8812au is the edimax driver and i think cfg80211 is the intergrated wifi driver so i don't really see where the problem is...

Any suggestions on where this may have gone wrong would be great!
Probably an issue with the file /etc/modprobe.d/8812au.conf. Check the file and see if there is a line

Code: Select all

blacklist brcmfmac
which will disable the built in wifi. If there is either comment out or delete the line.



MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

imadaily
Posts: 12
Joined: Wed Mar 02, 2016 2:29 am

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Wed Jan 04, 2017 4:21 pm

I removed that line and it's all working well, many thanks

dani12345
Posts: 1
Joined: Wed Feb 22, 2017 5:16 pm

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Wed Feb 22, 2017 5:28 pm

Hola,

Me gustaría poder bajar el Kernel de la Raspberry pi 3. Actualmente mi Kernel es 4.1.19-v7+.
Quisiera tener un Kernel 3.19.0 para instalar unos drivers de un adaptador, como podría bajarlo?

lenin1928
Posts: 3
Joined: Tue Mar 14, 2017 5:25 am

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Tue Mar 14, 2017 5:29 am

Linux raspberrypi 4.9.13-v7+ #974

hello is there a driver out for this kernel yet? edimax 7822ulc

MrEngman
Posts: 3849
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Tue Mar 14, 2017 10:48 am

lenin1928 wrote:Linux raspberrypi 4.9.13-v7+ #974

hello is there a driver out for this kernel yet? edimax 7822ulc
Don't know. What driver does it use as I've not seen that wifi mentioned before. What is the driver it uses and what is it's USB ID?


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

lenin1928
Posts: 3
Joined: Tue Mar 14, 2017 5:25 am

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Tue Mar 14, 2017 6:59 pm

MrEngman wrote:
lenin1928 wrote:Linux raspberrypi 4.9.13-v7+ #974

hello is there a driver out for this kernel yet? edimax 7822ulc
Don't know. What driver does it use as I've not seen that wifi mentioned before. What is the driver it uses and what is it's USB ID?


MrEngman
Edimax 7392:b822
Correct model number on edimax's website is EW-7822ULC
I can't find a specific driver for that particular model. I'm guessing it would use 7811's driver since it's similar.

MrEngman
Posts: 3849
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Tue Mar 14, 2017 10:24 pm

lenin1928 wrote:
MrEngman wrote:
lenin1928 wrote:Linux raspberrypi 4.9.13-v7+ #974

hello is there a driver out for this kernel yet? edimax 7822ulc
Don't know. What driver does it use as I've not seen that wifi mentioned before. What is the driver it uses and what is it's USB ID?


MrEngman
Edimax 7392:b822
Correct model number on edimax's website is EW-7822ULC
I can't find a specific driver for that particular model. I'm guessing it would use 7811's driver since it's similar.
Well, there are a number of wifi modules which include 7822 in the name and they use a variety of different drivers as do devices with 7811 in the name. So trying to guess the driver to use is not much help.

I've spent some time searching on the internet and cannot find any reference to a Linux driver.

I could add the USB code to the driver used by the EW-7811UTC but whether it will work or not I have no idea.



MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

MrEngman
Posts: 3849
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Tue Mar 14, 2017 10:52 pm

Finally found some info on the chip used in the EW-7822ULC so it may help find the driver. Found the info here https://www.reichelt.de/WLAN-Adapter/ED ... ARCH=%252A

Chip set is MT7621A + MT7615E whatever they are as I've not seen these specified before.

No idea what driver can be used other than perhaps mt7621a if there is such a thing.



MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

lenin1928
Posts: 3
Joined: Tue Mar 14, 2017 5:25 am

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Wed Mar 15, 2017 4:11 am

MrEngman wrote:Finally found some info on the chip used in the EW-7822ULC so it may help find the driver. Found the info here https://www.reichelt.de/WLAN-Adapter/ED ... ARCH=%252A

Chip set is MT7621A + MT7615E whatever they are as I've not seen these specified before.

No idea what driver can be used other than perhaps mt7621a if there is such a thing.



MrEngman
Disappointed to hear that. It had quite a bit advanced features. Just assumed the compatibility would be similar to the 7811. Appreciate that you looked into it.

chipper
Posts: 1
Joined: Thu Mar 16, 2017 3:50 am

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Thu Mar 16, 2017 3:52 am

Any chance of a module build for the following kernel happening soon?

Linux CDC-PI1 4.9.14-v7+ #977 SMP Mon Mar 13 18:25:19 GMT 2017 armv7l GNU/Linux
Your wifi module is Bus 001 Device 004: ID 7392:a812 Edimax Technology Co., Ltd

Thanks,
Chipper
Last edited by chipper on Thu Mar 16, 2017 2:09 pm, edited 1 time in total.

MrEngman
Posts: 3849
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Thu Mar 16, 2017 1:17 pm

chipper wrote:Any chance of a module build for the following kernel happening soon?

Linux CDC-PI1 4.9.14-v7+ #977 SMP Mon Mar 13 18:25:19 GMT 2017 armv7l GNU/Linux

Thanks,
Chipper
The file is available. Dropbox have made changes to their web site which now makes it impossible to easily download files using wget so I have had to move the files to a new site.

You can install a new script to handle the changes using commands

Code: Select all

sudo wget http://www.fars-robotics.net/install-wifi -O /usr/bin/install-wifi
sudo chmod +x /usr/bin/install-wifi
Use command

Code: Select all

sudo install-wifi -h
to see the info on how you can use the script.

Running command

Code: Select all

sudo install-wifi
should automatically select the right driver you need for the kernel you are currently running and download and install it.



MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

cdclawson
Posts: 4
Joined: Mon Apr 24, 2017 5:17 pm

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Mon Apr 24, 2017 5:28 pm

MrEngman wrote:
lenin1928 wrote:
MrEngman wrote: Don't know. What driver does it use as I've not seen that wifi mentioned before. What is the driver it uses and what is it's USB ID?


MrEngman
Edimax 7392:b822
Correct model number on edimax's website is EW-7822ULC
I can't find a specific driver for that particular model. I'm guessing it would use 7811's driver since it's similar.
Well, there are a number of wifi modules which include 7822 in the name and they use a variety of different drivers as do devices with 7811 in the name. So trying to guess the driver to use is not much help.

I've spent some time searching on the internet and cannot find any reference to a Linux driver.

I could add the USB code to the driver used by the EW-7811UTC but whether it will work or not I have no idea.



MrEngman
I contacted Edimax and they said it uses a Realtek RTL8822BU chipset. From what I can tell, the Windows driver supports both the 8812AU and 8822BU chipsets. So maybe it would work?

cdclawson
Posts: 4
Joined: Mon Apr 24, 2017 5:17 pm

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Mon Apr 24, 2017 6:52 pm

Okay, I tried editing os_dep/linux/usb_intf.c and adding the 7392:B822 ID to the end of the RTL8812A section (line 360?), recompiled and installed the driver. cfg80211 picked it up.

lsmod output:

Code: Select all

Module                  Size  Used by
8812au               1600099  0 
bnep                   10340  2 
hci_uart               17943  1 
btbcm                   5929  1 hci_uart
bluetooth             326105  22 bnep,btbcm,hci_uart
ip6table_filter         1349  0 
ip6table_mangle         1586  0 
ip6table_nat            1713  0 
nf_conntrack_ipv6       7858  1 
nf_defrag_ipv6         14848  1 nf_conntrack_ipv6
nf_nat_ipv6             5256  1 ip6table_nat
ip6_tables             11701  3 ip6table_filter,ip6table_mangle,ip6table_nat
iptable_filter          1409  0 
iptable_mangle          1454  0 
iptable_nat             1725  0 
nf_conntrack_ipv4      12912  1 
nf_defrag_ipv4          1428  1 nf_conntrack_ipv4
nf_nat_ipv4             4992  1 iptable_nat
nf_nat                 12375  2 nf_nat_ipv4,nf_nat_ipv6
nf_conntrack           77460  5 nf_nat,nf_nat_ipv4,nf_nat_ipv6,nf_conntrack_ipv4,nf_conntrack_ipv6
ip_tables              11445  3 iptable_filter,iptable_mangle,iptable_nat
x_tables               13165  6 ip6table_filter,ip6table_mangle,ip_tables,iptable_filter,iptable_mangle,ip6_tables
brcmfmac              186403  0 
brcmutil                5661  1 brcmfmac
cfg80211              428871  2 brcmfmac,8812au
rfkill                 16037  4 cfg80211,bluetooth
snd_bcm2835            20447  2 
snd_pcm                75762  1 snd_bcm2835
snd_timer              19288  1 snd_pcm
snd                    51908  7 snd_bcm2835,snd_timer,snd_pcm
bcm2835_gpiomem         2976  0 
spi_bcm2835             6678  0 
i2c_bcm2708             4834  0 
bcm2835_wdt             3225  0 
uio_pdrv_genirq         3164  0 
uio                     8000  1 uio_pdrv_genirq
i2c_dev                 5859  0 
fuse                   84037  3 
ipv6                  347620  90 ip6table_mangle,nf_defrag_ipv6,nf_nat_ipv6,nf_conntrack_ipv6
dmesg output:

Code: Select all

[ 2403.708365] usb 1-1.4: new high-speed USB device number 4 using dwc_otg
[ 2403.809436] usb 1-1.4: New USB device found, idVendor=7392, idProduct=b822
[ 2403.809457] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2403.809470] usb 1-1.4: Product: AC1200 MU-MIMO USB2.0 Adapter
[ 2403.809482] usb 1-1.4: Manufacturer: Realtek
[ 2403.809495] usb 1-1.4: SerialNumber: 123456
[ 2404.967902] RTL871X: module init start
[ 2404.967935] RTL871X: rtl8821au v4.3.14
[ 2404.967949] RTL871X: rtl8821au BT-Coex version = BTCOEX20150128-51
[ 2404.984554] RTL871X: invalid offset:0x42 
[ 2405.096447] RTL871X: invalid offset:0x40 
[ 2405.141310] RTL871X: rtw_ndev_init(wlan1)
[ 2405.142383] usbcore: registered new interface driver rtl8821au
[ 2405.142396] RTL871X: module init ret=0
However, it doesn't actually seem to work. Trying to scan returns the error:

Code: Select all

[email protected]:~ $ sudo iw dev wlan1 scan
command failed: Network is down (-100)
But scanning does work for the built-in wifi. I'm at a loss here. Would it be worthwhile to try loading a Windows driver?

MrEngman
Posts: 3849
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: Edimax EW-7811UTC WIFIAC NOT WORKING

Mon Apr 24, 2017 7:00 pm

cdclawson wrote:Okay, I tried editing os_dep/linux/usb_intf.c and adding the 7392:B822 ID to the end of the RTL8812A section (line 360?), recompiled and installed the driver. cfg80211 picked it up.

lsmod output:

Code: Select all

Module                  Size  Used by
8812au               1600099  0 
bnep                   10340  2 
hci_uart               17943  1 
btbcm                   5929  1 hci_uart
bluetooth             326105  22 bnep,btbcm,hci_uart
ip6table_filter         1349  0 
ip6table_mangle         1586  0 
ip6table_nat            1713  0 
nf_conntrack_ipv6       7858  1 
nf_defrag_ipv6         14848  1 nf_conntrack_ipv6
nf_nat_ipv6             5256  1 ip6table_nat
ip6_tables             11701  3 ip6table_filter,ip6table_mangle,ip6table_nat
iptable_filter          1409  0 
iptable_mangle          1454  0 
iptable_nat             1725  0 
nf_conntrack_ipv4      12912  1 
nf_defrag_ipv4          1428  1 nf_conntrack_ipv4
nf_nat_ipv4             4992  1 iptable_nat
nf_nat                 12375  2 nf_nat_ipv4,nf_nat_ipv6
nf_conntrack           77460  5 nf_nat,nf_nat_ipv4,nf_nat_ipv6,nf_conntrack_ipv4,nf_conntrack_ipv6
ip_tables              11445  3 iptable_filter,iptable_mangle,iptable_nat
x_tables               13165  6 ip6table_filter,ip6table_mangle,ip_tables,iptable_filter,iptable_mangle,ip6_tables
brcmfmac              186403  0 
brcmutil                5661  1 brcmfmac
cfg80211              428871  2 brcmfmac,8812au
rfkill                 16037  4 cfg80211,bluetooth
snd_bcm2835            20447  2 
snd_pcm                75762  1 snd_bcm2835
snd_timer              19288  1 snd_pcm
snd                    51908  7 snd_bcm2835,snd_timer,snd_pcm
bcm2835_gpiomem         2976  0 
spi_bcm2835             6678  0 
i2c_bcm2708             4834  0 
bcm2835_wdt             3225  0 
uio_pdrv_genirq         3164  0 
uio                     8000  1 uio_pdrv_genirq
i2c_dev                 5859  0 
fuse                   84037  3 
ipv6                  347620  90 ip6table_mangle,nf_defrag_ipv6,nf_nat_ipv6,nf_conntrack_ipv6
dmesg output:

Code: Select all

[ 2403.708365] usb 1-1.4: new high-speed USB device number 4 using dwc_otg
[ 2403.809436] usb 1-1.4: New USB device found, idVendor=7392, idProduct=b822
[ 2403.809457] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2403.809470] usb 1-1.4: Product: AC1200 MU-MIMO USB2.0 Adapter
[ 2403.809482] usb 1-1.4: Manufacturer: Realtek
[ 2403.809495] usb 1-1.4: SerialNumber: 123456
[ 2404.967902] RTL871X: module init start
[ 2404.967935] RTL871X: rtl8821au v4.3.14
[ 2404.967949] RTL871X: rtl8821au BT-Coex version = BTCOEX20150128-51
[ 2404.984554] RTL871X: invalid offset:0x42 
[ 2405.096447] RTL871X: invalid offset:0x40 
[ 2405.141310] RTL871X: rtw_ndev_init(wlan1)
[ 2405.142383] usbcore: registered new interface driver rtl8821au
[ 2405.142396] RTL871X: module init ret=0
However, it doesn't actually seem to work. Trying to scan returns the error:

Code: Select all

[email protected]:~ $ sudo iw dev wlan1 scan
command failed: Network is down (-100)
But scanning does work for the built-in wifi. I'm at a loss here. Would it be worthwhile to try loading a Windows driver?
A Windows driver will not work, this is Linux.

I have found a driver for the 8822bu. What kernel version are you using so I can try and compile the version you need. The output of command

Code: Select all

uname -a
would be useful.

I won't be able to test it but will let you know when it is available to download in an hour or so after you provide the output from uname -a.


MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

Return to “Troubleshooting”