Posts: 1
Joined: Thu Jan 28, 2016 12:37 pm

Ultimate GPS not working with gpsd

Thu Jan 28, 2016 12:59 pm

I'm pretty new to the Pi and my first effort is to get the Adafruit Ultimate GPS breakout communicating with my Pi 2.

Followed instructions in the Adafruit tutorial to the letter, got a fix with no problem (red LED flashing every 15 sec) with the antenna extension placed out of the window.

Using "sudo cat /dev/ttyUSB0", I can get output from the gps and the lat/long values buried in the text strings are OK.

Installed gpsd as per instructions, but only get "No Fix" when running "cgps -s".

Tried connecting to the GPIO instead, and using "sudo cat /dev/ttyAMA0", I can get the same output, but still nothing from "cgps -s".


Posts: 92
Joined: Tue Dec 08, 2015 9:59 am
Location: El Albir - Alicante
Contact: Website

Re: Ultimate GPS not working with gpsd

Sat Jan 30, 2016 12:27 pm


I had a similar problem, got information with cat from the ttyAMA0 (cat /dev/ttyAMA0), even gps information using gpsmon /dev/ttyAMA0 but could not make gpsd working nor cgps -s receiving information.

I fixed it uninstalling the gpsd using this command:

sudo apt-get purge gpsd

Then reinstalling it fresh:

sudo apt-get install gpsd gpsd-clients python-gps

And then making sure that /etc/default/gpsd looked like this (you can edit it with sudo nano /etc/default/gpsd )


did a reboot and got it working instantly.

I hope it helps, I had realized that there was so little feedback about this while there was some many people having this same problem.

Hasta pronto,


Posts: 1
Joined: Sat Jan 30, 2016 5:45 pm

Re: Ultimate GPS not working with gpsd

Sat Jan 30, 2016 6:04 pm


thank you for your help. I had some problem with cgps. Now its work nice.

But, I would like to ask for some extra help.

I trying to log GPS coordinates to .gpx file with gpxlogger

I use command :

Code: Select all

sudo gpxlogger > /var/log/mycoord.gpx
and I still get an answer

Code: Select all

 bash: /var/log/mycoord.gpx> Permission denied
even i try a different folder. Do you have any idea where can be problem?

Posts: 5
Joined: Thu Dec 12, 2019 11:03 pm

Re: Ultimate GPS not working with gpsd

Tue Dec 17, 2019 9:54 pm

This is a reply to Screspo post to get gpamon to work change device to serial0 not ttyAMAO this worked for me after two days of nothing from my gps hat

Return to “Troubleshooting”