JOHNBOY44
Posts: 3
Joined: Wed Aug 01, 2012 8:27 am

RS232 interface logon disable

Wed Aug 01, 2012 8:45 am

Hi,
I am trying to use the RS232 I/O port to read/write from a 'C' program. Output works fine but reading data appears to be inhibited by Linux sending logon username & password messages after a CR character is entered.
Is there a way of dissabling the system logon at the ttyAMA0 port?
I have tried both Squeeze and Wheezy versions - both do this.
Thanks JOHNBOY44

User avatar
nroff-man
Posts: 23
Joined: Mon Jul 30, 2012 7:31 pm
Location: /usr/bin

Re: RS232 interface logon disable

Wed Aug 01, 2012 9:11 am

lo

look at /etc/inittab

specifically the line with getty -L ttyAMA0

read the man page for getty, look at the
-l option.

change that line to run /bin/bash
instead of login

send a HUP to PID 1 and it should work

bye

jdbennet
Posts: 96
Joined: Sun Jul 22, 2012 2:25 pm

Re: RS232 interface logon disable

Wed Aug 01, 2012 9:12 am

Remove the "console=ttyAMA0...." lines from cmdline.txt, and also remove mention of it from /etc/inittab and /etc/securetty, this will stop terminals being spawned on it.

JOHNBOY44
Posts: 3
Joined: Wed Aug 01, 2012 8:27 am

Re: RS232 interface logon disable

Sun Aug 05, 2012 1:34 pm

Thanks for your suggestions - commenting-out the getty line in /etc/initab has solved the problem for me.
JOHNBOY44

Return to “Troubleshooting”