pine
Posts: 16
Joined: Sun Jun 24, 2012 8:32 pm

Problems with OpenFrameworks and VNC

Fri Jan 01, 2016 9:36 am

I've successfully downloaded/unpacked/ complied OF on my RPi 2 with the latest Raspian Jessie image. The OF examples I have tried run just fine as long as I have an HMDI monitor connected to the Pi. If I access the Pi via VNC (I've tried tightvnc and x11vnc) then the examples launch from a terminal window, but no graphics window appears. Not good, as my application needs VNC .

Qs:

Is it a matter of getting the right VNC server - I've read most versions of VNC do not support hardware accelerated software. Is there a version that does?

If compatibility with hardware acceleration is the problem, could an alternative solution be to switch to Raspian Wheezy and OF 0.8.4 (which I believe does not use hardware acceleration?). My graphics needs are not complex, so could probably cope with a lack of hardware acceleration.

Or is the problem more fundamental? I read a comment (related to the camera preview not being seen on VNC, I think) that indicated that output from the RPi GPU only goes to the HDMI port. In which case, any form of VNC will fail.

Any thought guys, gals & gurus?

Many thanks

pine
Posts: 16
Joined: Sun Jun 24, 2012 8:32 pm

Re: Problems with OpenFrameworks and VNC

Wed Jan 06, 2016 9:46 am

Anybody ... ?

ghans
Posts: 7882
Joined: Mon Dec 12, 2011 8:30 pm
Location: Germany

Re: Problems with OpenFrameworks and VNC

Wed Jan 06, 2016 10:02 am

You can try this special VNC server :

https://github.com/hanzelpeter/dispmanx_vnc

ghans
• Don't like the board ? Missing features ? Change to the prosilver theme ! You can find it in your settings.
• Don't like to search the forum BEFORE posting 'cos it's useless ? Try googling : yoursearchtermshere site:raspberrypi.org

pine
Posts: 16
Joined: Sun Jun 24, 2012 8:32 pm

Re: Problems with OpenFrameworks and VNC

Thu Jan 07, 2016 11:58 am

Thanks, ghans. Your suggestion seems very similar to the that on https://github.com/patrikolausson/dispmanx_vnc which was suggested on an openFrameworks forum. I've tried both, but the keyboard does not seem to work with either of them, and the mouse (with two pointers!) freezes or pauses the display when running an openFrameworks example. So close!

Pine

Return to “Troubleshooting”