Highlow9
Posts: 1
Joined: Wed Dec 30, 2015 9:13 pm

Transmission daemon doesn't start on boot

Wed Dec 30, 2015 9:35 pm

Hello

When i reboot my pi (2b with raspbian) my transmission-daemon doesn't seam to start. When i try to connect via web i get this message http://i.imgur.com/J80zRgi.png . But when i enter (on the pi) 'sudo service transmission-daemon reload' it works.


Setup
Pi 2 model b
16 gb sd (fat 32)
raspbian (via noobs)
external (3tb ntfs) hard drive

Tutorials followed :
http://pimylifeup.com/raspberry-pi-torrentbox/

Trouble shooting already done :
http://raspberrypi.stackexchange.com/qu ... at-startup (this guy seams to be having the same problem as me)

User avatar
dentex
Posts: 180
Joined: Sun May 20, 2012 7:58 am
Location: Italy
Contact: Website

Re: Transmission daemon doesn't start on boot

Fri Jan 08, 2016 8:03 am

Hi, just as a reference:
https://forum.transmissionbt.com/viewto ... 605#p72605
and
https://trac.transmissionbt.com/ticket/5737

If you want an awful fix (that anyway works), do:

Code: Select all

sudo nano /etc/init.d/transmission-daemon-reload
Put inside:
#!/bin/sh
### BEGIN INIT INFO
# Provides: transmission-daemon-reload
# Required-Start: $all
# Required-Stop:
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Short-Description: Reload the transmission-daemon
# Description: Reload the transmission-daemon at boot.
### END INIT INFO

NAME=transmission-daemon-reload

sleep 10
service transmission-daemon reload
Save the init.d script and make it executable.

Then do:

Code: Select all

sudo update-rc.d transmission-daemon-reload defaults
Reboot and check it.

Basically it's just an ugly "sleep" hack.
One of my projects with the Raspberry Pi:
--------------------------------------------------------
(Raspberry) Pi Aquarium Controller: https://github.com/dentex/piac

malicious
Posts: 96
Joined: Thu Jul 24, 2014 10:07 pm
Location: USA

Re: Transmission daemon doesn't start on boot

Fri Jan 08, 2016 10:39 am

This workaround from the Arch Linux wiki may also help:

https://wiki.archlinux.org/index.php/Tr ... rt_at_boot
/etc/systemd/system/transmission.service.d/fixdep.conf:
[Unit]
Requires=network.target

User avatar
dentex
Posts: 180
Joined: Sun May 20, 2012 7:58 am
Location: Italy
Contact: Website

Re: Transmission daemon doesn't start on boot

Fri Jan 08, 2016 11:18 am

malicious wrote:This workaround from the Arch Linux wiki may also help...]
transmission-daemon's script in /etc/init.d already has Required-Start: $network in its INIT INFO header.
The problem seems that the "network is up" notification by the system it's a bit buggy: https://trac.transmissionbt.com/ticket/5737
One of my projects with the Raspberry Pi:
--------------------------------------------------------
(Raspberry) Pi Aquarium Controller: https://github.com/dentex/piac

zamus
Posts: 1
Joined: Sun Feb 10, 2019 3:35 am

Re: Transmission daemon doesn't start on boot

Sun Feb 10, 2019 3:49 am

After hours of tests i finnaly found a solution that worked for me.

I'm writting this here because may be help other people on the future.

My issue, is the transmission daemon don't autostart on boot, but if i start the service manually work well.

After reboot the command: netstat -lntp
is helpful in order to see if you have the port 9091 on the list, when works you see that port on the list, if not something else is broken.

Run this command:
sudo systemctl status transmission-daemon.service

You should see something like this this:
transmission-daemon.service - Transmission BitTorrent Daemon
Loaded: loaded (/lib/systemd/system/transmission-daemon.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2019-02-10 03:33:45 UTC; 7min ago

Probably you see the service disabled and inactive.

So do this:

Edit the file /etc/default/transmission-daemon with your favorite editor

Look for this line:
ENABLE_DAEMON=0

and change the 0 to 1

ENABLE_DAEMON=1

Save the file.

Then run:
sudo systemctl enable transmission-daemon.service

Reboot and run the
sudo systemctl status transmission-daemon.service
and look for the active (running)

and run netstat -lntp
and look for
tcp 0 0 0.0.0.0:9091 0.0.0.0:* LISTEN 834/transmission-da

That's mean the deamon auto-started on boot.

Return to “Troubleshooting”