fraschizzato
Posts: 1
Joined: Thu Dec 17, 2015 8:56 am

SNMPD issue: pcilib: Cannot open /proc/bus/pci

Thu Dec 17, 2015 9:15 am

I've tried to install SNMPD using apt but during installation and on service start/restart I receive always that error: "pcilib: Cannot open /proc/bus/pci". The daemon is not running (googling I've found that someone reported the service runs even the error appears). Following the two answers at http://stackoverflow.com/questions/9470 ... oc-bus-pci I've tried to compile (with modification and/or both patch) net-snmp-5.7.1 - 5.7.2 and 5.7.3 but without success: the error is gone but the service is still not running, even if started manually (On service start I did not receive any response). Here the steps I've made (maybe there's something wrong):
unzip net-snmp source
./configure
patch < "patch.file"
make
make install
sudo /etc/init.d/snmpd restart -or- sudo service snmpd restart
(both without response or error)
and using
ps -A | grep snmpd -or- sudo service snmpd status
i did not receive any response:
[email protected] ~ $ sudo service snmpd restart
[email protected] ~ $

Hope someone can help to get it work

User avatar
DougieLawson
Posts: 38467
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: SNMPD issue: pcilib: Cannot open /proc/bus/pci

Thu Dec 17, 2015 11:12 am

There's no such thing as a PCI bus on a raspberry (that's an Intel X86_64 thing). So you're going to need to find a configuration for snmpd that works for an ARM processor.

It's probably better to install a ready built daemon rather than trying to configure and build your own.
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

I'll do your homework for you for a suitable fee.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

njohnsn
Posts: 3
Joined: Fri May 27, 2016 3:07 pm

Re: SNMPD issue: pcilib: Cannot open /proc/bus/pci

Sun Jun 05, 2016 11:07 pm

If you specify the IPv4 address of the Pi's interface in the following line in

Code: Select all

/etc/snmp/snmpd.conf
, then stock SNMPD will start:

For example:

Code: Select all

agentAddress udp:10.0.1.4:161,udp6:[::1]:161
My guess is that without an address SNMPD tries to find all possible network interfaces, including PCI ones.

ThomasDr
Posts: 55
Joined: Tue May 20, 2014 2:16 pm

Re: SNMPD issue: pcilib: Cannot open /proc/bus/pci

Sat May 18, 2019 3:49 pm

Hello,

it looks like the PCI error is normal, the answer helped me.

regards
Thomas Dr

Return to “Troubleshooting”