Page 1 of 1

HTML code instead of web page

Posted: Wed Dec 02, 2015 6:49 pm
by ErikGBL
I have recently downloaded Raspbian and am using the included Web 3.8.2 browser. It is usually working OK, but when i load a specific address I only see the html code and not the web page. Is it a simple way to swap between html code and page view?

Re: HTML code instead of web page

Posted: Wed Dec 02, 2015 8:42 pm
by fruitoftheloom
ErikGBL wrote:I have recently downloaded Raspbian and am using the included Web 3.8.2 browser. It is usually working OK, but when i load a specific address I only see the html code and not the web page. Is it a simple way to swap between html code and page view?
What "specific address" ? does the web page load correctly in other Browsers ?

Re: HTML code instead of web page

Posted: Wed Dec 02, 2015 8:55 pm
by ErikGBL
I have installed the RaZbarry z-wave controller and want to access the http://ipaddress:8083 which should open a page page where I can select various user interfaces e.g.: Expert UI, Z-Wave Home Automation UI, etc. The IP-address was found with "find.zwave.me" which gave me 10.0.0.219, accordingly the address I am using is: http://10.0.0.219:8083

Re: HTML code instead of web page

Posted: Wed Dec 02, 2015 9:02 pm
by fruitoftheloom
ErikGBL wrote:I have installed the RaZbarry z-wave controller and want to access the http://ipaddress:8083 which should open a page page where I can select various user interfaces e.g.: Expert UI, Z-Wave Home Automation UI, etc. The IP-address was found with "find.zwave.me" which gave me 10.0.0.219, accordingly the address I am using is: http://10.0.0.219:8083
http://razberry.z-wave.me/docs/RaZberry500_QSG_en1.pdf

Re: HTML code instead of web page

Posted: Wed Dec 02, 2015 9:22 pm
by ErikGBL
Yes, I have been through everything in this documentation, but when I access the 8083-port I do not get the web page only the html code!

Re: HTML code instead of web page

Posted: Wed Dec 02, 2015 9:39 pm
by DougieLawson
Try this
wget --server-response http://10.0.0.219:8083

You should get a load of noise like

Code: Select all

[email protected]:/tmp $ wget --server-response http://10.0.0.219:8083
--2015-12-02 21:35:38--  http://10.0.0.219:8083/
HTTP request sent, awaiting response...
  HTTP/1.1 200 OK
  Server: Transmission
  Content-Type: text/html
  Date: Wed, 02 Dec 2015 21:35:38 GMT
  Expires: Thu, 03 Dec 2015 21:35:38 GMT
  Content-Length: 24342
Length: 24342 (24K) [text/html]
Saving to: ‘index.html’

index.html          100%[=====================>]  23.77K  --.-KB/s   in 0.02s

2015-12-02 21:35:39 (1.03 MB/s) - ‘index.html’ saved [24342/24342]

[email protected]:/tmp 
post your noise on here.

Re: HTML code instead of web page

Posted: Wed Dec 02, 2015 9:53 pm
by fruitoftheloom
ErikGBL wrote:Yes, I have been through everything in this documentation, but when I access the 8083-port I do not get the web page only the html code!
In the PDF it states 8084 ?

Re: HTML code instead of web page

Posted: Thu Dec 03, 2015 7:56 am
by ErikGBL
No, port 8084 is for the set-up service and all that worked OK. Please, read the last paragraph on the second page of the documentation about how to choose user interface which should be available on port 8083.

Re: HTML code instead of web page

Posted: Thu Dec 03, 2015 8:10 am
by ErikGBL
Reply to DougieLawson:
This is the server response I get:

--2015-12-03 08:57:57-- http://10.0.0.219:8083/
Connecting to 10.0.0.219:8083... connected.
HTTP request sent, awaiting response...
HTTP/1.1 200 OK
Date: Thu, 03 Dec 2015 07:57:57 GMT
Last-Modified: Wed, 02 Sep 2015 13:57:52 GMT
Etag: "55e70060.345"
Content-Type: text/html
Content-Length: 345
Connection: keep-alive
Accept-Ranges: bytes
Length: 345 [text/html]
Saving to: ‘index.html’

index.html 100%[=====================>] 345 --.-KB/s in 0s

2015-12-03 08:57:57 (5.21 MB/s) - ‘index.html’ saved [345/345]

Re: HTML code instead of web page

Posted: Thu Dec 03, 2015 10:33 am
by DougieLawson
Try using a different web browser, because your server is sending exactly the right stuff.

Re: HTML code instead of web page

Posted: Thu Dec 03, 2015 5:55 pm
by ErikGBL
Any browser you could recommend? Right now I am using Web 3.8.2 which came with my Rasbian, I think it is based on Epiphany? Btw., how can I detect what version of Rasbian I am using? (Jessie or Wheezy)

Re: HTML code instead of web page

Posted: Thu Dec 03, 2015 6:07 pm
by fruitoftheloom
ErikGBL wrote:Any browser you could recommend? Right now I am using Web 3.8.2 which came with my Rasbian, I think it is based on Epiphany? Btw., how can I detect what version of Rasbian I am using? (Jessie or Wheezy)

Code: Select all

cat /etc/os-release

Re: HTML code instead of web page

Posted: Thu Dec 03, 2015 8:31 pm
by DougieLawson
ErikGBL wrote:Any browser you could recommend? Right now I am using Web 3.8.2 which came with my Rasbian, I think it is based on Epiphany? Btw., how can I detect what version of Rasbian I am using? (Jessie or Wheezy)
Lynx in a LXterminal window.

Re: HTML code instead of web page

Posted: Thu Dec 03, 2015 10:00 pm
by DougieLawson
I think you need to consider re-installing the z-wave code.

wget -q -O - razberry.z-wave.me/install | sudo bash

Because when I tried running that it worked first go.

Re: HTML code instead of web page

Posted: Fri Dec 04, 2015 11:04 pm
by ErikGBL
Thank you for good advice, Doug. It did work with another web browser (Iceweasel). However, I also reinstalled the z-wave.me, but that did not change anything. So the present status is: Web 3.8.2 shows only html-code when I address port 8083, while Icebreaker works fine.

Re: HTML code instead of web page

Posted: Thu Jun 09, 2016 10:08 am
by egge
Hi,
I got just the same issue, I was though able to see that there was some permission issue displayed just before the page turned in to plane html code. I tried to change the settings in the default browser but there was not much to set, i.e. no success. Will try to use the Iceweasel browser to night...

/Br,
Edgar