divahar300
Posts: 1
Joined: Sat Oct 31, 2015 5:01 pm

Ethernet connection not working

Sat Oct 31, 2015 5:09 pm

Capture.JPG
Capture.JPG (40.99 KiB) Viewed 1419 times
hi all,

Recently i brought Rasp pi 2 and tried connecting headless. when i pinging raspi 2 with my pc (ping raspberrypi.mshome.net), I get request time out.
However i connected the pi to a monitor and found the ip address of pi by ifconfig. when i manually ping by entering the ip address, i get response.

Also, though I've enabled the network sharing in my wi fi settings, I am not able to use internet in my pi via my pc

help me to find a solution

User avatar
lmarmisa
Posts: 1302
Joined: Thu Feb 14, 2013 2:22 am
Location: Jávea, Spain

Re: Ethernet connection not working

Sat Oct 31, 2015 8:07 pm

Take a look to this link:

http://packetlife.net/blog/2008/sep/24/ ... explained/

Something is wrong related to DHCP there. If the IP address of your RPi is 169.254.1.104, this is not a good signal.

If the DHCP protocolo works correctly, the IP address will be something like 192.169.x.y.

I recommend to post here the outputs of these commands:

1) RPi

Code: Select all

ifconfig
route -n
2) PC

Code: Select all

ipconfig
route print -4

fiazmr
Posts: 2
Joined: Sat Mar 30, 2019 5:40 pm

Re: Ethernet connection not working

Fri Apr 19, 2019 5:29 am

Browsing through some articles I came to know that my shared ip had changed for the pi. When I do >ping raspberrypi.mshome.net on command prompt its showing request timed out. As I was working out on a small project and what this sorted out immediately I went to the network options under control panel, selected my wifi connection disabled allow sharing under properties. Enabled it again and connected the pi and got a new ip address. Then I was able to successfully connect to pi using Putty. I know this could not be a long time solution.

Return to “Troubleshooting”