Posts: 2
Joined: Thu Oct 29, 2015 4:47 pm

el capitan ssh broken

Thu Oct 29, 2015 4:54 pm

Hi I have been connecting to RPI2 no problems with my mac pro using terminal ssh pi@ worked just fine. I upgraded to El Capitan and didn't clean install so the settings should all be the same however it does not connect to the server. I checked on my other computer and it still connects fine on Yosemite. I tried ssh pi@raspberrypi.local and it worked on El Capitan the first time and I noticed it changed the ip to however I tried again the next day and now nothing is working again. Any ideas of what is going on. It still connect at on Yosemite like I said. I had it working fine on both before. So it has to be on my macs side. RPI2 is updated and should be good to go. I can use my other computer for now but I will need it working on my laptop soon and would hate to downgrade because this is the only issue so far. Thanks in advance. Cheers.

Posts: 11
Joined: Thu Oct 29, 2015 10:38 am

Re: el capitan ssh broken

Thu Oct 29, 2015 9:44 pm

just tried connecting to my pi2 from one of my Macs running el Capitan using ssh and it works just fine.

It's running el Capitan 10.11.1 which is I believe the latest patch level (should be, I only got the machine last week and did a full update of all the installed software and OS over the next several days, which including upgrading the OS from Yosemite to el Capitan).

The pi2 is running Raspbian Jessie btw.

So I can confirm that the ssh client on el Capitan works.

Are you getting any errors trying to connect? If so, what are they?

Posts: 2
Joined: Thu Oct 29, 2015 4:47 pm

Re: el capitan ssh broken

Fri Oct 30, 2015 7:16 pm

so I got it to work but it is a bit odd. I have to restart my laptop everytime to get it to work but it's a workaround I don't mind. It only connects through pi@raspberrypi.local. Well at least it is working.

Posts: 3503
Joined: Thu Dec 27, 2012 4:05 am
Location: Québec, Canada

Re: el capitan ssh broken

Fri Oct 30, 2015 11:13 pm

It is possible that it connects on IPv6.

I do have El capitan on My mac and I didn't have any problem so far except for the minimize/maximize icons which sometimes don't want to show up when I want to resize a window.

What is your /etc/network/interfaces. I think you will have to check the settings for the eth0. It could be on static mode and you won't be able to connect via IP4 but IP6 will.

When I installed the latest Jessie . I found out that my Pi wasn't connect on IPv4 but I had connection on IP6.

Return to “Troubleshooting”