mood
Posts: 6
Joined: Mon Oct 29, 2012 9:35 pm

mplayer/mpv problem with jessie

Thu Oct 15, 2015 1:02 pm

I've regularly used mplayer with wheezy to access internet radio, but having installed jessie I'm having frequent buffering interrupting the sound. This is only happening with BBC .m3u8 radio streams, and so far, not any other internet radio stations.

With wheezy and mplayer, an example is

Code: Select all

mplayer -ao alsa -playlist"http://a.files.bbci.co.uk/media/live/manifesto/audio/simulcast/hls/uk/sbr_high/ak/bbc_radio_one.m3u8"
.

An example using mpv is

Code: Select all

mpv -ao alsa -playlist  "http://a.files.bbci.co.uk/media/live/manifesto/audio/simulcast/hls/uk/sbr_high/ak/bbc_radio_one.m3u8"
. With a jessie setup, both mpv and mplayer2 result in frequent buffering.

Any ideas anyone?

gingis
Posts: 5
Joined: Sun Jul 02, 2017 10:11 am

Re: mplayer/mpv problem with jessie

Sun Jul 02, 2017 9:57 pm

i would install mpv from deb-multimedia if on jessie;

even better is to compile it on wheezy

sudo aptitude install autoconf automake libasound2-dev libegl1-mesa-dev libfontconfig-dev libfreetype6-dev libfribidi-dev libgl1-mesa-dev libgnutls-dev libtool libx11-dev libxext-dev libxinerama-dev libxrandr-dev libxv-dev pkg-config python x11proto-core-dev yasm libxss-dev git build-essential devscripts equivs

git clone https://github.com/mpv-player/mpv-build.git
cd mpv-build
./update
./clean
cd libass
git checkout 9a2b38e8f5957418362e86b525f72794565deedd
cd ..
./build -j2
sudo ./build install

Return to “Troubleshooting”