Alexander
Posts: 4
Joined: Tue Jul 24, 2012 8:22 am

SD card spare part number

Tue Jul 24, 2012 8:28 am

Hi,

Does anybody know the exact spare part number (or a model) of the SecureDigital (SD) card socket used in Raspberry Pi (model B)?

I need to buy the new one to replace the existing which is damaged.

Frankly, I heard many complaints that the SD connector used in RPi is quite unreliable and I personally already had to solder out two broken ones. Unfortunately we cannot find which part to buy as the replacement.

Thanks in advance.

Alexander

PaulCheffus
Posts: 381
Joined: Tue May 29, 2012 2:51 pm
Location: Lincolnshire UK

Re: SD card spare part number

Tue Jul 24, 2012 8:50 am

Alexander wrote:Hi,

Does anybody know the exact spare part number (or a model) of the SecureDigital (SD) card socket used in Raspberry Pi (model B)?

I need to buy the new one to replace the existing which is damaged.

Frankly, I heard many complaints that the SD connector used in RPi is quite unreliable and I personally already had to solder out two broken ones. Unfortunately we cannot find which part to buy as the replacement.

Thanks in advance.

Alexander
Hi

If you feel it is that unreliable why would you want to replace it with exactly the same part?

I've had mine about month now and have put several different SD cards in and out multiple times without issue.

Cheers

Paul
Procrastination - The Thief of Time.

dukla2000
Posts: 190
Joined: Tue Jan 10, 2012 12:02 am
Location: Reading.UK.EU

Re: SD card spare part number

Tue Jul 24, 2012 8:50 am

Daily driver: Pi3B, 64GB Samsung Evo+ @100MHz, DVB-T, onboard WiFi for internet, BT/USB dongle for KB/mouse, 250GB HDD via USB for media, Raspbian Jessie Lite with Openbox desktop.
Museum: Pi B

Alexander
Posts: 4
Joined: Tue Jul 24, 2012 8:22 am

Re: SD card spare part number

Tue Jul 24, 2012 8:57 am

PaulCheffus wrote:
If you feel it is that unreliable why would you want to replace it with exactly the same part?
I tried a few other models of the SD connector and they didn't really fit to the layout. That's why I wanted the exactly the same one.

Return to “Troubleshooting”