Page 1 of 1

HDMI shows 4 colours

Posted: Fri Oct 02, 2015 1:22 am
by bcjohno
hi, just got my PI B+ 512mb working with a 3.5" touch screen. i want to also use the hdmi port but when i plug in a monitor all i get are 4colours in a square, the touch screen is woring fine. any help ? Cheers Brad

Re: HDMI shows 4 colours

Posted: Fri Oct 02, 2015 6:26 am
by texy
Hi
the 'rainbow' coloured square is an indication that the Pi is not being supplied enough power. What is the rating of the PSU you are using?
Texy

Re: HDMI shows 4 colours

Posted: Fri Oct 02, 2015 8:24 am
by rpdom
Is that a big coloured square in the middle of the screen, or a small one in the top-right corner?

Re: HDMI shows 4 colours

Posted: Fri Oct 02, 2015 9:27 am
by ait
Hello Brad,
same here, but when i am using the omxplayer on commandline the video is shown on the HDMI-Monitor.

Ait

ps: in my case its a big coloured square in the middle of the screen,
the 3.5 " Display works on commandline and/or GUI while the HDMI Monitor shows the coloured square.
When i am starting omxplayer on the commandline on the 3.5" Display the video is shown on the HDMI-Monitor.

Re: HDMI shows 4 colours

Posted: Sat Oct 03, 2015 12:53 am
by bcjohno
hi, thanks for the replys, ive just tryed an iphone charger as a power supply and i still get the big square in the middle of the screen, red/yellow on top, blue/aqua below. the screen on the PI shows as normal.

Re: HDMI shows 4 colours

Posted: Sat Oct 03, 2015 12:56 am
by kusti8
bcjohno wrote:hi, thanks for the replys, ive just tryed an iphone charger as a power supply and i still get the big square in the middle of the screen, red/yellow on top, blue/aqua below. the screen on the PI shows as normal.

Please read the boot sticky. It's also useful to try a different SD card and computer to make the SD card.

Re: HDMI shows 4 colours

Posted: Sat Oct 03, 2015 1:38 am
by plugwash
It seems most posters here. are missing the bit about the small touchscreen. I don't think we are dealing with a boot problem here.

It seems like what is happening is that all normal linux output (e.g. not stuff through pi specific libraries like those used by omxplayer) is being diverted to the small touchscreen. Unfortunately I don't know if there is a way to make linux use both :/