Axy
Posts: 25
Joined: Tue Sep 29, 2015 1:52 pm

Console goes blank after a while (on TFT)

Thu Oct 01, 2015 10:51 pm

My pi is set to login to console (no gui/desktop) and I have a TFT attached to it. However my console goes blank after a while, the TFT is still backlit but it's just black.

I've tried ediring /etc/kbd/config - changed POWERDOWN_TIME to 0 and BLANK_TIME to 0. Did not help.

How can I solve this?

(Jessie)

Axy
Posts: 25
Joined: Tue Sep 29, 2015 1:52 pm

Re: Console goes blank after a while (on TFT)

Fri Oct 02, 2015 12:06 am

I've also tried the following command

Code: Select all

setterm -blank 0 -powersave off -powerdown 0
and I get this as a response

Code: Select all

setterm: terminal xterm does not support --blank
setterm: cannot (un)set powersave mode: Inappropriate ioctl for device

User avatar
AndyD
Posts: 2334
Joined: Sat Jan 21, 2012 8:13 am
Location: Melbourne, Australia
Contact: Website

Re: Console goes blank after a while (on TFT)

Fri Oct 02, 2015 12:18 am

Have a look at this thread.

Axy
Posts: 25
Joined: Tue Sep 29, 2015 1:52 pm

Re: Console goes blank after a while (on TFT)

Fri Oct 02, 2015 12:25 am

@AndyD what's the solution in this case?

User avatar
AndyD
Posts: 2334
Joined: Sat Jan 21, 2012 8:13 am
Location: Melbourne, Australia
Contact: Website

Re: Console goes blank after a while (on TFT)

Fri Oct 02, 2015 12:50 am

Hi @Axy, there is an ongoing conversation on the thread that a linked to above.

Axy
Posts: 25
Joined: Tue Sep 29, 2015 1:52 pm

Re: Console goes blank after a while (on TFT)

Fri Oct 02, 2015 12:33 pm

I believe I found a solution, not sure this is the best one or not.

No matter what I do, I've relaized that when I type

Code: Select all

cat /sys/module/kernel/parameters/consoleblank
to console I get

Code: Select all

600
as response. No workarounds above fixed it.

So I

Code: Select all

sudo /boot/cmdline.txt
and added

Code: Select all

consoleblank=0
to the end of the line.

So far it's working.

Return to “Troubleshooting”