User avatar
ReadiesCards
Posts: 40
Joined: Sun May 13, 2012 5:22 am

Issue: upside down mouse after running various commands

Mon Jul 16, 2012 5:39 am

On Debian Squeeze my little Chinese RF keyboard with built in mouse pad works great (this thing: http://www.ebay.co.uk/itm/2-4GHz-RF-Min ... 23150a3b07)

But when I tried Wheezy (and selected the default keyboard as required by the startup config utility ) and likewise when I ran Raspbian and performed all the update commands including various keyboard configs as given here: http://www.raspbian.org/PiscesImages the mouse pointer stays rooted to the bottom of the startx windows. I can get it to bounce a little and it moves right and left ok - it appears as if there is a massive offset or the mouse y co-ords are being translated incorrectly.

Would anyone know where and how might I fix this please?

In all cases I selected standard UK 105 keyboard (not knowing what else to select) Though I now notice the keyboard has no £ symbol so maybe UK is not the right selection.

Many thanks
Paul

User avatar
ReadiesCards
Posts: 40
Joined: Sun May 13, 2012 5:22 am

Re: Issue: upside down mouse after running various commands

Wed Feb 20, 2013 7:47 am

Still getting this issue every now and again. Would love to know any tips/suggestions on how I can force the mouse settings to always mean up is up and down is down

Thank you
Paul

User avatar
ReadiesCards
Posts: 40
Joined: Sun May 13, 2012 5:22 am

Re: Issue: upside down mouse after running various commands

Wed Feb 20, 2013 7:48 am

FYI
Left and right directions work just fine!
Only the vertical that is the issue

User avatar
RaTTuS
Posts: 10377
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: Issue: upside down mouse after running various commands

Wed Feb 20, 2013 8:05 am

so it's not upside down it's just not moving vertically ?

open a terminal window up and
tail -f /var/log/syslog

and move the mouse and see if anything show up [probably not]
also tail .xerrors
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

User avatar
ReadiesCards
Posts: 40
Joined: Sun May 13, 2012 5:22 am

Re: Issue: upside down mouse after running various commands

Fri Mar 08, 2013 7:36 am

Thank you for the reply - I'd forgot to tick 'Watch' so sorry for slow response.

When I do:
tail -f /var/log/syslog

and move the mouse you are correct nothing happens.

.xerrors does not appear to be in my home directory - assuming that is where a LXTerminal opens

Further information:
When I startx the mouse appears in the centre of the screen
I can then move the mouse perfectly normally for approx 1-2 seconds
After which it suddenly jumps to bottom of the screen
At this point it will happily move left and right as I wish
It will also move vertically up under my command for a few pixels before immediately jumping back to the bottom of the display

Bit werid! Any ideas?
Thanks
Paul

User avatar
ReadiesCards
Posts: 40
Joined: Sun May 13, 2012 5:22 am

Re: Issue: upside down mouse after running various commands

Fri Mar 08, 2013 7:40 am

I find .xsession-errors but nothing occurs in there when I move the mouse

Return to “Troubleshooting”