devenh
Posts: 32
Joined: Fri Jun 05, 2015 9:11 pm

cgps/xgps not connecting to Bluetooth GPS

Fri Jun 05, 2015 9:20 pm

Trying to connect my Raspberry Pi 2 B to an XGPS150a Bluetooth GPS. Running latest Raspian. Followed the instructions on how to connect to a Bluetooth device available on a few web pages and I have been able to get to the point where the following command works:

Code: Select all

cat /dev/rfcomm0
So I have a connection to the GPS, but I can't seem to get cgps or xgps to connect. I've tried variations of this:

Code: Select all

cgps /dev/rfcomm0
but still no go. I'm a newbie, so it is probably something simple that I've overlooked.

Thanks!

devenh
Posts: 32
Joined: Fri Jun 05, 2015 9:11 pm

Re: cgps/xgps not connecting to Bluetooth GPS

Sun Oct 02, 2016 3:05 am

I have not been able to get a reliable connection to the XGPS150a, but here are a few things to try:

Turn the XGPS150a on and make sure it is set to Andriod (as opposed to iPhone) mode.

On the Raspberry, run the following command:

Code: Select all

hcitool scan
You should see the XGPS150a and an address in the form of XX:XX:XX:XX:XX:XX

Now try:

Code: Select all

sudo rfcomm connect XX:XX:XX:XX:XX:XX 0 &
Wait 20-40 seconds and you should hopefully see a connection response.

Now you can enter:

Code: Select all

cat /dev/rfcomm0
If you are lucky, you'll see the output from the GPS device.

Search on "raspberry gps rfcomm" for more information. I'd love to be able to get this working consistently, but so far no joy.

User avatar
bensimmo
Posts: 4187
Joined: Sun Dec 28, 2014 3:02 pm
Location: East Yorkshire

Re: cgps/xgps not connecting to Bluetooth GPS

Sun Oct 02, 2016 8:10 am

Do you get anything from gpsmon ?

Return to “Troubleshooting”