Odog1996
Posts: 19
Joined: Fri Jul 13, 2012 8:02 pm

Tight VNC Server

Fri Jul 13, 2012 8:07 pm

Hi,
Due to space limitations on my desk I am using Tight VNC Server to operate my Raspberry Pi, It has been working fine until I tried to switch it on again now and I get the error message:
Couldn't start Xtightvnc; trying default font path.
Please set correct fontPath in the tightvncserver script.
Couldn't start Xtightvnc process.
I have tried updates and re-installing using apt-get but it still comes up with a problem.
I am a complete beginner to Debian Linux so an idiots guide to solving the problem would be appreciated!!!
Thanks
Owen

User avatar
devacc12
Posts: 12
Joined: Sat Jul 07, 2012 6:22 pm

Re: Tight VNC Server

Sat Jul 14, 2012 9:46 am

Apparently the package has a hard coded link (a fault) to a fonts directory that doesn't exist in many linux distributions.
I installed tightvncserver this morning.
The usual font warning but it didn't stop it from starting.
I've an archlinux build and when I linked the directory name tightvncserver is expecting to the place where the fonts are installed, most of the errors went away.
A few extra Xorg fonts may need installing.

I haven't checked this for Debian but for Archlinux the warnings were like:
missing: /usr/X11R6/lib/X11/fonts/misc and Speedo and Type1 and 75dpi and 100dpi
I had to install some extra fonts:
pacman - S font-bitstream-speedo xord-fonts-type1 xorg-xcomp xorg-xkb-utils xkbsel
(for Debian sudo apt-get instead of pacman - S may work)
then link:
ln -s /usr/X11R6/lib/X11/fonts to /usr/share/fonts

I had one last complain about the Speedo font and it looked like an uppercase first letter problem but I think this
ln -s /usr/share/fonts/Speedo /usr/share/font/speedo
didn't fix it.

In any case these warnings didn't stop the server from working.

Odog1996
Posts: 19
Joined: Fri Jul 13, 2012 8:02 pm

Re: Tight VNC Server

Sat Jul 14, 2012 1:23 pm

Hi,
Right, I was playing around and in the VNC script (Used Nano) it askes for some fonts that are in the X11 folder that aren't there. I tried to use: " sudo apt-get font-bitstream-speedo xord-fonts-type1 xorg-xcomp xorg-xkb-utils xkbsel " (without quotation marks) to get the missing fonts but it comes up with unable to locate package. Is there any other way to get the fonts into the folder?
Thanks
Owen
P.S.
The missing fonts are:
Type1
75dpi
100dpi

blowhard
Posts: 2
Joined: Sun Jul 29, 2012 7:14 am

Re: Tight VNC Server

Sun Jul 29, 2012 7:19 am

You have run out of space on your sdcard.

You need to use e.g. gparted to resize the ~2Gbyte partition (created when you installed the latest version of debian) to ~4Gbyte (or whatever you card will take).

User avatar
ro6er
Posts: 24
Joined: Fri Oct 19, 2012 6:26 pm

Re: Tight VNC Server

Tue Dec 18, 2012 1:20 pm

Wasn't memory space on mine. I did

Code: Select all

df -h
I had bags of space. I read a few forums, one suggested this:
http://www.x.org/wiki/FAQErrorMessages# ... 27fixed.27

From that I basically fixed mine by installing the xfonts-base again:

Code: Select all

apt-get install  xfonts-base
I seem to remember faffing with fonts before. So it's probably all my own stupid fault.

Roger

Return to “Troubleshooting”