ana3bdelr7man
Posts: 2
Joined: Mon Mar 27, 2017 3:59 pm

Re: [Solved] USB not working - Raspberry pi 2

Mon Mar 27, 2017 4:36 pm

ahmedawad wrote:I took out U13 (BK5tE) chip and the Capacitor C97 completely out of my board and shorted pin 1 and pin 6 of the U13. The Pi became stable once again and the power red led stopped blinking. Thanks for @jbeale, his thread and discussion was helpful.

I would suggest, first use an Avometer and while the Pi is Off, try using the buzzer and check the 2 pins of C97. If sound comes out then the problem is with the capacitor, take it out and try again. If the problem still exists, then take the U13 chip out and make the short. This what happened on Pi3 and it did work.

Ahmed Can you help me with U13 ??

what should i do exactly and what are the pins that you are talking about
please answer with photos >>

Tesla92
Posts: 4
Joined: Wed Aug 02, 2017 5:22 am

Re: [Solved] USB not working - Raspberry pi 2

Wed Aug 02, 2017 3:52 pm

I am having similar problem with my RPi 3 rev 1.2
Yesterday, out of nowhere, Ethernet and all of the usb ports stopped working. However i can boot raspbian. There is a constant yellow thunder symbol on top right corner of the display. The green ACT led is also not blinking. I have tried different psu and cables but nothing helps.
Then i found that pin6 of AP2552 ic has 0.00v while pin1 has 4.96v. I have also made sure that there is no short in the usb ports and c97, c98, c99 work fine.
So should i short pin 1 and 6 of the ic?
(i am asking this as maybe my problem is different as ethernet and ACT led doesnt work and also i have a yellow thunder symbol)
Plz help.

User avatar
Burngate
Posts: 6067
Joined: Thu Sep 29, 2011 4:34 pm
Location: Berkshire UK Tralfamadore
Contact: Website

Re: [Solved] USB not working - Raspberry pi 2

Wed Aug 02, 2017 5:30 pm

Tesla92 wrote:
Wed Aug 02, 2017 3:52 pm
I am having similar problem with my RPi 3 rev 1.2
Yesterday, out of nowhere, Ethernet and all of the usb ports stopped working. However i can boot raspbian. There is a constant yellow thunder symbol on top right corner of the display. The green ACT led is also not blinking. I have tried different psu and cables but nothing helps.
Then i found that pin6 of AP2552 ic has 0.00v while pin1 has 4.96v. I have also made sure that there is no short in the usb ports and c97, c98, c99 work fine.
So should i short pin 1 and 6 of the ic?
(i am asking this as maybe my problem is different as ethernet and ACT led doesnt work and also i have a yellow thunder symbol)
Plz help.
The green ACT led only flashes when the SD card is being accessed, so not flashing isn't a fault indication.
The "yellow thunder symbol" means the 5v rail is at less than 4.6v. That's the first indication of a fault. Also it means your measurement of 4.96v on the AP255x chip is suspect.
You say you're sure "there is no short in the usb ports and c97, c98, c99 work fine". How did you check the capacitors?

I wouldn't short out that chip before going through more fault-finding - though it's your Pi, so you can do what you want!
For example, what are the voltages on the other pins of that chip?
Pin 3 - enable - is an input, so is the chip being told to be off?
Pin 4 - Fault - is an output, so will tell you what the chip thinks is happening.

Tesla92
Posts: 4
Joined: Wed Aug 02, 2017 5:22 am

Re: [Solved] USB not working - Raspberry pi 2

Thu Aug 03, 2017 5:25 am

Thanks a lot for your reply :)
Burngate wrote:
Wed Aug 02, 2017 5:30 pm
You say you're sure "there is no short in the usb ports and c97, c98, c99 work fine". How did you check the capacitors?
I took off the 3 caps ie. c97, c98, c99 using hot air and measured them individually with my LCR meter and they showed 52uF each. (I dont know exactly what their value should be, as all 3 are showing same capacity, i guessed they are fine )
For the usb ports, I inspected them thoroughly with my eyes and also checked via multimeter for any short.

Then I did some voltage tests from the test pads. They are as follows:

1. PP1/2 = 5.04V (5V from micro-USB)
2. PP7 = 4.99V (5V after polyfuse)
3. PP8 = 3.29V (3V3)
4. PP9 = 1.80V (1V8)
5. PP 27 = 0.00V (VBUS (USB 5V power))

Then I tested the AP2552 IC and found the following:
1. Pin1 - 4.98V
2. Pin3 - 0.02V
3. Pin4 - 0.03V
4. Pin5 - 0.00V
5. Pin6 - 0.00V

As many threads have stated i have also reflowed the X1 crystal. But nothing helps...
What should i do now?

User avatar
Burngate
Posts: 6067
Joined: Thu Sep 29, 2011 4:34 pm
Location: Berkshire UK Tralfamadore
Contact: Website

Re: [Solved] USB not working - Raspberry pi 2

Thu Aug 03, 2017 6:20 pm

Then I tested the AP2552 IC and found the following:
1. Pin1 - 4.98V
2. Pin3 - 0.02V
3. Pin4 - 0.03V
4. Pin5 - 0.00V
5. Pin6 - 0.00V
Okay, so with those measurements, it would seem that both the Enable in and the Fault out are low.
(by the way, I believe it's a 2553, not 2552, so the Enable should be held high for it to work)

It could be that the LAN9514 USB chip isn't driving the Enable correctly, or ... well, a number of other things, including but not limited to o/c resistors, s/c diodes, faulty 2553, a bad batch of pixie dust, ...

At this point I would definitely go for the wiring-out-of-circuit option. But I'm a cowboy, and it's your Pi.

Tesla92
Posts: 4
Joined: Wed Aug 02, 2017 5:22 am

Re: [Solved] USB not working - Raspberry pi 2

Fri Aug 04, 2017 8:42 am

Burngate wrote:
Thu Aug 03, 2017 6:20 pm
At this point I would definitely go for the wiring-out-of-circuit option. But I'm a cowboy, and it's your Pi.
I had no options so went ahead by removing the AP2553 and shorted Pin1 with Pin6.
When Pi booted up ACT led blinked ONLY once and went to desktop with the yellow thunder symbol still on up right corner. USB and Ethernet worked fine BUT AFTER 120 SECONDS both USB and ethernet automatically stopped working and consequently the thunder symbol also went away. I rebooted again and exactly same thing happened.

One thing I noticed when i click on Bluetooth button in the taskbar, it says: No Bluetooth adapter found.
WiFi button says: No WiFi interface found.

I managed to get dmesg log. Here it is:

Code: Select all

[email protected]:~ $ dmesg
[    0.000000] Booting Linux on physical CPU 0x0
[    0.000000] Linux version 4.9.35-v7+ ([email protected]) (gcc version 4.9.3                                                                                                                      (crosstool-NG crosstool-ng-1.22.0-88-g8460611) ) #1014 SMP Fri Jun 30 14:47:43 B                                                                                                                     ST 2017
[    0.000000] CPU: ARMv7 Processor [410fd034] revision 4 (ARMv7), cr=10c5383d
[    0.000000] CPU: div instructions available: patching division code
[    0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instructio                                                                                                                     n cache
[    0.000000] OF: fdt:Machine model: Raspberry Pi 3 Model B Rev 1.2
[    0.000000] cma: Reserved 8 MiB at 0x3a800000
[    0.000000] Memory policy: Data cache writealloc
[    0.000000] On node 0 totalpages: 241664
[    0.000000] free_area_init_node: node 0, pgdat 80c6ee40, node_mem_map b9faa00                                                                                                                     0
[    0.000000]   Normal zone: 2124 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 241664 pages, LIFO batch:31
[    0.000000] percpu: Embedded 14 pages/cpu @b9f64000 s25600 r8192 d23552 u5734                                                                                                                     4
[    0.000000] pcpu-alloc: s25600 r8192 d23552 u57344 alloc=14*4096
[    0.000000] pcpu-alloc: [0] 0 [0] 1 [0] 2 [0] 3
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pag                                                                                                                     es: 239540
[    0.000000] Kernel command line: 8250.nr_uarts=1 bcm2708_fb.fbwidth=656 bcm27                                                                                                                     08_fb.fbheight=416 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3dc00000 vc_mem.mem_siz                                                                                                                     e=0x3f000000  dwc_otg.lpm_enable=0 console=ttyS0,115200 console=tty1 root=PARTUU                                                                                                                     ID=eb86031c-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet                                                                                                                      splash plymouth.ignore-serial-consoles
[    0.000000] PID hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)
[    0.000000] Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.000000] Memory: 936296K/966656K available (7168K kernel code, 484K rwdata                                                                                                                     , 2012K rodata, 1024K init, 778K bss, 22168K reserved, 8192K cma-reserved)
[    0.000000] Virtual kernel memory layout:
    vector  : 0xffff0000 - 0xffff1000   (   4 kB)
    fixmap  : 0xffc00000 - 0xfff00000   (3072 kB)
    vmalloc : 0xbb800000 - 0xff800000   (1088 MB)
    lowmem  : 0x80000000 - 0xbb000000   ( 944 MB)
    modules : 0x7f000000 - 0x80000000   (  16 MB)
      .text : 0x80008000 - 0x80800000   (8160 kB)
      .init : 0x80b00000 - 0x80c00000   (1024 kB)
      .data : 0x80c00000 - 0x80c79014   ( 485 kB)
       .bss : 0x80c7b000 - 0x80d3da64   ( 779 kB)
[    0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[    0.000000] Hierarchical RCU implementation.
[    0.000000]  Build-time adjustment of leaf fanout to 32.
[    0.000000] NR_IRQS:16 nr_irqs:16 16
[    0.000000] arm_arch_timer: Architected cp15 timer(s) running at 19.20MHz (ph                                                                                                                     ys).
[    0.000000] clocksource: arch_sys_counter: mask: 0xffffffffffffff max_cycles:                                                                                                                      0x46d987e47, max_idle_ns: 440795202767 ns
[    0.000009] sched_clock: 56 bits at 19MHz, resolution 52ns, wraps every 43980                                                                                                                     46511078ns
[    0.000021] Switching to timer-based delay loop, resolution 52ns
[    0.000322] Console: colour dummy device 80x30
[    0.000342] console [tty1] enabled
[    0.000373] Calibrating delay loop (skipped), value calculated using timer fr                                                                                                                     equency.. 38.40 BogoMIPS (lpj=192000)
[    0.000390] pid_max: default: 32768 minimum: 301
[    0.000724] Mount-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000733] Mountpoint-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.001724] Disabling cpuset control group subsystem
[    0.001885] CPU: Testing write buffer coherency: ok
[    0.001925] ftrace: allocating 22390 entries in 66 pages
[    0.054467] CPU0: update cpu_capacity 1024
[    0.054485] CPU0: thread -1, cpu 0, socket 0, mpidr 80000000
[    0.054556] Setting up static identity map for 0x100000 - 0x100034
[    0.056773] CPU1: update cpu_capacity 1024
[    0.056781] CPU1: thread -1, cpu 1, socket 0, mpidr 80000001
[    0.057500] CPU2: update cpu_capacity 1024
[    0.057506] CPU2: thread -1, cpu 2, socket 0, mpidr 80000002
[    0.058173] CPU3: update cpu_capacity 1024
[    0.058179] CPU3: thread -1, cpu 3, socket 0, mpidr 80000003
[    0.058263] Brought up 4 CPUs
[    0.058274] SMP: Total of 4 processors activated (153.60 BogoMIPS).
[    0.058278] CPU: All CPU(s) started in HYP mode.
[    0.058282] CPU: Virtualization extensions available.
[    0.059079] devtmpfs: initialized
[    0.070470] VFP support v0.3: implementor 41 architecture 3 part 40 variant 3                                                                                                                      rev 4
[    0.070739] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, ma                                                                                                                     x_idle_ns: 19112604462750000 ns
[    0.070755] futex hash table entries: 1024 (order: 4, 65536 bytes)
[    0.071289] pinctrl core: initialized pinctrl subsystem
[    0.072185] NET: Registered protocol family 16
[    0.074568] DMA: preallocated 1024 KiB pool for atomic coherent allocations
[    0.083531] hw-breakpoint: found 5 (+1 reserved) breakpoint and 4 watchpoint                                                                                                                      registers.
[    0.083537] hw-breakpoint: maximum watchpoint size is 8 bytes.
[    0.083687] Serial: AMBA PL011 UART driver
[    0.085690] bcm2835-mbox 3f00b880.mailbox: mailbox enabled
[    0.086216] uart-pl011 3f201000.serial: could not find pctldev for node /soc/                                                                                                                     [email protected]/uart0_pins, deferring probe
[    0.086734] irq: no irq domain found for /soc/[email protected] !
[    0.155061] bcm2835-dma 3f007000.dma: DMA legacy API manager at bb80f000, dma                                                                                                                     chans=0x1
[    0.156903] SCSI subsystem initialized
[    0.157056] usbcore: registered new interface driver usbfs
[    0.157131] usbcore: registered new interface driver hub
[    0.157221] usbcore: registered new device driver usb
[    0.164020] raspberrypi-firmware soc:firmware: Attached to firmware from 2017                                                                                                                     -07-03 14:16
[    0.165536] clocksource: Switched to clocksource arch_sys_counter
[    0.212309] VFS: Disk quotas dquot_6.6.0
[    0.212386] VFS: Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
[    0.212585] FS-Cache: Loaded
[    0.212826] CacheFiles: Loaded
[    0.225026] NET: Registered protocol family 2
[    0.225939] TCP established hash table entries: 8192 (order: 3, 32768 bytes)
[    0.226048] TCP bind hash table entries: 8192 (order: 4, 65536 bytes)
[    0.226232] TCP: Hash tables configured (established 8192 bind 8192)
[    0.226319] UDP hash table entries: 512 (order: 2, 16384 bytes)
[    0.226361] UDP-Lite hash table entries: 512 (order: 2, 16384 bytes)
[    0.226568] NET: Registered protocol family 1
[    0.226974] RPC: Registered named UNIX socket transport module.
[    0.226979] RPC: Registered udp transport module.
[    0.226983] RPC: Registered tcp transport module.
[    0.226987] RPC: Registered tcp NFSv4.1 backchannel transport module.
[    0.228077] hw perfevents: enabled with armv7_cortex_a7 PMU driver, 7 counter                                                                                                                     s available
[    0.230351] workingset: timestamp_bits=14 max_order=18 bucket_order=4
[    0.246492] FS-Cache: Netfs 'nfs' registered for caching
[    0.247463] NFS: Registering the id_resolver key type
[    0.247493] Key type id_resolver registered
[    0.247497] Key type id_legacy registered
[    0.249895] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 2                                                                                                                     51)
[    0.249999] io scheduler noop registered
[    0.250004] io scheduler deadline registered (default)
[    0.250262] io scheduler cfq registered
[    0.255989] BCM2708FB: allocated DMA memory fa910000
[    0.256014] BCM2708FB: allocated DMA channel 0 @ bb80f000
[    0.264722] Console: switching to colour frame buffer device 82x26
[    0.269977] Serial: 8250/16550 driver, 1 ports, IRQ sharing enabled
[    0.270587] bcm2835-aux-uart 3f215040.serial: could not get clk: -517
[    0.271810] bcm2835-rng 3f104000.rng: hwrng registered
[    0.271927] vc-cma: Videocore CMA driver
[    0.271933] vc-cma: vc_cma_base      = 0x00000000
[    0.271939] vc-cma: vc_cma_size      = 0x00000000 (0 MiB)
[    0.271944] vc-cma: vc_cma_initial   = 0x00000000 (0 MiB)
[    0.272134] vc-mem: phys_addr:0x00000000 mem_base=0x3dc00000 mem_size:0x3f000                                                                                                                     000(1008 MiB)
[    0.287509] brd: module loaded
[    0.296323] loop: module loaded
[    0.296335] Loading iSCSI transport class v2.0-870.
[    0.296875] usbcore: registered new interface driver smsc95xx
[    0.296890] dwc_otg: version 3.00a 10-AUG-2012 (platform bus)
[    0.524956] Core Release: 2.80a
[    0.524965] Setting default values for core params
[    0.524994] Finished setting default values for core params
[    0.725379] Using Buffer DMA mode
[    0.725385] Periodic Transfer Interrupt Enhancement - disabled
[    0.725389] Multiprocessor Interrupt Enhancement - disabled
[    0.725395] OTG VER PARAM: 0, OTG VER FLAG: 0
[    0.725406] Dedicated Tx FIFOs mode
[    0.725769] WARN::dwc_otg_hcd_init:1032: FIQ DMA bounce buffers: virt = 0xba9                                                                                                                     04000 dma = 0xfa904000 len=9024
[    0.725794] FIQ FSM acceleration enabled for :
Non-periodic Split Transactions
Periodic Split Transactions
High-Speed Isochronous Endpoints
Interrupt/Control Split Transaction hack enabled
[    0.725800] dwc_otg: Microframe scheduler enabled
[    0.725841] WARN::hcd_init_fiq:459: FIQ on core 1 at 0x8058ef90
[    0.725851] WARN::hcd_init_fiq:460: FIQ ASM at 0x8058f300 length 36
[    0.725861] WARN::hcd_init_fiq:486: MPHI regs_base at 0xbb87a000
[    0.725916] dwc_otg 3f980000.usb: DWC OTG Controller
[    0.725949] dwc_otg 3f980000.usb: new USB bus registered, assigned bus number                                                                                                                      1
[    0.725980] dwc_otg 3f980000.usb: irq 62, io mem 0x00000000
[    0.726026] Init: Port Power? op_state=1
[    0.726031] Init: Power Port (0)
[    0.726224] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    0.726234] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=                                                                                                                     1
[    0.726242] usb usb1: Product: DWC OTG Controller
[    0.726250] usb usb1: Manufacturer: Linux 4.9.35-v7+ dwc_otg_hcd
[    0.726257] usb usb1: SerialNumber: 3f980000.usb
[    0.727082] hub 1-0:1.0: USB hub found
[    0.727125] hub 1-0:1.0: 1 port detected
[    0.727776] dwc_otg: FIQ enabled
[    0.727781] dwc_otg: NAK holdoff enabled
[    0.727785] dwc_otg: FIQ split-transaction FSM enabled
[    0.727797] Module dwc_common_port init
[    0.728006] usbcore: registered new interface driver usb-storage
[    0.728213] mousedev: PS/2 mouse device common for all mice
[    0.729150] bcm2835-wdt 3f100000.watchdog: Broadcom BCM2835 watchdog timer
[    0.729427] bcm2835-cpufreq: min=600000 max=1200000
[    0.729810] sdhci: Secure Digital Host Controller Interface driver
[    0.729815] sdhci: Copyright(c) Pierre Ossman
[    0.730089] sdhost-bcm2835 3f202000.sdhost: could not get clk, deferring prob                                                                                                                     e
[    0.732266] mmc-bcm2835 3f300000.mmc: could not get clk, deferring probe
[    0.732364] sdhci-pltfm: SDHCI platform and OF driver helper
[    0.733834] ledtrig-cpu: registered to indicate activity on CPUs
[    0.734019] hidraw: raw HID events driver (C) Jiri Kosina
[    0.734197] usbcore: registered new interface driver usbhid
[    0.734201] usbhid: USB HID core driver
[    0.734957] vchiq: vchiq_init_state: slot_zero = 0xba980000, is_master = 0
[    0.736608] Initializing XFRM netlink socket
[    0.736629] NET: Registered protocol family 17
[    0.736749] Key type dns_resolver registered
[    0.737260] Registering SWP/SWPB emulation handler
[    0.737950] registered taskstats version 1
[    0.738278] vc-sm: Videocore shared memory driver
[    0.738287] [vc_sm_connected_init]: start
[    0.744865] [vc_sm_connected_init]: end - returning 0
[    0.750905] 3f201000.serial: ttyAMA0 at MMIO 0x3f201000 (irq = 87, base_baud                                                                                                                      = 0) is a PL011 rev2
[    0.752405] console [ttyS0] disabled
[    0.752430] 3f215040.serial: ttyS0 at MMIO 0x0 (irq = 220, base_baud = 312500                                                                                                                     00) is a 16550
[    0.759042] console [ttyS0] enabled
[    0.759713] sdhost: log_buf @ ba907000 (fa907000)
[    0.835567] mmc0: sdhost-bcm2835 loaded - DMA enabled (>1)
[    0.837766] mmc-bcm2835 3f300000.mmc: mmc_debug:0 mmc_debug2:0
[    0.837774] mmc-bcm2835 3f300000.mmc: DMA channel allocated
[    0.895679] of_cfs_init
[    0.895777] of_cfs_init: OK
[    0.896260] Waiting for root device PARTUUID=eb86031c-02...
[    0.907502] mmc0: host does not support reading read-only switch, assuming wr                                                                                                                     ite-enable
[    0.909464] mmc0: new high speed SDHC card at address 59b4
[    0.910082] mmcblk0: mmc0:59b4 00000 7.48 GiB
[    0.912143]  mmcblk0: p1 p2
[    0.945722] Indeed it is in host mode hprt0 = 00021501
[    1.029003] random: fast init done
[    1.049998] EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. O                                                                                                                     pts: (null)
[    1.050040] VFS: Mounted root (ext4 filesystem) readonly on device 179:2.
[    1.051044] devtmpfs: mounted
[    1.052835] Freeing unused kernel memory: 1024K (80b00000 - 80c00000)
[    1.145585] usb 1-1: new high-speed USB device number 2 using dwc_otg
[    1.145711] Indeed it is in host mode hprt0 = 00001101
[    1.350894] systemd[1]: systemd 215 running in system mode. (+PAM +AUDIT +SEL                                                                                                                     INUX +IMA +SYSVINIT +LIBCRYPTSETUP +GCRYPT +ACL +XZ -SECCOMP -APPARMOR)
[    1.351236] systemd[1]: Detected architecture 'arm'.
[    1.375881] usb 1-1: New USB device found, idVendor=0424, idProduct=9514
[    1.375892] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    1.376698] hub 1-1:1.0: USB hub found
[    1.376787] hub 1-1:1.0: 5 ports detected
[    1.498146] NET: Registered protocol family 10
[    1.499488] systemd[1]: Inserted module 'ipv6'
[    1.501322] systemd[1]: Set hostname to <raspberrypi>.
[    1.501473] systemd[1]: Initializing machine ID from random generator.
[    1.501680] systemd[1]: Installed transient /etc/machine-id file.
[    1.705597] usb 1-1.1: new high-speed USB device number 3 using dwc_otg
[    1.835903] usb 1-1.1: New USB device found, idVendor=0424, idProduct=ec00
[    1.835918] usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber                                                                                                                     =0
[    1.838751] smsc95xx v1.0.5
[    1.876844] systemd[1]: Cannot add dependency job for unit regenerate_ssh_hos                                                                                                                     t_keys.service, ignoring: Unit regenerate_ssh_host_keys.service failed to load:                                                                                                                      No such file or directory.
[    1.880447] systemd[1]: Expecting device dev-ttyS0.device...
[    1.880729] systemd[1]: Starting Forward Password Requests to Wall Directory                                                                                                                      Watch.
[    1.880932] systemd[1]: Started Forward Password Requests to Wall Directory W                                                                                                                     atch.
[    1.931417] smsc95xx 1-1.1:1.0 eth0: register 'smsc95xx' at usb-3f980000.usb-                                                                                                                     1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:3a:7a:9c
[    2.018228] fuse init (API version 7.26)
[    2.066119] i2c /dev entries driver
[    2.251060] systemd-udevd[138]: starting version 215
[    2.684719] Driver for 1-wire Dallas network protocol.
[    2.700831] w1-gpio [email protected]: gpio pin 4, external pullup pin -1, parasitic                                                                                                                      power 0
[    2.700863] w1_add_master_device: set_pullup requires write_byte or touch_bit                                                                                                                     , disabling
[    2.755384] gpiomem-bcm2835 3f200000.gpiomem: Initialised: Registers at 0x3f2                                                                                                                     00000
[    3.064977] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[    3.599969] systemd-journald[142]: Received request to flush runtime journal                                                                                                                      from PID 1
[    5.370818] w1_master_driver w1_bus_master1: w1_search: max_slave_count 64 re                                                                                                                     ached, will continue next search.
[    5.662346] uart-pl011 3f201000.serial: no DMA platform data
[    6.204602] Adding 102396k swap on /var/swap.  Priority:-1 extents:2 across:1                                                                                                                     67932k SSFS
[    6.218736] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[    7.790719] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0x45E                                                                                                                     1
[   18.188083] random: crng init done
[   35.776830] Bluetooth: Core ver 2.22
[   35.776908] NET: Registered protocol family 31
[   35.776914] Bluetooth: HCI device and connection manager initialized
[   35.776933] Bluetooth: HCI socket layer initialized
[   35.776945] Bluetooth: L2CAP socket layer initialized
[   35.776975] Bluetooth: SCO socket layer initialized
[   35.799385] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   35.799395] Bluetooth: BNEP filters: protocol multicast
[   35.799417] Bluetooth: BNEP socket layer initialized
[   56.415316] w1_master_driver w1_bus_master1: Family 0 for 00.800000000000.8c                                                                                                                      is not registered.
[  120.015328] w1_master_driver w1_bus_master1: Family 0 for 00.400000000000.46                                                                                                                      is not registered.
I didn't understand much from the log.

These 2 lines seemed unusual to me:
[ 0.270587] bcm2835-aux-uart 3f215040.serial: could not get clk: -517
[ 2.700863] w1_add_master_device: set_pullup requires write_byte or touch_bit , disabling


Some other tests...
ifconfig:

Code: Select all

[email protected]:~ $ ifconfig
eth0      Link encap:Ethernet  HWaddr b8:27:eb:3a:7a:9c
          inet addr:192.168.1.108  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::cf1b:150b:4297:5daf/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:847 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1784 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:113771 (111.1 KiB)  TX bytes:452746 (442.1 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:209 errors:0 dropped:0 overruns:0 frame:0
          TX packets:209 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:17180 (16.7 KiB)  TX bytes:17180 (16.7 KiB)
lsusb:

Code: Select all

[email protected]:~ $ lsusb
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
iwconfig:

Code: Select all

[email protected]:~ $ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.
No wlan showing :?
Would you please help me find out what is wrong with my pi?

Return to “Troubleshooting”