cybermaxpower
Posts: 4
Joined: Fri Apr 20, 2012 7:43 am

Very incompatible VCHIQ library when trying to run Quake3

Wed Jul 11, 2012 11:03 am

Hi,

Please help im not sure where to post this but here goes

I’ve just installed Quake3 from information on http://mitchtech.net/install-quake-3-on-raspberry-pi/ on to the 2012-06-18 Debian “wheezy” public beta Image.

I get the following error message when I try run to ./start.sh

1028537591: vchiq_lib: Very incompatible VCHIQ library - cannot retrieve driver version
* failed to open vchiq instance


i have done both sudo apt-get upgrade && sudo apt-get update to no effect.

What is VCHIQ library?
Is there a work around i could do to fix this?

Thank you,

Zeek20
Posts: 10
Joined: Sat Jun 23, 2012 7:06 pm

Re: Very incompatible VCHIQ library when trying to run Quake

Wed Jul 11, 2012 1:43 pm

Search the forums this has been resolved several times, look for rpi-update.

cybermaxpower
Posts: 4
Joined: Fri Apr 20, 2012 7:43 am

Re: Very incompatible VCHIQ library when trying to run Quake

Thu Jul 12, 2012 8:44 am

Thanks

I have searched this Forum http://www.raspberrypi.org/phpBB3/searc ... rpi+update & Searched Google for this.With no luck on finding a fix. :(

I have tried installing & running the rpi-update tool to see if the same error happen with that but rpi-update. It worked just fine with no error.

Too me it looks like a bug with vchiq library &/or 2012-06-18 Debian “wheezy” public beta image.
I cant see way or find a fix for this :(

if anyone has any idea on a easy way of fixing this please could you let me know,

Thank you,

jerhay
Posts: 7
Joined: Thu Jun 21, 2012 9:51 am

Re: Very incompatible VCHIQ library when trying to run Quake

Sun Jul 15, 2012 7:00 pm

I have the same problem when I try to run the Quake3. I also did the rpi-update succesfully, but it doesn't make any difference. How to fix this?

mattthias
Posts: 1
Joined: Sun Jul 15, 2012 12:03 pm

Re: Very incompatible VCHIQ library when trying to run Quake

Sat Jul 21, 2012 4:49 pm

Hi jerhay,
jerhay wrote:I have the same problem when I try to run the Quake3. I also did the rpi-update succesfully, but it doesn't make any difference. How to fix this?
look here:
http://www.raspberrypi.org/phpBB3/viewt ... 802#p73802

With the recompiled version downloaded from the link in this post the "very incompatible" message is gone.

Best wishes,
Matthisa

loracrow
Posts: 1
Joined: Fri Jul 27, 2012 9:08 am

Re: Very incompatible VCHIQ library when trying to run Quake

Fri Jul 27, 2012 9:15 am

I was having the same error :-Very incompatible VCHIQ library when trying to run Quake3

after installing quake 3 running on Raspbian “wheezy”

check out :- http://www.raspbian.org/RaspbianQuake3

follow the instructions and after the install is complete and your new ioquake3.arm file is created in dir /home/pi/src/quake3
move/copy the file ioquake3.arm to your /home/pi/quake dir. Overwrite the file that is already there from you install of quake 3.

This worked for me and Quake is now up and running on Raspbian “wheezy”

cybermaxpower
Posts: 4
Joined: Fri Apr 20, 2012 7:43 am

Re: Very incompatible VCHIQ library when trying to run Quake

Fri Jul 27, 2012 2:14 pm

loracrow wrote: check out :- http://www.raspbian.org/RaspbianQuake3

follow the instructions and after the install is complete and your new ioquake3.arm file is created in dir /home/pi/src/quake3
move/copy the file ioquake3.arm to your /home/pi/quake dir. Overwrite the file that is already there from you install of quake 3.

This worked for me and Quake is now up and running on Raspbian “wheezy”
:D Thank you That work grate for me :)

apt-e
Posts: 8
Joined: Wed Jun 27, 2012 6:57 pm
Location: York
Contact: Website

Re: Very incompatible VCHIQ library when trying to run Quake

Sat Jul 28, 2012 7:30 pm

Try this set of binaries, complete with working sound driver.....

http://www.apt-e.org/raspberry/Quake3.zip

Enjoy

This is for Raspbian...................

lunchmeat2
Posts: 3
Joined: Fri Dec 28, 2012 3:50 am

Re: Very incompatible VCHIQ library when trying to run Quake

Sat Jan 19, 2013 5:11 am

I still get this message and I followed the instructions as per those instructions after I had the same issue. This originally fixed it, but now it came back:

Code: Select all

pi@raspberrypi ~/quake3 $ sudo ./ioquake3.arm
vchiq_lib: Very incompatible VCHIQ library - cannot retrieve driver version
* failed to open vchiq instance
Any help?

Return to “Troubleshooting”