Page 1 of 1

USB HDD stopped working

Posted: Fri Apr 10, 2015 8:19 pm
by norbus2000a
Hello,

I had a working SATA>USB adapter until yesterday. Several days ago, I've run OpenELEC, everything was OK. Yesterday I wanted to boot my Pi to My Gentoo installation. And my adapter stopped working. :shock: The red LED(work LED) is flashing slowly. On PC with the same HDD(and power supply for it) adapter works very well, so adapter and USB cable are good. Here LED flashes very fast. So why It isn't working on Pi?

I'm using B+, WD RED 2TB HDD. Please, help me!

Re: USB HDD stopped working

Posted: Fri Apr 10, 2015 8:44 pm
by DougieLawson
Have you got

Code: Select all

max_usb_current=1
in your /boot/config.txt ?

Re: USB HDD stopped working

Posted: Fri Apr 10, 2015 9:24 pm
by norbus2000a
No, I hadn't. It didn't help. But why It was working and now is not? No updates!

Re: USB HDD stopped working

Posted: Sat Apr 11, 2015 3:59 pm
by norbus2000a
Anybody ?

Re: USB HDD stopped working

Posted: Sat Apr 11, 2015 4:02 pm
by DougieLawson
Has the hardware physically broken, as in head to disk interference?

Is the device detected when you boot or when it's plugged in? What does a dmesg command show?

Re: USB HDD stopped working

Posted: Sat Apr 11, 2015 6:40 pm
by norbus2000a
Hardware must be good, because It's working on PC. "dmesg" shows nothing. When I plug it in, no reaction, lsusb or dmesg gives nothing. Tomorrow I'll try to boot clear Raspbian.

Re: USB HDD stopped working

Posted: Sat Apr 11, 2015 7:48 pm
by DougieLawson
When I plug in a HDD or boot with my HDD plugged in I get

[ 10.331118] sd 0:0:0:0: [sda] 312581808 512-byte logical blocks: (160 GB/149 GiB)
[ 10.340318] sd 0:0:0:0: [sda] Write Protect is off
[ 10.354969] sd 0:0:0:0: [sda] Mode Sense: 28 00 00 00
[ 10.355727] sd 0:0:0:0: [sda] No Caching mode page found
[ 10.357727] sd 0:0:0:0: [sda] Assuming drive cache: write through
[ 10.384632] sda: sda1
[ 10.395660] sd 0:0:0:0: [sda] Attached SCSI disk
[ 10.837714] EXT4-fs (sda1): INFO: recovery required on readonly filesystem
[ 10.839680] EXT4-fs (sda1): write access will be enabled during recovery
[ 12.425693] EXT4-fs (sda1): orphan cleanup on readonly fs
[ 12.477635] EXT4-fs (sda1): 14 orphan inodes deleted
[ 12.479549] EXT4-fs (sda1): recovery complete
[ 12.498631] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)

If you don't get that sort of stuff then your HDD or USB carrier for your HDD is dead.

Re: USB HDD stopped working

Posted: Sat Apr 11, 2015 8:38 pm
by norbus2000a
I know what I'm supposed to get ;). If the disk or adapter is broken, why PC read/writes data without any problem?

Re: USB HDD stopped working

Posted: Sat Apr 11, 2015 9:39 pm
by DougieLawson
If it's a model A, A+ or B are you using a powered hub? If it's a B+ or 2B have you got

Code: Select all

max_usb_current=1
in the active config.txt? Or can your HDD carrier use an external power supply (possibly with a Y connector on the cable)?

Every USB device that you plug in should get some messages in dmesg even if the kernel fails to load a driver.

Re: USB HDD stopped working

Posted: Sun Apr 12, 2015 8:10 am
by norbus2000a
HDD is usuall computer's HDD powered from standalone PSU. Adapter connects only on SATA port. On PC it's detected by lsusb and dmesg gives proper messages. When I reconnect USB from PC to Pi B+, red LED is blinking slowly and there is no reaction. NOTHING. On PC works and on Pi is not. Why ???

Re: USB HDD stopped working

Posted: Sun Apr 12, 2015 10:50 am
by gkreidl
Even if has its own power supply it may use it only for 12V supply and get the 5V supply from the USB port. I had a similar problem, when connecting a powered HDD to a RPi B. With the B+ or B2 it works, if I set the high power USB option.

Re: USB HDD stopped working

Posted: Sun Apr 12, 2015 1:55 pm
by norbus2000a
Do tell me, how it can get power from USB by SATA cable??

Re: USB HDD stopped working

Posted: Sun Apr 12, 2015 4:17 pm
by gkreidl
norbus2000a wrote:Do tell me, how it can get power from USB by SATA cable??
SATA cable?

Re: USB HDD stopped working

Posted: Sun Apr 12, 2015 5:34 pm
by norbus2000a
AFAIK SATA cable pinout is DI-, DI+, DO-, DO+, 3xGND. Where is 5V? :o

Re: USB HDD stopped working

Posted: Sun Apr 12, 2015 6:03 pm
by gkreidl
You cannot connect a SATA cable to the RPi.

Re: USB HDD stopped working

Posted: Sun Apr 12, 2015 6:40 pm
by norbus2000a
But I'm using an adapter. Pi > USB > Adapter > SATA > Disk . Disk cannot use Pi 5V voltage because SATA don't have 5V rail.

Re: USB HDD stopped working

Posted: Sun Apr 12, 2015 9:34 pm
by AndrewdAzotus
When you connect the drive to the PC do you do it via SATA or the USB Adaptor?

Try connecting the drive through the USB Adaptor to the PC and see what you get...

Re: USB HDD stopped working

Posted: Mon Apr 13, 2015 1:11 pm
by norbus2000a
YES, I'm connecting the drive throught adaptor :mrgreen: . That's why it is so strange. Suddenly it stopped working on Pi, but on PC it's still working :o . USB on Pi works and it boots with flash memory instead of disk(with copied rootfs) on the same USB port.

Re: USB HDD stopped working

Posted: Mon Apr 13, 2015 9:34 pm
by ghellquist
Possible cause -- if you mount it as /dev/sda.

The reason is that the /dev/sda might (without any reason known to humans) change into /dev/sdb at any time. It is all in how USB works.
The solution is to mount the disc as UUID instead. (google: linux mount uuid )

// Gunnar

Re: USB HDD stopped working

Posted: Mon Apr 13, 2015 10:48 pm
by norbus2000a
I don't ask you how to mount it. Pi is NOT detecting the adapter. No dmesg or lsusb messages. On PC the adapter is detected.