Abe_Stew
Posts: 18
Joined: Mon Mar 16, 2015 9:48 pm

Mucous and NCurses

Fri Mar 20, 2015 9:27 am

Hi all,

I am currently trying to get mucous (a ncurses based client for museek-plus) to work on my raspberry pi. Whenever I start it from the terminal it initially loads fine but after a while the UI will be lost in a garble of text. Tried googling the issue and couldn't find a working solution - a couple of threads on other forums suggested it being a locales issues, though OPs said the suggested solutions didn't work for them. Tried them myself as well just to double-check and still being plagued by garbled text. Any ideas of how to fix this? Currently having to use tightvnc to access museek when away from home but would must rather be able to do everything I need from the terminal and uninstall tightvnc.

Cheers!

Abe.

Update: Noticed in one thread someone saying issue was mucous defaulting to iso-8859 no matter which locales are set. Went through mucous with nano and changed all instances of iso-8859 to utf-8 - there were a few lines where if it didn't detect the language setting it would set itself to iso-8859 so theoretically it should now set itself to utf-8. Sadly made no difference and still so much garbled text appearing that it is unusable.

Return to “Troubleshooting”