gregbert
Posts: 4
Joined: Thu Feb 19, 2015 5:45 pm

R Pi 2 Ethernet Port not working

Fri Feb 20, 2015 3:29 pm

Hi,

I just received my new raspberry Pi 2, but the ethernet port appears to be completely dead. I've used a tried-and-true power supply (which i've used on my other RPis), multiple ethernet cables, and tried two different imagines (snappy ubuntu and debian). Both of them see the ethernet hardware, but both report 'no carrier' to 'ip addr'.. the lights on the RPIs port don't light up either.

Should I conclude this is just a bad board? Anything you would recommend trying or debug information i could provide?

jdb
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 2123
Joined: Thu Jul 11, 2013 2:37 pm

Re: R Pi 2 Ethernet Port not working

Fri Feb 20, 2015 3:51 pm

Do keyboards and mice work?

If so can you provide the output of cat /proc/cpuinfo (take a pic of the screen if needed).
Rockets are loud.
https://astro-pi.org

gregbert
Posts: 4
Joined: Thu Feb 19, 2015 5:45 pm

Re: R Pi 2 Ethernet Port not working

Fri Feb 20, 2015 4:13 pm

jdb wrote:Do keyboards and mice work?

If so can you provide the output of cat /proc/cpuinfo (take a pic of the screen if needed).

Yes, they do - no problems with USB ports.

Here is the cpuinfo.. it looks like i can only update 64kb attachments here, so here is a link to the file on my dropbox

https://www.dropbox.com/s/3hno8m005hzlb ... 4.JPG?dl=0

User avatar
B.Goode
Posts: 8884
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: R Pi 2 Ethernet Port not working

Fri Feb 20, 2015 4:35 pm

gregbert wrote:Anything you would recommend trying or debug information i could provide?
Purely for the purposes of troubleshooting - not because I am trying to brainwash you into thinking it might be superior - why not install the Raspberry Pi Foundation approved and supported Raspbian as your Operating System?

When connected via a working utp 'ethernet' cable to a working port on a network which automatically assigns IP addresses via dhcp my experience has always been that an RPi (including a recent RPi2) 'just works' out of the box using Raspbian as the OS.

http://www.raspberrypi.org/downloads/

(Just to check that you have verified independently of the RPi that the network cable and network port you are using are functional?)

gregbert
Posts: 4
Joined: Thu Feb 19, 2015 5:45 pm

Re: R Pi 2 Ethernet Port not working

Fri Feb 20, 2015 5:01 pm

B.Goode wrote:
gregbert wrote:Anything you would recommend trying or debug information i could provide?
Purely for the purposes of troubleshooting - not because I am trying to brainwash you into thinking it might be superior - why not install the Raspberry Pi Foundation approved and supported Raspbian as your Operating System?

(Just to check that you have verified independently of the RPi that the network cable and network port you are using are functional?)
Hi - thanks for this post. no worries about brainwashing :-)

When I said debian in my original post, i actually meant raspbian - thats the first thing i tried.
I've tried 2 cables - both of which i also tried with my laptop (and they worked). i also tried plugging in directly to my router rather than through a secondary switch.. dead..dead..dead. no lights, no action.

User avatar
B.Goode
Posts: 8884
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: R Pi 2 Ethernet Port not working

Fri Feb 20, 2015 5:09 pm

gregbert wrote:I've tried 2 cables - both of which i also tried with my laptop (and they worked). i also tried plugging in directly to my router rather than through a secondary switch.. dead..dead..dead. no lights, no action.
I have nothing else to suggest. Maybe @jdb can provide some insight from the screenshot you provided.

User avatar
DougieLawson
Posts: 36322
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: R Pi 2 Ethernet Port not working

Fri Feb 20, 2015 5:19 pm

Have you checked the power supply how much does the voltage drop?
Try with just a keyboard no other USB devices. [CTRL]+[ALT]+[F2] gets a console login screen.

Is there

Code: Select all

auto lo
iface lo inet loopback
auto eth0
iface eth0 inet dhcp
in /etc/network/interfaces? The auto eth0 is there to get the interface active at boot time.

If not try sudo ifup eth0 or sudo ifconfig eth0 up 192.168.1.100 netmask 255.255.255.0 to bring the interface up.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

user007
Posts: 32
Joined: Wed Feb 11, 2015 8:17 pm

Re: R Pi 2 Ethernet Port not working

Fri Feb 20, 2015 6:42 pm

gregbert wrote:Hi,

I just received my new raspberry Pi 2, but the ethernet port appears to be completely dead. I've used a tried-and-true power supply (which i've used on my other RPis), multiple ethernet cables, and tried two different imagines (snappy ubuntu and debian). Both of them see the ethernet hardware, but both report 'no carrier' to 'ip addr'.. the lights on the RPIs port don't light up either.

Should I conclude this is just a bad board? Anything you would recommend trying or debug information i could provide?
Normally you may try for troubleshooting:
ifconfig eth0 up
ifconfig eth0
You may try also wireless USB card to connect to Internet.
You may try to install different RPI2 OS - just in case your OS is not a correct version for the RPI2. For example latest Raspbian OS version for RPI2.

jdb
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 2123
Joined: Thu Jul 11, 2013 2:37 pm

Re: R Pi 2 Ethernet Port not working

Fri Feb 20, 2015 7:26 pm

Hm.

Looks like you have a faulty Pi.

You have a PM (private message).
Rockets are loud.
https://astro-pi.org

DanPi
Posts: 2
Joined: Fri Feb 20, 2015 9:05 pm

Re: R Pi 2 Ethernet Port not working

Fri Feb 20, 2015 9:09 pm

I was also having this problem with the ethernet port. I decided to return this after checking the ethernet cables, the router, and the switch. Additionally I noticed that the wifi dongle only worked in the bottom right port (when facing the ports). I ordered a replacement Pi 2 Model B.

DanPi
Posts: 2
Joined: Fri Feb 20, 2015 9:05 pm

Re: R Pi 2 Ethernet Port not working

Sat Feb 21, 2015 7:06 pm

DanPi wrote:I was also having this problem with the ethernet port. I decided to return this after checking the ethernet cables, the router, and the switch. Additionally I noticed that the wifi dongle only worked in the bottom right port (when facing the ports). I ordered a replacement Pi 2 Model B.
I returned my faulty raspberry pi 2 model b and ordered a new one. The new one can play audio and has a working ethernet port so I would advise you do the same if you have these problems.

trininox
Posts: 3
Joined: Wed Feb 25, 2015 12:32 am

Re: R Pi 2 Ethernet Port not working

Wed Feb 25, 2015 12:35 am

I just got two new raspberry pi 2's in the mail yesterday, and both have this issue. zero activity on the ethernet regardless of what I try. fresh Noob install of Raspbian 1.4 and everything, I did a cable test from the switch when the Pi is connected, reports a short. Cable is fine on other devices. So I'm guessing this is going to be a thing?

User avatar
DougieLawson
Posts: 36322
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: R Pi 2 Ethernet Port not working

Wed Feb 25, 2015 12:45 am

Wire one pi directly to the other with a straight 568A-568A or 568B-568B cable (doesn't need a X-over with an autosensing port) and see if you can get a point to point interface running.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

trininox
Posts: 3
Joined: Wed Feb 25, 2015 12:32 am

Re: R Pi 2 Ethernet Port not working

Wed Feb 25, 2015 3:30 am

I spoke to soon, got home and connected both to my managed netgear switch and viola. connected and blinking away at me.
Not sure what was different about the netgear smart switch at work. I thought some kind of Green ethernet feature but I made sure they were all off..

Either way, disregard! Onward!

User avatar
DougieLawson
Posts: 36322
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: R Pi 2 Ethernet Port not working

Wed Feb 25, 2015 9:33 am

Your switch at work may have MAC filtering enabled, to prevent unauthorised devices being connected.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

afremont
Posts: 22
Joined: Wed Jan 28, 2015 1:32 pm

Re: R Pi 2 Ethernet Port not working

Wed Feb 25, 2015 11:24 am

I might be missing something, but I have never seen MAC filtering stop a link light from turning on. It would have to establish a link before it could know what the MAC address is, right? The cable test reporting a short sounds like a soldering problem. How thorough is production testing? I can imagine that they use some kind of test jig, do they actually plug a network cable into the jack though?
"Experience: It's what you get when you were expecting something else"

User avatar
RaTTuS
Posts: 10493
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: R Pi 2 Ethernet Port not working

Wed Feb 25, 2015 11:31 am

afremont wrote:I might be missing something, but I have never seen MAC filtering stop a link light from turning on. It would have to establish a link before it could know what the MAC address is, right? The cable test reporting a short sounds like a soldering problem. How thorough is production testing? I can imagine that they use some kind of test jig, do they actually plug a network cable into the jack though?
trininox
having hijacked the thread * reported a problem which he then reported as being fixed [it possible was a bad NIC lead he used]

MAC filtering would of lit the RPi NIC port - but a bad cable may not

in the RPI test jig the NIC are tested

*I was going to say OP but ....
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

User avatar
B.Goode
Posts: 8884
Joined: Mon Sep 01, 2014 4:03 pm
Location: UK

Re: R Pi 2 Ethernet Port not working

Wed Feb 25, 2015 11:37 am

afremont wrote:I might be missing something, but I have never seen MAC filtering stop a link light from turning on. It would have to establish a link before it could know what the MAC address is, right? The cable test reporting a short sounds like a soldering problem. How thorough is production testing? I can imagine that they use some kind of test jig, do they actually plug a network cable into the jack though?
The perils of thread highjacking! There are now 3 (I think) enquirers in this thread. The most recent, @trininox, does not mention the link status light. Nor is it clear whether the cable tested at work is the same as the one used at home. I think @Dougie's hypothesis is at least plausible, until discounted by hard facts.

[Apparent duplicate of another reply posted as I was typing this up... ]

afremont
Posts: 22
Joined: Wed Jan 28, 2015 1:32 pm

Re: R Pi 2 Ethernet Port not working

Wed Feb 25, 2015 12:10 pm

Yeah, I see now. Sorry to interject any confusion. gregbert said he had no lights at all, but trinonos only specified no activity. I wasn't attempting to hijack the thread to get a question answered, just offering up my personal experience with network hardware and software. I was primarily being rhetorical with the testing question.
"Experience: It's what you get when you were expecting something else"

trininox
Posts: 3
Joined: Wed Feb 25, 2015 12:32 am

Re: R Pi 2 Ethernet Port not working

Wed Feb 25, 2015 5:03 pm

I'll be more specific and say my initial problem was identical to the initially reported issue, no lights, no connection or blinking activity light, on the ethernet port. This is why I chose to add my 2 cents, and 'hijack' the thread as you say. I did use the same cable at work as at home.

As I said disregard as I found with further testing the Pi's are operating normally. I'll have to investigate what's going on with the switch (No MAC filtering or features that shutdown ports enabled).

The "short" test result isn't unheard of, just a curious point. My Xbox at home when powered off will test with a short. The unplugged cables however tested fine with "open", at the appropriate length.

So for those googling as I did for such an issue, there you have it. Again, onward. :roll:

sonium
Posts: 25
Joined: Mon Feb 11, 2013 1:30 pm

Re: R Pi 2 Ethernet Port not working

Tue Mar 03, 2015 9:50 pm

I just want to state that I also have a Raspberry Pi 2 with no working ethernet connection.
It is connected to switch and all other devices work without problems, using different cables
I unfortunately only have a headless setup for the pi2.
It suspect this is a hardware problem on the pi2-side.

User avatar
DougieLawson
Posts: 36322
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: R Pi 2 Ethernet Port not working

Tue Mar 03, 2015 10:15 pm

Get a fresh microSD card and a copy of the 2015-02-16 Raspbian (or NOOBS/Raspbian) on it.

Try wiring it directly to your laptop. Code

Code: Select all

auto lo
iface lo inet loopback
auto eth0
iface eth0 inet static
address 169.254.3.14
netmask 16
in /etc/network/interfaces, so you have a fixed and known IP address.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

sonium
Posts: 25
Joined: Mon Feb 11, 2013 1:30 pm

Re: R Pi 2 Ethernet Port not working

Tue Mar 03, 2015 10:39 pm

Ok, reinstalling the SD-card fixed the issue. Thanks a lot.

frankamente
Posts: 1
Joined: Fri May 08, 2015 11:40 am

Re: R Pi 2 Ethernet Port not working

Wed Jun 10, 2015 10:59 pm

Same problem, and same solution. Reinstalling the SD. Thanks to all.

Pilsener
Posts: 58
Joined: Thu Jan 03, 2013 3:25 pm

Re: R Pi 2 Ethernet Port not working

Wed Jul 08, 2015 11:56 am

Just got 2 RPi 2 today, and neither had working LAN ports.
Tried some ifdown/ifup without result.
Then I googled around a bit and read that it could be cable related, although I used the same cable which had worked with 2 models of RPi 1.
So I connected another cable, and the LAN port started to work.
Now for the real mystery: I reconnected the old cable and to my surprise, it also worked now.

Return to “Troubleshooting”