russalex
Posts: 11
Joined: Thu Feb 19, 2015 6:52 am

Pi 2 INTERNET PROBLEMS VERY SLOW !!! (SOLVED)

Fri Feb 20, 2015 5:44 am

I am still straggling to get my Pi2 working properly. Created SD card with latest Rasbian, booted successfully with Ethernet port plugged in. When opening a browser it takes about 3 min to load a google page, extremely slow!!! I got 30MB i-net @ home, and all of my other devices are flying... Am I missing something here? I already spend a night with "0" results - rebooting a cable modem, liksys E3000 router, Pi 2, changing Eth ports on router, etc... Same results with Ethernet cable plugged in or using WiFi dongle. I tried to ping google.com or yahoo.com got reply over 300ms (thats a lot), pinged from my mac and got around 40ms. Is it a DNS issue? Not sure what to do next... Please HELP!
Thanks in advance!

User avatar
paulcaseyjr
Posts: 28
Joined: Wed Jun 04, 2014 1:23 pm
Location: New Hampshire
Contact: Website

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!!

Fri Feb 20, 2015 10:14 am

What do sort of ping times are you getting from the Pi to another machine on your network?


russalex
Posts: 11
Joined: Thu Feb 19, 2015 6:52 am

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!!

Fri Feb 20, 2015 2:54 pm

paulcaseyjr wrote:What do sort of ping times are you getting from the Pi to another machine on your network?
Hi Paul, looks like Im getting quick reply inside my network, 192.168.1.151 is my CentOS linux server, the problem is to go outside... Re-burned the card many times, reinstalling Raspbian, tried the NOOBS way also, same story. Never seen it in my life... I dont know what to think... If the DNS resolution did not work, I could not go public at all. But I still can load google, yahoo, etc pages but in 3-5 min...

pi@raspberrypi ~ $ ping 192.168.1.151
PING 192.168.1.151 (192.168.1.151) 56(84) bytes of data.
64 bytes from 192.168.1.151: icmp_req=1 ttl=64 time=13.9 ms
64 bytes from 192.168.1.151: icmp_req=2 ttl=64 time=4.13 ms
64 bytes from 192.168.1.151: icmp_req=3 ttl=64 time=1.81 ms
64 bytes from 192.168.1.151: icmp_req=4 ttl=64 time=8.49 ms
64 bytes from 192.168.1.151: icmp_req=5 ttl=64 time=13.8 ms
64 bytes from 192.168.1.151: icmp_req=6 ttl=64 time=2.30 ms
64 bytes from 192.168.1.151: icmp_req=7 ttl=64 time=1.32 ms

gkreidl
Posts: 6326
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!!

Fri Feb 20, 2015 3:00 pm

Use another DNS server, either on your router or from the RPi directly.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

russalex
Posts: 11
Joined: Thu Feb 19, 2015 6:52 am

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!!

Fri Feb 20, 2015 3:06 pm

THJ wrote:I had the same problem, check this one: http://www.raspberrypi.org/forums/viewt ... 28&t=99935
and maybe also this: http://www.raspberrypi.org/forums/viewtopic.php?t=99985
/T
Thanks guys for your replies!
Looks like you solved your problem by switching network cables around: " I moved the network cable from my last router to the second last (there are two routers in a row)... and guess what?Now it works! "

In my case I only have one router with 4 ports out, tried switching as well... All my devices Wired or Wireless are working without complains but Pi 2... So strange! I mentioned earlier by connecting Pi2 using wireless USB dongle, same story...

unameme
Posts: 5
Joined: Fri Feb 13, 2015 11:50 am

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!!

Fri Feb 20, 2015 11:04 pm

I have the same problem, I thought it's the web browser fault, and left it as I don't need to browse internett on Rpi2 right now, but I can confirm, that browser it's very slow on Rpi2.
in terminal speed is up to 800KiB/s, not too bad :)

gkreidl
Posts: 6326
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!!

Sat Feb 21, 2015 8:34 am

unameme wrote:I have the same problem, I thought it's the web browser fault, and left it as I don't need to browse internett on Rpi2 right now, but I can confirm, that browser it's very slow on Rpi2.
in terminal speed is up to 800KiB/s, not too bad :)
Test with another bowser which doesn't depend on webkit, e. g. iceweasel.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

User avatar
DougieLawson
Posts: 39117
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!!

Sat Feb 21, 2015 8:37 am

If this is wired is your router switching to half-duplex or degrading to 10Mbps?

Edit: another thought, can you reach all the nameservers defined in /etc/resolv.conf. If any are unreachable or don't answer DNS queries then your network performance can take an unexplained nosedive.
https://www.safaribooksonline.com/libra ... 09s06.html has an option for reducing the impact of failed DNS queries.
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

russalex
Posts: 11
Joined: Thu Feb 19, 2015 6:52 am

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!!

Sat Feb 21, 2015 5:38 pm

gkreidl wrote:
unameme wrote:I have the same problem, I thought it's the web browser fault, and left it as I don't need to browse internett on Rpi2 right now, but I can confirm, that browser it's very slow on Rpi2.
in terminal speed is up to 800KiB/s, not too bad :)
Test with another bowser which doesn't depend on webkit, e. g. iceweasel.
I actually installed Chromium browser yesterday and there is a huge improvement - double faster, but still slow. I not sure how fast does the browser supposed to be compare to decent computer... By having 4 900Mhz cores and 1GB of RAM Im expecting a decent performance 2-5sec page load...

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 13087
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!!

Sat Feb 21, 2015 5:58 pm

I doubt any browser on the PI is already optimized to fully use the new processor. Its been only out to developers for a few weeks people!
don't expect miracles just yet.

gkreidl
Posts: 6326
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!!

Sat Feb 21, 2015 6:04 pm

mahjongg wrote:I doubt any browser on the PI is already optimized to fully use the new processor. Its been only out to developers for a few weeks people!
I doubt that compiling the libraries for ARM7 will provide a much better performance. If google needs 3 minutes to load the OP has really another problem; it loads within a second here.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

russalex
Posts: 11
Joined: Thu Feb 19, 2015 6:52 am

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!!

Sat Feb 21, 2015 6:10 pm

mahjongg wrote:I doubt any browser on the PI is already optimized to fully use the new processor. Its been only out to developers for a few weeks people!
don't expect miracles just yet.
How could you explain this on the regular Pi overlocked though, but still: https://www.youtube.com/watch?v=v0pLdY2Ap5Q
When I load any of this pages on my Pi2 I can go and have some tea or take a nap until the page is completely loaded... At the same time my network speed allows me to play 4K videos from the Mac...
I think my unit is defective or so as I see other fox browsing the web with no issues and on their OLDER Pi models...

russalex
Posts: 11
Joined: Thu Feb 19, 2015 6:52 am

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!!

Sat Feb 21, 2015 6:26 pm

DougieLawson wrote:If this is wired is your router switching to half-duplex or degrading to 10Mbps?

Edit: another thought, can you reach all the nameservers defined in /etc/resolv.conf. If any are unreachable or don't answer DNS queries then your network performance can take an unexplained nosedive.
https://www.safaribooksonline.com/libra ... 09s06.html has an option for reducing the impact of failed DNS queries.
I did not really notice any speed degradation. The resolve.conf looks good and matches my routers and the other devices settings... Im satisfied with command line speed and it seems to be normal now. The biggest problem is my browser... Feels like I moved back to 90's to enjoy great Dial-up speed even worse in my case.

I noticed one thing! When I tried to install Raspbian from Noobs and prior installation I used Web Browser and it worked very fast as it should. But after installation became very SLOW...

User avatar
DougieLawson
Posts: 39117
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!! (SOLVED)

Sat Feb 21, 2015 6:35 pm

Are you running epiphany or some other browser?
Epiphany (when it works) is the only one that gets almost acceptable performance on an RPi2B.

All browsing with anything other than curl, wget or lynx on an RPi1 (all four models) is an absolute nonstarter.
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

russalex
Posts: 11
Joined: Thu Feb 19, 2015 6:52 am

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!! (SOLVED)

Sat Feb 21, 2015 6:49 pm

DougieLawson wrote:Are you running epiphany or some other browser?
Epiphany (when it works) is the only one that gets almost acceptable performance on an RPi2B.

All browsing with anything other than curl, wget or lynx on an RPi1 (all four models) is an absolute nonstarter.
Im running Epiphany Web Browser which is very slow for me (google loads in minutes). Per some fox suggestions I installed Chromium Web Browses and it works a lot faster in my case but not as fast as it should (google loads in about 10 seconds)...
I was thinking from power perspective maybe my Pi doesn't get enough juice??? Im running it from the iPhones 5V 1Amp charger, seems to be working ok. Why I mentioned that because I see a lot of people are ordering 2Amps power supplies for their Pi's and maybe I should get one as well. I just don't know what else to think... Sorry!

gkreidl
Posts: 6326
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!! (SOLVED)

Sat Feb 21, 2015 7:08 pm

With all browsers I tested google loads within less than a second on a Pi2.

There must be some kind of problem with your installation.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

russalex
Posts: 11
Joined: Thu Feb 19, 2015 6:52 am

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!! (SOLVED)

Sun Feb 22, 2015 9:13 pm

gkreidl wrote:With all browsers I tested google loads within less than a second on a Pi2.

There must be some kind of problem with your installation.
Solved my problem by installing unofficial Ubuntu 14.04 image. Running Lubuntu Desktop environment on my Pi2 right now. WiFi, Sound everything works, All browsers are flying, pretty happy now! Xubuntu works too, but looks like is taking little more GPU resources but still usable.
I recommend of trying just follow this link: http://www.finnie.org/2015/02/16/raspbe ... available/

Thanks guys for your replies!

russalex
Posts: 11
Joined: Thu Feb 19, 2015 6:52 am

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!! (SOLVED)

Sun Feb 22, 2015 9:14 pm

DougieLawson wrote:Are you running epiphany or some other browser?
Epiphany (when it works) is the only one that gets almost acceptable performance on an RPi2B.

All browsing with anything other than curl, wget or lynx on an RPi1 (all four models) is an absolute nonstarter.

Solved my problem by installing unofficial Ubuntu 14.04 image. Running Lubuntu Desktop environment on my Pi2 right now. WiFi, Sound everything works, All browsers are flying, pretty happy now! Xubuntu works too, but looks like is taking little more GPU resources but still usable.
I recommend of trying just follow this link: http://www.finnie.org/2015/02/16/raspbe ... available/

Thanks guys for your replies!

faisal
Posts: 2
Joined: Sat Mar 07, 2015 3:06 am

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!! (SOLVED)

Sat Mar 07, 2015 3:09 am

Can you add openelec as a dual boot to this ubuntu? Not sure how to do this.
Can I add this ubuntu image to noobs?

DirkS
Posts: 10362
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!! (SOLVED)

Sat Mar 07, 2015 9:46 am

faisal wrote:Can you add openelec as a dual boot to this ubuntu? Not sure how to do this.
Can I add this ubuntu image to noobs?
Totally unrelated to this topic.
Please create a new one.

ArnieO
Posts: 1
Joined: Sun Mar 15, 2015 10:58 pm

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!! (SOLVED)

Sun Mar 15, 2015 11:02 pm

I have a RPi2 with a fairly fresh Raspbian installation (two days ago).
Epiphany is painstakingly slow (=useless for all practical purposes)
So I installed Chromium. On for instance Google Maps it has a speed that is close to my PC (i.e. fully useable).

gkreidl
Posts: 6326
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany

Re: Pi 2 INTERNET PROBLEMS VERY SLOW !!! (SOLVED)

Mon Mar 16, 2015 8:31 am

ArnieO wrote:I have a RPi2 with a fairly fresh Raspbian installation (two days ago).
Epiphany is painstakingly slow (=useless for all practical purposes)
So I installed Chromium. On for instance Google Maps it has a speed that is close to my PC (i.e. fully useable).
Read this and the following posts ...
http://www.raspberrypi.org/forums/viewt ... 25#p635835
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer

Return to “Troubleshooting”