fire3k
Posts: 3
Joined: Tue Feb 17, 2015 5:51 pm

RPI 2, LIRC -> Sending KEYS

Wed Feb 18, 2015 5:38 pm

Ok, i am quite new to thhis forum (also to PI GPIO usage) but i think i tried everything i've found to fix the Problem ....

As described, i have a PI 2, Latest Updates und such are installed, Lirc is running (Recive works, send not)

I have build a few IR Transmitters to test different way's, but i cannot get Lirc to send Remote codes.

Here's my conf:

config.txt

# Uncomment this to enable the lirc-rpi module
device_tree_overlay=lirc-rpi
device_tree_param=gpio_out_pin=17
device_tree_param=gpio_in_pin=18
device_tree_param=gpio_in_pull=down

as said before, recive is not a problem, only sending with IR doesn't work, when i send some recorded
IR Signal the control LED only flickers very low.

I searched the forums, the net a few day's but i cannot find a soloution, has anyone here running LIRC
on tje RPI 2 with Reciving AND sending?

thx

elmicha
Posts: 27
Joined: Tue Jul 03, 2012 4:43 pm

Re: RPI 2, LIRC -> Sending KEYS

Wed Feb 18, 2015 8:34 pm

You are not alone!

Here is another thread where a few people (including me) have the same problem: receiving works, sending does not. It worked on the RPi1, and it still works on the RPi1 with the latest kernel and the device tree.

theceej
Posts: 7
Joined: Sat Feb 07, 2015 5:13 pm

Re: RPI 2, LIRC -> Sending KEYS

Wed Feb 18, 2015 9:04 pm

fire3k wrote:Ok, i am quite new to thhis forum (also to PI GPIO usage) but i think i tried everything i've found to fix the Problem ....

As described, i have a PI 2, Latest Updates und such are installed, Lirc is running (Recive works, send not)

I have build a few IR Transmitters to test different way's, but i cannot get Lirc to send Remote codes.

Here's my conf:

config.txt

# Uncomment this to enable the lirc-rpi module
device_tree_overlay=lirc-rpi
device_tree_param=gpio_out_pin=17
device_tree_param=gpio_in_pin=18
device_tree_param=gpio_in_pull=down

as said before, recive is not a problem, only sending with IR doesn't work, when i send some recorded
IR Signal the control LED only flickers very low.

I searched the forums, the net a few day's but i cannot find a soloution, has anyone here running LIRC
on tje RPI 2 with Reciving AND sending?

thx
This has been fixed with the latest kernel from rpi-update!

elmicha
Posts: 27
Joined: Tue Jul 03, 2012 4:43 pm

Re: RPI 2, LIRC -> Sending KEYS

Wed Feb 18, 2015 9:47 pm

Ah yes, thank you, you are correct, now it works!

The output of "uname -a" now has "3.18.7-v7+ #756".

fire3k
Posts: 3
Joined: Tue Feb 17, 2015 5:51 pm

Re: RPI 2, LIRC -> Sending KEYS

Wed Feb 18, 2015 11:19 pm

wow, thx for the hint, i think the new kernel is fresh :)

anyways, it works now .....

thank you

Return to “Troubleshooting”