hecsys
Posts: 10
Joined: Sat Feb 14, 2015 6:19 am

GDBus.Error:org.freedesktop.PolicyKit1

Sat Feb 14, 2015 6:24 am

I just got my Raspberry Pi 2 and after loading Raspbian every time I boot I get this error

GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed:
Cannot determine user of subject

I also having problem with my wireless N adapter... I can not connect to the internet with it.

Please I need help :)

User avatar
DougieLawson
Posts: 35358
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: GDBus.Error:org.freedesktop.PolicyKit1

Sat Feb 14, 2015 6:04 pm

Ignore it, it's not important and will be fixed with a future update.
Note: Having anything remotely humorous in your signature is completely banned on this forum.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

hecsys
Posts: 10
Joined: Sat Feb 14, 2015 6:19 am

Re: GDBus.Error:org.freedesktop.PolicyKit1

Tue Feb 17, 2015 12:30 am

Thank you DougieLawson! :)

Buda
Posts: 6
Joined: Thu Feb 28, 2013 8:50 am

Re: GDBus.Error:org.freedesktop.PolicyKit1

Fri Feb 20, 2015 8:34 am

open a Terminal, Type

Code: Select all

lxsession-edit
to open Desktop Session Settings dialog box and uncheck LXPolKit. Click OK. then reboot.

hecsys
Posts: 10
Joined: Sat Feb 14, 2015 6:19 am

Re: GDBus.Error:org.freedesktop.PolicyKit1

Fri Feb 20, 2015 3:26 pm

Thank you Buda, I will try this and let you know how it goes.

Tentbat
Posts: 2
Joined: Mon Dec 29, 2014 6:11 am

Re: GDBus.Error:org.freedesktop.PolicyKit1

Mon Feb 23, 2015 12:26 am

Buda wrote:open a Terminal, Type

Code: Select all

lxsession-edit
to open Desktop Session Settings dialog box and uncheck LXPolKit. Click OK. then reboot.
This worked like a charm! Thanks. It solved a frustrating problem that, while it had no functional implications, did manage to eat up a lot of time with solutions that didn't work.

Does unchecking LXPolKit have any consequence? Is there value in reinstating it at a later point (after an update) or was it supposed to be off?

Thanks again,

Bret

hobbsy
Posts: 7
Joined: Fri Sep 07, 2012 7:32 am

Re: GDBus.Error:org.freedesktop.PolicyKit1

Thu Feb 26, 2015 2:42 pm

Hi, just got my RPi2 and installed Raspbian. I also got the same pop-up error on entering the desktop but it seems "lxsession-edit" and unticking the "LXPolKit" box makes the error go away. Thanks.

hecsys
Posts: 10
Joined: Sat Feb 14, 2015 6:19 am

Re: GDBus.Error:org.freedesktop.PolicyKit1

Fri Feb 27, 2015 3:29 am

It works!!!! awesome! thank you guys :D :D

Thehamburglar01
Posts: 1
Joined: Fri Mar 06, 2015 7:27 pm

Re: GDBus.Error:org.freedesktop.PolicyKit1

Fri Mar 06, 2015 7:33 pm

Typing the command and unchecking the box worked for me as well. I hadn't noticed the error prior to setting TightVNCServer to start automatically on boot.

MrTreeHugger
Posts: 1
Joined: Sun Aug 27, 2017 12:09 pm

Re: GDBus.Error:org.freedesktop.PolicyKit1

Sun Aug 27, 2017 12:12 pm

Buda wrote:
Fri Feb 20, 2015 8:34 am
open a Terminal, Type

Code: Select all

lxsession-edit
to open Desktop Session Settings dialog box and uncheck LXPolKit. Click OK. then reboot.
Hello, I've got the same problem when connecting via remote desktop. When I type lxsession-edit I don't have the option LXPolKit... Is there anything else to do?

Return to “Troubleshooting”