moses
Posts: 3
Joined: Tue Jul 24, 2012 10:21 am

hdmi_ignore_cec won't work as expected

Tue Jul 24, 2012 11:45 am

Hi,
I have attached my Raspberry Pi to my Samsung TV. The Raspi is also powered by the USB port of the TV. I love this solution because the Raspi starts up, when I switch on my TV and powers off when the TV goes off. The Raspi should act as a media player in this situation.
Everything works fine also the CEC function. So I can control the media player with the Samsung IR control.
But one thing is a little bit annoying. When I switch on my TV the Raspi starts as described above and the TV always switch to the HDMI input of the Raspi. This is, what I don't want.
I tried to use "hdmi_ignore_cec" in the config.txt to disable this. But this option disables the whole CEC function of the Raspi. But I need CEC for controlling the media player.
Is there any chance to use CEC but to disable the auto switching to the HDMI input of the Raspi?

I tried the things above with an actual OpenELEC build and with ArchLinux.

moses

User avatar
Paul Webster
Posts: 681
Joined: Sat Jul 30, 2011 4:49 am
Location: London, UK

Re: hdmi_ignore_cec won't work as expected

Tue Jul 24, 2012 2:30 pm

There might be a setting in your TV that can be changed to stop it switching.

moses
Posts: 3
Joined: Tue Jul 24, 2012 10:21 am

Re: hdmi_ignore_cec won't work as expected

Tue Jul 24, 2012 2:41 pm

I didn't find any setting for this. Perhaps I look at the wrong places. I appreciate every hint. My TV Model is a Samsung UE32D5700.

drgeoff
Posts: 7220
Joined: Wed Jan 25, 2012 6:39 pm

Re: hdmi_ignore_cec won't work as expected

Tue Jul 24, 2012 5:49 pm

As Paul Webster hints, the auto selection of the HDMI-CEC input is a feature of the TV, not the RPi. I had a scan through the Samsung manual but didn't find any mention of disabling it.

moses
Posts: 3
Joined: Tue Jul 24, 2012 10:21 am

Re: hdmi_ignore_cec won't work as expected

Wed Jul 25, 2012 7:23 am

I tought the switching was initiated by the Raspi.
My satelitte receiver has a configuration where I can change this behaviour.
There is also a command "vc_cec_send_ActiveSource" which was used by the rpi-cecd daemon (which is now removed).

bspi
Posts: 16
Joined: Sun Oct 21, 2012 1:27 pm

Re: hdmi_ignore_cec won't work as expected

Tue Nov 06, 2012 12:28 pm

I love hdmi-cec functionality to death but this feature is really annoying. I wish there was a way to disable it.

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5097
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: hdmi_ignore_cec won't work as expected

Tue Nov 06, 2012 12:37 pm

http://elinux.org/RPi_config.txt

Code: Select all

hdmi_ignore_cec_init Doesn't sent initial active source message. Avoids bringing (CEC enabled) TV out of standby and channel switch when rebooting.

 hdmi_ignore_cec_init=1

bspi
Posts: 16
Joined: Sun Oct 21, 2012 1:27 pm

Re: hdmi_ignore_cec won't work as expected

Tue Nov 06, 2012 3:11 pm

dom wrote:http://elinux.org/RPi_config.txt

Code: Select all

hdmi_ignore_cec_init Doesn't sent initial active source message. Avoids bringing (CEC enabled) TV out of standby and channel switch when rebooting.

 hdmi_ignore_cec_init=1
Should i just add that line to the config.txt? I did that but it changes nothing. Heres how my config.txt looks now:

Code: Select all

arm_freq=840
core_freq=375
disable_overscan=1	

#hdmi_force_hotplug=1
hdmi_ignore_cec_init=1
force_turbo=0
gpu_mem_256=128
gpu_mem_512=256

dom
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 5097
Joined: Wed Aug 17, 2011 7:41 pm
Location: Cambridge

Re: hdmi_ignore_cec won't work as expected

Tue Nov 06, 2012 4:39 pm

bspi wrote:Should i just add that line to the config.txt? I did that but it changes nothing. Heres how my config.txt looks now:
Yes. With that present Raspberry Pi won't send an "active source" CEC message.

If your TV is still changing channels (is it? At boot up?) then I don't think it is due to CEC. Possibly it just monitors an output on the hdmi.

bspi
Posts: 16
Joined: Sun Oct 21, 2012 1:27 pm

Re: hdmi_ignore_cec won't work as expected

Tue Nov 06, 2012 4:44 pm

It is coming up when i reboot the pi from the xbmc menu, and when i plug/unplug the pi. I am using the hdmi/dvi port on the tv. I will try a different port and see what happens.

bspi
Posts: 16
Joined: Sun Oct 21, 2012 1:27 pm

Re: hdmi_ignore_cec won't work as expected

Tue Nov 06, 2012 6:06 pm

dom wrote:
bspi wrote:Should i just add that line to the config.txt? I did that but it changes nothing. Heres how my config.txt looks now:
Yes. With that present Raspberry Pi won't send an "active source" CEC message.

If your TV is still changing channels (is it? At boot up?) then I don't think it is due to CEC. Possibly it just monitors an output on the hdmi.
Just tried another hdmi port and it is still autoswitching. I am using xbian, not sure if i have to do something differently?

bspi
Posts: 16
Joined: Sun Oct 21, 2012 1:27 pm

Re: hdmi_ignore_cec won't work as expected

Sun Nov 18, 2012 1:11 pm

To anyone who still has this problem, you can fix this by adding

Code: Select all

hdmi_ignore_cec_init=1
in the config.txt, AND by going to XBMC and then system>setting>system>input devices>peripherals>raspberry pi cec adapter and in here un-tick "make XBMC the active source".
The combination of these two changes disables the autoswitch.
Thanks to:
http://openelec.tv/forum/124-raspberry- ... ce-on-boot

Return to “Troubleshooting”

Who is online

Users browsing this forum: Bing [Bot], klricks and 45 guests