allanoptical
Posts: 8
Joined: Mon Nov 16, 2015 2:08 pm

Problem with SDcopier

Sun Aug 01, 2021 11:40 am

I have a Pi 4 which has been setup to boot from a USB device but at the moment I am booting from a mSD card in the on board card reader.

I wish to make a copy of the boot card using SDCopier but it fails. When I run it I am offered /dev/mmcblk0 as the source and two destinations /dev/sda and /dev/sdb but there is only one card inserted to be copied to. When I select either of these and start the run I see the usual warning messages but then get a message "Could not create partition" This also corrupts the card.

Two separate mSD cards have been tried. One has been reformatted using Raspberry Pi Imager and I have written a simple text file to it on the Pi. I therefore think the cards are ok.

I suspect I am making a silly mistake but cannot see what it is. Any advice would be welcome.
Thanks in advance

pidd
Posts: 2508
Joined: Fri May 29, 2020 8:29 pm
Location: Wirral, UK
Contact: Website

Re: Problem with SDcopier

Sun Aug 01, 2021 4:20 pm

Can you show results of following when booted from SD card and the target SD card is in the reader.

Code: Select all

lsblk

RonR
Posts: 2380
Joined: Tue Apr 12, 2016 10:29 pm
Location: US

Re: Problem with SDcopier

Sun Aug 01, 2021 6:26 pm

allanoptical wrote:
Sun Aug 01, 2021 11:40 am
I have a Pi 4 which has been setup to boot from a USB device but at the moment I am booting from a mSD card in the on board card reader.

I wish to make a copy of the boot card using SDCopier but it fails.

Assuming that you're running Raspberry Pi OS...

usb-boot will copy your running system (SD card or USB device) to a USB device (including an SD card in a USB adapter).

image-backup will create an image file of your running system that can then be written to an SD card or USB device.

User avatar
FTrevorGowen
Forum Moderator
Forum Moderator
Posts: 6388
Joined: Mon Mar 04, 2013 6:12 pm
Location: Bristol, U.K.
Contact: Website

Re: Problem with SDcopier

Sun Aug 01, 2021 7:53 pm

allanoptical wrote:
Sun Aug 01, 2021 11:40 am
I have a Pi 4 which has been setup to boot from a USB device but at the moment I am booting from a mSD card in the on board card reader.

I wish to make a copy of the boot card using SDCopier but it fails. When I run it I am offered /dev/mmcblk0 as the source and two destinations /dev/sda and /dev/sdb but there is only one card inserted to be copied to. When I select either of these and start the run I see the usual warning messages but then get a message "Could not create partition" This also corrupts the card.

...
What are you trying to copy to? Is it another uSD card in a USB card reader/writer with more than one slot? (There was a thread a while ago where that led to two destination devices and caused similar "confusion")
Trev.
Still running Raspbian Jessie or Stretch on some older Pi's (an A, B1, 2xB2, B+, P2B, 3xP0, P0W, 2xP3A+, P3B, B+, and a A+) but Buster on the P3B+, P4B's & P400. See: https://www.cpmspectrepi.uk/raspberry_pi/raspiidx.htm

allanoptical
Posts: 8
Joined: Mon Nov 16, 2015 2:08 pm

Re: Problem with SDcopier

Mon Aug 02, 2021 8:53 am

Thank all you for your comments.
I am using a an adaptor that will take either a full SD card or a micro so this may be the problem.
These comments do give me somewhere to start again.

Return to “Troubleshooting”