satirical wizard
Posts: 4
Joined: Sat May 08, 2021 11:15 pm

Pi 4B not booting, Green LED blink speed tied to temperature?

Sat May 08, 2021 11:43 pm

Got my Pi 4B, and got linux running on it, but after a while, when I was editing a config file, it decided to reboot itself.
Since then it hasn't booted again (tried raspbian, lite, the bootloader recovery, and alpine).
It turns on with a solid green light, but after a half a minute or so it will begin blinking, and slowly speed up the blinking rate until it "balances out".
Now if, however, I pull the plug and put it back in, it will keep blinking at the speed it previously was, leading me to believe the blinking is tied to the pi's temperature.
Video showcasing exactly what's happening: https://files.catbox.moe/uzybhq.webm
3) Please include which distro/SD card image you are using, and which version of that distro/image
Started with raspbian to test and update, then installed Alpine, the latest of both as of 2-3 weeks ago.
Tested with two cards, a 2gb kingston, and a 32gb sandisk ultra class 10, but the blinking happens even without a card inside the pi.

Can't say for sure but it was probaby inside the case when it started.
Last edited by satirical wizard on Mon May 10, 2021 2:16 pm, edited 1 time in total.

fruitoftheloom
Posts: 26820
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Pi 4B not booting, Green LED blink speed tied to temperature?

Sun May 09, 2021 5:17 pm

satirical wizard wrote:
Sat May 08, 2021 11:43 pm
Got my Pi 4B, and got linux running on it, but after a while, when I was editing a config file, it decided to reboot itself.
Since then it hasn't booted again (tried raspbian, lite, the bootloader recovery, and alpine).
It turns on with a solid green light, but after a half a minute or so it will begin blinking, and slowly speed up the blinking rate until it "balances out".
Now if, however, I pull the plug and put it back in, it will keep blinking at the speed it previously was, leading me to believe the blinking is tied to the pi's temperature.
Video showcasing exactly what's happening: https://files.catbox.moe/uzybhq.webm
3) Please include which distro/SD card image you are using, and which version of that distro/image
Started with raspbian to test and update, then installed Alpine, the latest of both as of 2-3 weeks ago.
tested with two cards, a 2gb kingston, and a 32gb sandisk ultra class 10

Can't say for sure but it was probaby inside the case when it started.

Temperature and Power have pop up warnings:

https://www.raspberrypi.org/documentati ... g-icons.md
The information is out there....you just have to let it in.

My other Linux machines: ChromeBox
https://www.aliexpress.com/item/32966393971.html
& Stone Desktop Intel CoreDuo circa 2010

satirical wizard
Posts: 4
Joined: Sat May 08, 2021 11:15 pm

Re: Pi 4B not booting, Green LED blink speed tied to temperature?

Sun May 09, 2021 9:43 pm

Temperature and Power have pop up warnings:
There is no display dude. It won't boot.
And I didn't suggest it is overheating (definitely isn't with this case), only that the temperature is linked to the blink speed.

fruitoftheloom
Posts: 26820
Joined: Tue Mar 25, 2014 12:40 pm
Location: Delightful Dorset

Re: Pi 4B not booting, Green LED blink speed tied to temperature?

Mon May 10, 2021 6:38 am

satirical wizard wrote:
Sun May 09, 2021 9:43 pm
Temperature and Power have pop up warnings:
There is no display dude. It won't boot.
And I didn't suggest it is overheating (definitely isn't with this case), only that the temperature is linked to the blink speed.

Flashing status of LED is listed in the Sticky and nothing to do with temperature, DUDE:

viewtopic.php?f=28&t=58151#p1485558
The information is out there....you just have to let it in.

My other Linux machines: ChromeBox
https://www.aliexpress.com/item/32966393971.html
& Stone Desktop Intel CoreDuo circa 2010

cleverca22
Posts: 3743
Joined: Sat Aug 18, 2012 2:33 pm

Re: Pi 4B not booting, Green LED blink speed tied to temperature?

Mon May 10, 2021 11:31 am

fruitoftheloom wrote:
Mon May 10, 2021 6:38 am
satirical wizard wrote:
Sun May 09, 2021 9:43 pm
Temperature and Power have pop up warnings:
There is no display dude. It won't boot.
And I didn't suggest it is overheating (definitely isn't with this case), only that the temperature is linked to the blink speed.

Flashing status of LED is listed in the Sticky and nothing to do with temperature, DUDE:

viewtopic.php?f=28&t=58151#p1485558
if you check the video he linked, its doing a very weird thing, where its fading in and out at random
it doesnt look like any standard blink code

pidd
Posts: 2051
Joined: Fri May 29, 2020 8:29 pm
Location: Wirral, UK
Contact: Website

Re: Pi 4B not booting, Green LED blink speed tied to temperature?

Mon May 10, 2021 1:06 pm

How are you writing your SD cards? I can't see a 2GB SD card being anywhere big enough for the OS.

satirical wizard
Posts: 4
Joined: Sat May 08, 2021 11:15 pm

Re: Pi 4B not booting, Green LED blink speed tied to temperature?

Mon May 10, 2021 2:13 pm

pidd wrote: How are you writing your SD cards? I can't see a 2GB SD card being anywhere big enough for the OS.
It fits raspbian lite, alpine and the bootloader utility. Wrote raspbian using pi imager, alpine by extracting the tar into the card.
Both worked at first so it doesn't have to do with the cards.
I forgot to mention, but the flashing happens even without an sd card installed, I'll update the OP.

User avatar
rpdom
Posts: 18696
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Pi 4B not booting, Green LED blink speed tied to temperature?

Mon May 10, 2021 2:29 pm

pidd wrote:
Mon May 10, 2021 1:06 pm
How are you writing your SD cards? I can't see a 2GB SD card being anywhere big enough for the OS.
You can just fit a usable Raspbian Lite on a 2GB card. I use some 4GB cards and there is plenty of space

Code: Select all

Filesystem      Size  Used Avail Use% Mounted on
/dev/root       3.4G  1.4G  1.8G  45% /
Unreadable squiggle

pidd
Posts: 2051
Joined: Fri May 29, 2020 8:29 pm
Location: Wirral, UK
Contact: Website

Re: Pi 4B not booting, Green LED blink speed tied to temperature?

Mon May 10, 2021 4:04 pm

Is the blinking the same with absolutely nothing else connected other than the power lead (no sd, no display, not keyboards etc), or is it a regular blink then?

Someone's got to ask ..... what are you using for a power supply?

satirical wizard
Posts: 4
Joined: Sat May 08, 2021 11:15 pm

Re: Pi 4B not booting, Green LED blink speed tied to temperature?

Mon May 10, 2021 4:10 pm

pidd wrote: Is the blinking the same with absolutely nothing else connected other than the power lead?
What are you using for a power supply?
Same result with nothing but power connected. Power supply is the official one, 5.1v 3A.

MiscBits
Posts: 249
Joined: Wed Jan 27, 2021 12:48 pm

Re: Pi 4B not booting, Green LED blink speed tied to temperature?

Mon May 10, 2021 6:25 pm

Do you have anything plugged into the Pi?

Some keyboards / mice are very heavy in power use...
Is a computer language with goto's totally Wirth-less?

Return to “Troubleshooting”