DickiePhitt
Posts: 4
Joined: Tue Jun 30, 2020 8:05 am

Rpi3B+ & SSD - Is regular yellow LED pulsing normal?

Tue Jun 30, 2020 8:25 am

I recently moved Home Assistant from SD to SSD. Everything works fine but I notice the yellow LED on the Rpi3B+ is pulsing constantly at an interval of about 1 second.

I read somewhere that this might be the Pi looking for the SD card but as I understand it the Rpi3B+ can recognise there is no SD card installed. It certainly started up OK without one.

Is this pulsing normal, and if not what should/can I do about it?

Thanks for reading

drgeoff
Posts: 10674
Joined: Wed Jan 25, 2012 6:39 pm

Re: Rpi3B+ & SSD - Is regular yellow LED pulsing normal?

Tue Jun 30, 2020 8:51 am

The only yellow LED on a 3B+ is in the ethernet jack. Nothing to do with SD card access. That's the green one nearer the red power LED.

DickiePhitt
Posts: 4
Joined: Tue Jun 30, 2020 8:05 am

Re: Rpi3B+ & SSD - Is regular yellow LED pulsing normal?

Tue Jun 30, 2020 8:59 am

Its the LED near power LED I'm referring to - its definitely yellow!!
Attachments
RPi LED.jpg
RPi LED.jpg (180.23 KiB) Viewed 177 times

User avatar
rpdom
Posts: 17016
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Rpi3B+ & SSD - Is regular yellow LED pulsing normal?

Tue Jun 30, 2020 9:38 am

No, it is green. The red from the other LED bleeds over inside the case and makes it look yellow.
Unreadable squiggle

DickiePhitt
Posts: 4
Joined: Tue Jun 30, 2020 8:05 am

Re: Rpi3B+ & SSD - Is regular yellow LED pulsing normal?

Tue Jun 30, 2020 9:59 am

Haha, whatever the colour it flashes continuously, which the SD card install never did.
Should I be concerned? What to do if anything to prevent it?

User avatar
rpdom
Posts: 17016
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Rpi3B+ & SSD - Is regular yellow LED pulsing normal?

Tue Jun 30, 2020 11:55 am

It's nothing to worry about. It's just the Pi checking about once a second to see if an SD card has been inserted. There's an option you can put in /boot/config.txt that will stop it.

I think it was

Code: Select all

dtparam=sd_poll_once=on
Unreadable squiggle

DickiePhitt
Posts: 4
Joined: Tue Jun 30, 2020 8:05 am

Re: Rpi3B+ & SSD - Is regular yellow LED pulsing normal?

Tue Jun 30, 2020 1:57 pm

Thanks, I'll try that.

Return to “Troubleshooting”