misaalanshori
Posts: 4
Joined: Thu Jan 24, 2019 11:22 am

Connection to archive.raspberrypi.org is very slow(1-10 kilobytes/s slow))

Thu Jul 11, 2019 2:48 pm

I just installed raspbian buster on my pi zero and for some reason "sudo apt upgrade" was running very slowly and kept failing with speeds around 1-10kbps (my internet is 20mbit and usually get 2-3mbps on downloads, I live in Indonesia)

I don't have a screenshot of my terminal but here's the speed on my main computer (on the same network)
img1.png
img1.png (13.69 KiB) Viewed 88 times

it kept failing at this raspberrypi-firmware package so I copied the link and created a mirror of the file on my VPS (its located in the us I think)
img2.png
img2.png (19.2 KiB) Viewed 88 times

and then I downloaded it using wget from my VPS at almost full speed (around 1mbps) and installed it with no problems (yet)
Screenshot (360).png
Screenshot (360).png (161.98 KiB) Viewed 88 times

the errors at the top is from me trying to wget http://archive.raspberrypi.org/..... directly from my raspberry pi

running speedtest-cli (had to wait a couple of minutes for it to download) results in almost my full speed (17mbit down and 3mbit up)


I'm sorry if this post looks like mess
tl;dr: my connection to http://archive.raspberrypi.org/ is very slow at around 1-10kbps and making "apt upgrade/install" run very slowly and sometimes failing

misaalanshori
Posts: 4
Joined: Thu Jan 24, 2019 11:22 am

Re: Connection to archive.raspberrypi.org is very slow(1-10 kilobytes/s slow))

Thu Jul 11, 2019 2:54 pm

it seems like connection to http://raspbian.raspberrypi.org/ is also failing, but connection to http://mirror.rise.ph/ is fine (but kinda slow)
imgg.png
imgg.png (59.86 KiB) Viewed 80 times

misaalanshori
Posts: 4
Joined: Thu Jan 24, 2019 11:22 am

Re: Connection to archive.raspberrypi.org is very slow(1-10 kilobytes/s slow))

Fri Jul 12, 2019 9:24 am

It seems like no one know why this is happening, so i installed a vpn (windscribe vpn) and got 200-300kbps

Return to “Troubleshooting”