Overload86
Posts: 7
Joined: Fri May 19, 2017 5:32 pm

A few seconds after starting LXDE my PI switches to terminal

Fri May 19, 2017 5:49 pm

Hello everyone,
I am fairly new at this with a bit of experience regarding linux.

After first tinkering with another sd card image, I decided to "get my hands dirty" so to speak.

I am using a Raspberry Pi 3 with the Raspbian Lite image, everything is up-to-date (apt-get update&&upgrade&&dist-upgrade&&clean has been run). LXDE, lightdm, bluez and Retropie have been installed so far (also git, build essentials, a network manager).

Everything is working just fine, apart from one little annoyance: I decided to try out the booting straight to Retropie and then changed my mind, so I went back into raspi-config and selected boot to desktop with autologin. Now it does that, but... It boots to Desktop and a few seconds after that it just switches to tty1 and only goes back to lxde after I press CTRL+ALT+F7.

I can't for the life of me figure out why. I tried using the raspi-config many times, retropie_setup.sh also has an autostart option, tried that, too. I read up on the internet about how init.d works, I typed 'sudo update-rc.d lightdm enable 2' into the terminal and it didn't help xD

Can't figure out why it just switches to terminal 1 like that. Any help would be greatly appreciated. This is driving me insane.

Edit: I looked at /etc/rc.local, ~/.config/lxsessions/LXDE/autostart, into /etc/rc2.d and can't find anything.
It is getting more annoying, since have now installed synergy to share my Windows PC's mouse and keyboard, but synergy only works in X, so when it switches to Terminal 1 after boot I have to plug in a keyboard, press CTRL-ALT-F7 and _then_ finally can I use my KBM software.

Where else could the problem lie? My other sd card with installed retropie with optional PIXEL environment doesn't have the same problem.


mattmiller
Posts: 1833
Joined: Thu Feb 05, 2015 11:25 pm

Re: A few seconds after starting LXDE my PI switches to term

Sat May 20, 2017 4:55 pm

I suspect that since you've done a lot of unique stuff to your install - you are the only person able to help yourself.

Once you go off-piste - dangers lurk :)

User avatar
davidcoton
Posts: 2941
Joined: Mon Sep 01, 2014 2:37 pm
Location: Cambridge, UK

Re: A few seconds after starting LXDE my PI switches to term

Sat May 20, 2017 6:40 pm

mattmiller wrote:Once you go off-piste - dangers lurk :)
Of course -- you know that "piste" stands for "PI STandard Engineering"? :lol:
"Thanks for saving my life." See https://www.raspberrypi.org/forums/viewtopic.php?p=1327656#p1327656
“Raspberry Pi is a trademark of the Raspberry Pi Foundation”

Overload86
Posts: 7
Joined: Fri May 19, 2017 5:32 pm

Re: A few seconds after starting LXDE my PI switches to term

Sun May 21, 2017 2:54 am

I am aware that this is a problem I somehow created, I was just hoping some Linux wiz would be able to help me figure it out. If I had found a way to make the boot process wait for a key after every step (or heck if I knew where that wall of text in the beginning came from specifically) I could probably figure out what gets started after the X-server is run, that would force it back to tty1. I could also have probably botched some kind of workaround like executing 'chvt 7' at the end of the boot process...

In the end I have for now settled to using a new clean RetroPie image, installed the optional Pixel module from within it's setup and proceeded to install several programs, including kodi, themes, icons, openbox and whatnot. This time everything is booting as it should! xD

When I am done with the basics, before loading roms onto it, I am so going to make another image from my SD and saving it as a backup. Already looking for a way to shrink it down afterwards and forcing it to expand back up on first boot after reflash... Like the other images have done :)

Rascas
Posts: 386
Joined: Tue Mar 11, 2014 6:18 pm
Location: Porto, Portugal
Contact: Website

Re: A few seconds after starting LXDE my PI switches to term

Sun May 21, 2017 6:56 pm


Overload86
Posts: 7
Joined: Fri May 19, 2017 5:32 pm

Re: A few seconds after starting LXDE my PI switches to term

Mon May 22, 2017 1:33 pm

Thank you very much! That seemed to fix it.

Zomb413
Posts: 1
Joined: Mon May 28, 2018 3:45 pm

Re: A few seconds after starting LXDE my PI switches to terminal

Mon May 28, 2018 3:59 pm

note....i do realize this thread has been solved. But feel my alternate method may help some.

I was also having this issue. Also wanted to avoid problems later as a result of changing the code. One way i found to fix it was to run a video splash through retropie setup script (or menu option in gui) at least 10 seconds long. After the splash video at boot, the return code kicks you back to tty7. Although the terminal login on tty1 still takes place. (as observed by ctrl-alt-f1) . If you don't mind a video splash this may be an option.

Return to “Troubleshooting”

Who is online

Users browsing this forum: epelj1, n67 and 47 guests