HDMI Sleep


15 posts
by mrbiz » Wed Jun 19, 2013 9:37 am
Hi All.
I've had my Pi for a while now & am using it for all sorts of things. I'm a bit of a Linux noob though.
I use my Pi mostly for services (DNS, VPN endpoint, proxy, etc) so it is on all the time. But I given it it's own little HDMI monitor & keyboard next to my main PC for when I do want to do something on the Pi directly. The one thing that has been vexing me for a while now is that the Pi will sleep by making the screen go blank but it will not put the monitor to sleep/suspend. The backlight stays on so when I come into my office at night there's always this glow (read: wasted energy) from the monitor. Mostly it stays in terminal mode but it can be in X sometimes, but the sleep states are the same.

Is there a way to fix this? How to I play with the power management settings for the HDMI/display?

Cheers.
Posts: 3
Joined: Wed Jun 19, 2013 9:19 am
by broo0ose » Sun Jun 23, 2013 8:48 pm
There's a set of instructions on this page that should help.
http://www.triggeredmessaging.com/blog/ ... d-graphite
Posts: 312
Joined: Wed Dec 14, 2011 3:59 pm
Location: Wirral, UK
by mrbiz » Wed Aug 21, 2013 5:59 pm
Bump. I still have no control over HDMI power management. please help.
Posts: 3
Joined: Wed Jun 19, 2013 9:19 am
by broo0ose » Thu Aug 22, 2013 2:14 pm
These are my notes on what I did for one project...

Make sure the Pi is set to the correct timezone using the raspi-config utility.

Code: Select all
sudo raspi-config


eg. Europe/London

cron is the service that runs jobs at various times.
tvservice controls the HDMI

Code: Select all
crontab -e
allows you to modify the cron table.

Code: Select all
# m h  dom mon dow   command

# power saving
0  17  *   *   *     tvservice -o
0   8   *   *   1-5    /home/pi/screen_on.sh



this will run tvservice -o at 17:00 every day turning the screen off,
and run a screen_on.sh script at 08:00 every weekday morning.

contents of screen_on.sh

#!/bin/sh
tvservice --preferred > /dev/null
fbset -depth 8; fbset -depth 16; xrefresh
Posts: 312
Joined: Wed Dec 14, 2011 3:59 pm
Location: Wirral, UK
by mrbiz » Tue Aug 27, 2013 6:45 pm
cheers, i'll give it a shot, but still it's not really power management. I mean, the RPi does screen blanking there must be a way to change the method used, it is Linux after all???
Posts: 3
Joined: Wed Jun 19, 2013 9:19 am
by broo0ose » Wed Aug 28, 2013 3:54 pm
'tvservice -o' puts the monitor into sleep mode, the LED on the screen goes from green to orange, there's no glow.
Posts: 312
Joined: Wed Dec 14, 2011 3:59 pm
Location: Wirral, UK
by gkreidl » Wed Aug 28, 2013 4:19 pm
Nobody seem to understand the real problem: There should be a way to set the monitor in sleep mode automatically, instead of just blanking the screen. All my other Computers do this (Linux and Windows).
It's simpy a question of saving power.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer
Posts: 4108
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany
by spongman » Fri Sep 06, 2013 12:33 am
bump.

is there really no way to do this?

just think of the trees!
Posts: 10
Joined: Wed Aug 22, 2012 9:04 pm
by AGWA » Wed Jan 08, 2014 5:54 am
The kernel driver for the Raspberry Pi's GPU does not support the function that X uses to put the monitor to sleep. I have opened an issue about this here:

https://github.com/raspberrypi/linux/issues/487

Until this issue is resolved, it won't be possible for X to put the monitor to sleep on a Raspberry Pi.
Posts: 3
Joined: Wed Jan 08, 2014 5:51 am
by __Plasma__ » Sat Apr 02, 2016 10:59 pm
This I still a problem for me, I know this thread is old but surely this should have been fixed by now?

I'm running an rPi 3 with the latest Jessie release, screen goes blank, but the screen is still awake. I too would like to save energy, with a Windows PC the screen sleeps properly.

Plasma
Posts: 25
Joined: Sat Mar 05, 2016 9:31 pm
by AGWA » Sun Apr 03, 2016 3:07 am
Plasma: addding
Code: Select all
hdmi_blanking=1
to /boot/config.txt should fix the issue.
Posts: 3
Joined: Wed Jan 08, 2014 5:51 am
by __Plasma__ » Mon Apr 04, 2016 8:57 pm
Fantastic that has indeed solved my problem.

Plasma
Posts: 25
Joined: Sat Mar 05, 2016 9:31 pm
by gkreidl » Mon Apr 04, 2016 9:12 pm
AGWA wrote:Plasma: addding
Code: Select all
hdmi_blanking=1
to /boot/config.txt should fix the issue.

Unfortunately this keeps some applications (gstreamer1.0 based) from working and may even crash the system.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer
Posts: 4108
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany
by __Plasma__ » Mon Apr 04, 2016 9:32 pm
gkreidl wrote:
AGWA wrote:Plasma: addding
Code: Select all
hdmi_blanking=1
to /boot/config.txt should fix the issue.

Unfortunately this keeps some applications (gstreamer1.0 based) from working and may even crash the system.


Any suggestions on a better way to enable this functionality? Its likely I will only be using Raspian with the Web Browser and Kodi.

I am running it as a Media Centre in my kitchen, so a few recipes and some movies are all I need.

Plasma
Posts: 25
Joined: Sat Mar 05, 2016 9:31 pm
by HankB » Tue Apr 05, 2016 2:56 pm
Thanks, works for me too.
Posts: 73
Joined: Fri Jan 01, 2016 2:45 pm