theholychilli
Posts: 18
Joined: Thu Apr 25, 2013 5:07 pm

timeout in locking authority file /home/pi/.Xauthority

Sun Apr 28, 2013 6:09 pm

so I have just been following this tutorial: http://www.instructables.com/id/Bluetoo ... spberry-Pi
I've done everything up to step 3, because when I reboot my Raspberry Pi, it just says:
xauth: timeout in locking authority file /home/pi/.Xauthority
Then it goes black for a few minutes and then it comes up with "No protocol specified" all the way down the screen, then:
xinit: giving up
xinit: unable to connect to X server: Resource temporarily unavailable

waiting for X server to shut down Server terminated successfully (0). Closing log file.
xinit: server error
xauth: timeout in locking authority file /home/pi/.Xauthority

I'm running Debian and have all the latest upgrades and updates.

Any help would be awesome.

tvoverbeek
Posts: 89
Joined: Mon Feb 04, 2013 9:50 am
Location: Fieberbrunn, Austria

Re: timeout in locking authority file /home/pi/.Xauthority

Sun Apr 28, 2013 6:21 pm

Step 3 installs a vnc server in case you do not have a display connected to your Pi.
My guess is that you already have a X server running on display :0, hence when the vncserver
tries to access display :0 it fails.
In step 3 try to change 'vncserver :0 -geometry 1920x1080 -depth 24' to
'vncserver :1 -geometry 1920x1080 -depth 24'.
This gives the vncserver its own display and X server which does not conflict with the other one.
Hope this helps.

Ton

theholychilli
Posts: 18
Joined: Thu Apr 25, 2013 5:07 pm

Re: timeout in locking authority file /home/pi/.Xauthority

Sun Apr 28, 2013 6:50 pm

Thanks, this helped a lot. :D

theholychilli
Posts: 18
Joined: Thu Apr 25, 2013 5:07 pm

Re: timeout in locking authority file /home/pi/.Xauthority

Sun Apr 28, 2013 7:22 pm

Is there any way I can disable it?

tvoverbeek
Posts: 89
Joined: Mon Feb 04, 2013 9:50 am
Location: Fieberbrunn, Austria

Re: timeout in locking authority file /home/pi/.Xauthority

Sun Apr 28, 2013 7:58 pm

I assume you mean disabling the original X server running on display :0.
If you are using Raspbian just run raspi-config and under the 'boot behaviour' topic
select to *not* boot to the desktop.
This will delete starting the X server and the window manager at boot time.

Ton

theholychilli
Posts: 18
Joined: Thu Apr 25, 2013 5:07 pm

Re: timeout in locking authority file /home/pi/.Xauthority

Sun Apr 28, 2013 8:12 pm

Ok, so I've done that, and it comes up with login and password, but whenever I enter those in, it goes black for a few seconds, then goes back onto that screen.
yeah i think ive screwed everything up

I'm a complete noob at this. :lol:

theholychilli
Posts: 18
Joined: Thu Apr 25, 2013 5:07 pm

Re: timeout in locking authority file /home/pi/.Xauthority

Sun Apr 28, 2013 8:22 pm

Ok this is really annoying me now! :evil:

Return to “Beginners”

Who is online

Users browsing this forum: No registered users and 35 guests