Harrowed
Posts: 6
Joined: Mon Aug 27, 2012 8:13 pm

Usb memory drive mounts as read-only file system

Mon Aug 27, 2012 8:21 pm

I have problem with my usb memory drive mounting as read-only file system (even for the owner). How to change this?

elatllat
Posts: 1338
Joined: Sat Dec 17, 2011 5:05 pm

Re: Usb memory drive mounts as read-only file system

Mon Aug 27, 2012 11:39 pm

mount -n -o remount,rw /your/mount/point

How are you mounting it?
What's the output of

Code: Select all

mount
?
4k or USB3 : hardkernel.com

FAQ : raspberrypi.stackexchange.com

https://google.com/search?q=site%3Awww.raspberrypi.org+search+first

https://www.raspberrypi.org/forums/search.php?search_id=unanswered

Harrowed
Posts: 6
Joined: Mon Aug 27, 2012 8:13 pm

Re: Usb memory drive mounts as read-only file system

Tue Aug 28, 2012 8:06 am

Code: Select all

pi@raspberrypi ~ $ sudo mount -n -o remount,rw /home/pi/Mohikaani
mount: warning: /home/pi/Mohikaani seems to be mounted read-only.
I'm mounting with this script:

Code: Select all

#! /bin/sh
# /etc/init.d/mountdisk

sudo mount -o uid=pi,gid=pi /dev/sda1 /home/pi/Mohikaani

exit 0
I also tried without that script and even automatic mount to the media folder happens as read-only.

User avatar
RaTTuS
Posts: 9495
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK

Re: Usb memory drive mounts as read-only file system

Tue Aug 28, 2012 8:09 am

check the filesystem of the drive
i.e.
fsck.ext4 [or whatever] /dev/sda1
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

Harrowed
Posts: 6
Joined: Mon Aug 27, 2012 8:13 pm

Re: Usb memory drive mounts as read-only file system

Tue Aug 28, 2012 8:50 am

The file system is ntfs because it was used with Windows before (and still is every now and then) and there's 1,5 TB used so the file system change would be pretty burdensome. It worked before.

So here's the output with ntfsfix from ntfs-3g suite.

Code: Select all

pi@raspberrypi ~ $ sudo ntfsfix /dev/sda1
Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sda1 was processed successfully.

Harrowed
Posts: 6
Joined: Mon Aug 27, 2012 8:13 pm

Re: Usb memory drive mounts as read-only file system

Tue Aug 28, 2012 9:05 am

Oh, now it works after 10th reboot. I can see what ya did there Mr. USB-Drive.

Harrowed
Posts: 6
Joined: Mon Aug 27, 2012 8:13 pm

Re: Usb memory drive mounts as read-only file system

Sat Sep 01, 2012 9:00 am

Ok, the problem is back and rebooting doesn't help. Any ideas?

bestie
Posts: 1
Joined: Wed Nov 14, 2012 6:31 pm

Re: Usb memory drive mounts as read-only file system

Wed Nov 14, 2012 6:36 pm

I've had a similar problem, it turned out the file system on my USB stick was being corrupted by NZBGet so every time I started it the stick would go read-only. Once I repaired the file system it was fine.

Hope that helps someone.

Noar
Posts: 1
Joined: Wed Oct 24, 2012 10:05 pm

Re: Usb memory drive mounts as read-only file system

Thu Nov 15, 2012 9:38 am

Maybe comming from unclean disconnection from windows box. For me, ntfs-3g did the trick.
sudo apt-get install ntfs-3g

Rad77
Posts: 5
Joined: Sat Dec 29, 2012 9:53 am

Re: Usb memory drive mounts as read-only file system

Sat Dec 29, 2012 9:57 am

Also had the same problem and that fix (install ntfs-3g) worked for me - Thanks!
Now mounted just fine using...
sudo mount -t ntfs-3g -o uid=pi,gid=pi /dev/sda1 /media/WD250/

jfornango
Posts: 113
Joined: Fri Sep 14, 2012 7:46 pm
Location: St. Louis, MO USA
Contact: Yahoo Messenger

Re: Usb memory drive mounts as read-only file system

Mon Dec 31, 2012 9:02 pm

Just one more reason for the world to go NFS. :lol:
I'm only wearing black until they find something darker.

cats_five
Posts: 45
Joined: Mon Oct 22, 2012 8:12 am

Re: Usb memory drive mounts as read-only file system

Fri Jan 11, 2013 10:12 am

I had exactly the same problem and using ntfs-3g fixed it, but I didn't realise at first I needed to install something extra to do this.

Anyway that means a PC could read what's on my external HDD and I've not had to reformat it all of which is Good.

xfear238
Posts: 1
Joined: Thu Aug 15, 2013 10:15 am

Re: Usb memory drive mounts as read-only file system

Thu Aug 15, 2013 10:17 am

Use this command first to install ntfs-3g on your raspberry pi :

sudo apt-get install fuse ntfs-3g

sudo mount -t ntfs-3g /dev/sda1 /media/2TO/

It works !

russellhoff
Posts: 4
Joined: Fri Jul 26, 2013 1:43 pm

Re: Usb memory drive mounts as read-only file system

Wed Dec 18, 2013 5:03 pm

You should try mounting devices with Fstab. It's properlier to do with it rather than using any other script. It's also very simple.

$ leafpad /etc/fstab

Then add a line similarly as the one you wrote in the script.

Check out wikipedia's fstab page.

Return to “Beginners”

Who is online

Users browsing this forum: Kaej and 42 guests