Booting to command-line interface

5 posts
by winegums » Fri Oct 26, 2012 8:02 am
Hi, new to Pi so sorry for the invariably dumb question. I've setup my Pi to use the retro-pi stuff contained here: ... pberry-pi/

When trying to use it, however, I get an error that suggests that the app needs all input devices exclusively, and that I need to run it without e.g. LXDE.

X is still running. Please shut down X in order to mitigate problems with losing keyboard input. For example, log out of LXDE

So, I try logging out and get to a login screen. One of them is 'default xSession', which sounds like what I want, but when I log on to that I get bumped back to LXDE.

tl;dr - how do I boot to command line? Or, am I way off in my solution to this problem?
Posts: 1
Joined: Fri Oct 26, 2012 7:31 am
by smartpatrol » Sun Oct 28, 2012 3:10 pm
If you can get to a terminal session you can issue an init 3 which will put you at Multi-user with networking run level;shutting off the GUI. You then can make that permanent but changing the default runlevel(Google it) in the /etc/inittab(be careful editing this file is easy to foobar your system with a bad edit) otherwise you can switch back and forth by using the init command (init 5 which will take you back into a run level with a display manager).
Posts: 23
Joined: Thu Oct 18, 2012 2:28 am
by hexelpdkk » Sun Oct 28, 2012 7:49 pm
A slightly easier way is to open a terminal and run raspi-config. There is an option there that sets whether you boot straight to a graphical desktop or not.
User avatar
Posts: 175
Joined: Fri Feb 24, 2012 4:40 pm
by Digital Larry » Sun Nov 04, 2012 4:45 pm
I'm having a similar issue.

I started with Raspbian "Pisces" image and have modified it heavily since then - mostly adding the Xfce desktop. Now I can't figure out how to get to a basic "no-X" boot. This is pretty important because I've written some timing applications in Python and they keep best time when not running inside X.

I do not have a "raspi-config" script, or if I do, I don't know where it lives.

I also tried the advice I found on this page. The results are:

root@pisces:/etc/init.d# sudo update-rc.d gdm disable
update-rc.d: using dependency based boot sequencing
update-rc.d: error: cannot find a LSB script for gdm

How can I install raspi-config?

I tried apt-get install raspi*, and while it found and installed a few things, raspi-config was not among them.

Thanks in advance!
Posts: 63
Joined: Tue Jul 24, 2012 9:10 pm
Location: Silicon Valley, CA
by Digital Larry » Sun Nov 04, 2012 9:03 pm
I think I can answer some of my own question.

#1 I found the code for raspi-config here: ... n-raspbian

I made a copy of this and pasted into a new file on my machine. I ran it and it popped out some odd errors/warnings, and the bootup behavior did not change.

#2 Pretty sure that when I installed Xfce that it over-rode the startup script that was there by default in the Pisces image I started with. At this point it may be easier just to go back to that image.

In general, my experience with running Xfce or LXDE on Raspberry Pi is pretty bad. Opening a browser takes CPU to 100% typically. It's slow enough to make one not want to do it. So I'm OK going back to a "no-X" configuration for the Raspberry Pi.
Posts: 63
Joined: Tue Jul 24, 2012 9:10 pm
Location: Silicon Valley, CA