Keyboard layout for Your country


23 posts
by Strawberry_Monty » Mon Oct 01, 2012 4:17 am
Haven't seen any guide here for making the keyboard showing Your national characters - like german or swedish Ö in the console (that is from boot).

Not that the national charaters are exactly usefull in console due to the OS's english nature - BUT by god - You need to have the keyboard configured to enter a simple # char by pressing the corresponding key with that symbol.

Else You get all kinds of other chars (like a silly pound sign etc.).

go sudo (or call for him) - the SUPERUSER and write:

dpkg-reconfigure keyboard-configuration

wait a moment and select keyboard type (default marked) and Your language (indo zulu or whatever..)

at end reboot (by writing that or kill the fruit by unpowering)

note: wonder why not anyone else has asked for this - i tried search. Maybe only english ppl get a Pi and therefore :? not any problems with the layout...
Posts: 33
Joined: Wed Sep 19, 2012 9:56 pm
by pluggy » Mon Oct 01, 2012 7:57 am
It doesn't ,come up that much because its part of the initial configuration on the Raspbian image.

Image

Code: Select all
sudo raspi-config


will get you into it after the event.
Don't judge Linux by the Pi.......
I must not tread on too many sacred cows......
User avatar
Posts: 3636
Joined: Thu May 31, 2012 3:52 pm
Location: Barnoldswick, Lancashire,UK
by Strawberry_Monty » Mon Oct 01, 2012 12:16 pm
Mine did not ask for any configuration at all. Maybe because i did'nt have the network connected....
Posts: 33
Joined: Wed Sep 19, 2012 9:56 pm
by pyter » Thu Oct 11, 2012 11:23 pm
None of the options above is really working...
I've tried to create a script and register it to run on startup but nothing happened...

Could it be the drivers?
Posts: 4
Joined: Wed Nov 02, 2011 4:26 pm
by pluggy » Fri Oct 12, 2012 6:19 am
Its only recent versions of the image that have the raspi-config. If you bought a preloaded SD card (which typically have old images) it won't work.
Don't judge Linux by the Pi.......
I must not tread on too many sacred cows......
User avatar
Posts: 3636
Joined: Thu May 31, 2012 3:52 pm
Location: Barnoldswick, Lancashire,UK
by pyter » Fri Oct 12, 2012 8:39 am
pluggy wrote:Its only recent versions of the image that have the raspi-config. If you bought a preloaded SD card (which typically have old images) it won't work.


Not the case. I've downloaded from here. But after a while I've managed to fix it.

Create this file
Code: Select all
sudo nano /home/pi/.xsessionrc

Insert inside the file (this example is for Portuguese layout):
Code: Select all
setxkbmap pt


Save it and reboot it.

Source: http://www.raspberrypi.org/phpBB3/viewtopic.php?f=66&t=17371
Posts: 4
Joined: Wed Nov 02, 2011 4:26 pm
by SiriusHardware » Fri Oct 12, 2012 9:19 pm
Strawberry_Monty wrote:Haven't seen any guide here for making the keyboard showing Your national characters -

note: wonder why not anyone else has asked for this - i tried search. Maybe only english ppl get a Pi and therefore :? not any problems with the layout...


Some of the surplus/cheap keyboards available in Britain are of American origin, or were made for the American market and then wrongly imported into Britain, for which they are not really suitable: Several of the keys have some of the characters in the wrong places, and of course we Brits do use that silly pound sign which is missing from the American layout.

We can't solve the problem of the keyboard not having a Pound sign, but we can make the symbols on the keys match the ones which appear on the screen by using your guide to set the key layout to American, to match the keyboard. I have about 5-6 very nice mini USB keyboards - USA layout - which I salvaged from equipment which came with them at work.

If RS ever delivers my other Pi I will use one of them with that.
Posts: 474
Joined: Thu Aug 02, 2012 9:09 pm
Location: UK
by toxibunny » Fri Oct 12, 2012 9:55 pm
Bought myself a keyboard the other day which turned out to be Czech. Switched it to Czech, and now all my symbols match the ones on the keys, but it's HORRIBLE. Poor Czechies have to press shift just to type numbers! And the brackets are all wrong... I'm going to switch back to the UK layout and just remember where the symbols are...
note: I may or may not know what I'm talking about...
Posts: 1383
Joined: Thu Aug 18, 2011 9:21 pm
by malakai » Fri Oct 12, 2012 10:01 pm
As an American I must admit when you say it doesn't have a pound sign I think of this # it's Shift+3 on our keyboard. But then I have to think is it £ which is also Shift+3 as I am assuming you call our pound a hash maybe.

If nothing this thing is culturally educational and since my $ is not worth an ounce of a £ I guess we were wise in dropping the term from our currency. :)
http://www.raspians.com - always looking for content feel free to ask to have it posted. Or sign up and message me to become a contributor to the site. Raspians is not affiliated with the Raspberry Pi Foundation. (RPi's + You = Raspians)
User avatar
Posts: 1383
Joined: Sat Sep 15, 2012 10:35 am
by SiriusHardware » Sat Oct 13, 2012 9:56 am
malakai wrote:As an American I must admit when you say it doesn't have a pound sign I think of this # it's Shift+3 on our keyboard. But then I have to think is it £ which is also Shift+3 as I am assuming you call our pound a hash maybe.


Yes, in British english the (#) symbol is called a 'hash'.

malakai wrote:If nothing this thing is culturally educational and since my $ is not worth an ounce of a £ I guess we were wise in dropping the term from our currency. :)


That's quite interesting - you (Americans) call this (#) a 'Pound'? On a British keyboard shift-3 has this (£), which is the British Pound (currency) symbol. We do have the hash (#) character as well, but it is the unshifted character on the key to the left of the main carriage return (enter) key on a full sized British keyboard. These (and a couple of other differences) make American-layout keyboards slightly awkward to use on British computing devices.

I saw the (#) symbol referred to as 'Pound' in a programming book of USA origin and thought it must have been missed in the translation from the American to the British market version (or just not translated at all).

You Americans can at least take some consolation from the fact that the dominant size of your market means that much of the equipment made in the world is tailored for you - a good example would be clocks and watches - virtually all digital clocks and watches sold here in Britain now use the American Month / Day date format, whereas in the UK the date format used is Day / Month, although it is nearly impossible for us to find a clock which displays them in that order.

So cheer up! :)
Posts: 474
Joined: Thu Aug 02, 2012 9:09 pm
Location: UK
by Tomin » Tue Dec 25, 2012 2:52 pm
Keyboard configuration in rasp-config doesn't seem to work. I've set my keyboard layout to Finnish on very first boot, but it's still something else (US?). Something it changes though as rasp-config remembers that I've chosen Finnish layout. Next I'm going to try dpkg-reconfigure keyboard-configuration.
Posts: 3
Joined: Tue Dec 25, 2012 2:46 pm
by Sleep Mode zZ » Tue Dec 25, 2012 4:41 pm
Tomin wrote:Keyboard configuration in rasp-config doesn't seem to work. I've set my keyboard layout to Finnish on very first boot, but it's still something else (US?). Something it changes though as rasp-config remembers that I've chosen Finnish layout. Next I'm going to try dpkg-reconfigure keyboard-configuration.

Look at pyter's solution above. Instead of "pt" use "fi".
Posts: 319
Joined: Sun Aug 19, 2012 5:56 am
Location: Finland
by Tomin » Tue Dec 25, 2012 5:37 pm
Interesting. I had used a different keyboard previously and now when I plugged it back I found myself writing with Finnish layout. Is this desired behaviour?
Posts: 3
Joined: Tue Dec 25, 2012 2:46 pm
by buurmas » Fri Jan 04, 2013 7:36 pm
This "remapping your keyboard" topic is also covered here:

http://elinux.org/index.php?title=R-Pi_ ... an_Squeeze
Posts: 2
Joined: Wed Jan 02, 2013 8:13 pm
by bennyroger » Sun May 12, 2013 6:41 am
Thank you pyter, now I have the Norwegian ØÆÅ :-)
Posts: 2
Joined: Sun May 12, 2013 6:35 am
by Mrloewe67 » Mon Aug 26, 2013 3:37 pm
Hey ! I don t now if any one will reply to my question, but I will ask it.
I have a german kezboard (logitech wireless k400r) but I couldn t find the correct layout on my Raspberry PI for this keyboard... Can you help me please ?

Thanks
Posts: 1
Joined: Mon Aug 26, 2013 3:26 pm
by kmakila » Tue Oct 08, 2013 12:59 pm
pyter wrote:
pluggy wrote:Its only recent versions of the image that have the raspi-config. If you bought a preloaded SD card (which typically have old images) it won't work.


Not the case. I've downloaded from here. But after a while I've managed to fix it.

Create this file
Code: Select all
sudo nano /home/pi/.xsessionrc

Insert inside the file (this example is for Portuguese layout):
Code: Select all
setxkbmap pt

Thanks pyter,  working now but it took me some time to figure out that it is se for sweden rather than sw /Sweden)  or  se (Sverige) and in OpenELEC se-fi-lat6


Save it and reboot it.

Source: http://www.raspberrypi.org/phpBB3/viewtopic.php?f=66&t=17371
Posts: 5
Joined: Fri Oct 04, 2013 10:26 am
by qwertinsky » Sat Dec 27, 2014 9:41 pm
How do I make my shift+3 make the # instead of that funny British dollar sign?

I can't even figure out how to make that symbol on my Windows machine?

The only choices I saw in raspi-setup was for UK keyboards and char sets?
Posts: 6
Joined: Fri Mar 15, 2013 1:19 am
by DougieLawson » Sun Dec 28, 2014 11:38 am
sudo raspi-config
Then choose the internationalisation option from the menu.
That option lets you set keyboard layout, locale and timezone.
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

Since 2012: 1B*5, 2B*2, B+, A+, Zero*2, 3B*3

Please post ALL technical questions on the forum. Do not send private messages.
User avatar
Posts: 27083
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
by klricks » Sun Dec 28, 2014 11:44 pm
qwertinsky wrote:How do I make my shift+3 make the # instead of that funny British dollar sign?

I can't even figure out how to make that symbol on my Windows machine?

The only choices I saw in raspi-setup was for UK keyboards and char sets?


The menu is not very intuitive. To get to country menu you first have to scroll to the bottom of the list and choose [Other]
Detailed instructions below:
---------------------------------
(For Raspbian OS)

sudo raspi-config

- Choose Internationalization menu
- Choose keyboard setup menu.
- If your exact keyboard is not on the list then choose one of the generic 101, 102 or 104 keyboards.

The following steps are Important! If need US then you must choose US. Don't leave it set to UK.......

- The default Keyboard Layout is [ English (UK) ]
- You may need to scroll down and select [Other] to get back to the country of origin menu
- From country of origin menu select [English (US) ]
- Then from Keyboard layout: menu, scroll to top of list and select - [ English (US) ]. Do not choose anything else unless you know exactly what you are doing!

- Complete the other menus then reboot.
Go here for my RPi writeup. Basic config, Serial Port add-on etc:
http://blackeagle12.net/Comp/RPi/Rpi.html Click web icon on right side --->
Posts: 4227
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
by tomreedtoon » Sun Jan 11, 2015 7:25 am
I tried the process of going through and re-selecting the keyboard, but things are still wrong. The shift-2 should be an ampersand (@), but it's a double-quote sign ("). The keyboard I'm using is a garden-variety 105-key model, which I selected during setup. After finishing, I still get the same strange results from the keyboard. Do I have to reboot for the keyboard settings to apply?

Also, there are lots of variant keyboards listed in the US settings including Dvorak, and ones which sound like the Microsoft "International U.S. Keyboard" settings - which allow symbols and other type to be entered in with the ALT plus four keypad numbers. (Such as ALT-0169 is the copyright - © - symbol.) If anyone knows if this setting is available on the Pi, please explain it! A thousand thanks.
Posts: 1
Joined: Sun Jan 11, 2015 7:16 am
by klricks » Sun Jan 11, 2015 5:13 pm
tomreedtoon wrote:I tried the process of going through and re-selecting the keyboard, but things are still wrong. The shift-2 should be an ampersand (@), but it's a double-quote sign ("). The keyboard I'm using is a garden-variety 105-key model, which I selected during setup. After finishing, I still get the same strange results from the keyboard. Do I have to reboot for the keyboard settings to apply?

Also, there are lots of variant keyboards listed in the US settings including Dvorak, and ones which sound like the Microsoft "International U.S. Keyboard" settings - which allow symbols and other type to be entered in with the ALT plus four keypad numbers. (Such as ALT-0169 is the copyright - © - symbol.) If anyone knows if this setting is available on the Pi, please explain it! A thousand thanks.


As already mentioned in previous post, reboot is required after keyboard setup change.
Don't know about the Alt key entering? Try it and see you would likely be the 1st one to do so. Don't choose Dvorak unless you learned to type on Dvorak keyboard!!!
Go here for my RPi writeup. Basic config, Serial Port add-on etc:
http://blackeagle12.net/Comp/RPi/Rpi.html Click web icon on right side --->
Posts: 4227
Joined: Sat Jan 12, 2013 3:01 am
Location: Grants Pass, OR, USA
by rjwhite » Thu Dec 17, 2015 1:59 am
I went through a lot of frustration trying to get the British Pound (£) changed to a hash (#) character on my keyboard and nothing worked. I ended up with a question mark, after repeatedly saying I wanted English US.

So, I fixed it by just changing the file /etc/default/keyboard to this:
Code: Select all
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="us"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"

and then rebooting.
Thanx to Tom McCurdy at https://www.youtube.com/watch?v=L1F-TxTPyiM
Posts: 1
Joined: Thu Dec 17, 2015 1:38 am
Location: Toronto, Canada