Network manager in raspbian "wheezy"?


10 posts
by Mauste » Thu Jul 19, 2012 1:24 pm
Hello, I would call myself a beginner. I have used linux before (fedora), but my skills are very rusty since it was somewhat long ago. I tried searching, but either my keywords were bad or I overlooked something.

I have an internet-connection that requires me to type in username and password before I can connect to the internet (PPPoE-connection) . I don't see a network manager in the graphical environment in the recommended raspbian wheezy-distro. Am I being blind or do I have to edit some files? Is any other distro "easier to set-up" considering my issue? Any help is very much appreciated. Thank you in advance.
Posts: 29
Joined: Thu Jul 19, 2012 1:15 pm
by redhawk » Thu Jul 19, 2012 2:42 pm
try: apt-get wicd

Richard S.
User avatar
Posts: 3465
Joined: Sun Mar 04, 2012 2:13 pm
Location: ::1
by Mauste » Thu Jul 19, 2012 3:27 pm
Thanks for the suggestion. However, it doesn't help me.

apt-get install needs an internet-connection so it can automatically download and install the package. And since I don't have an active internet-connection, the install fails.
Posts: 29
Joined: Thu Jul 19, 2012 1:15 pm
by Mast » Thu Jul 19, 2012 7:18 pm
The recommended images (including the new official "raspbian" wheezy) don't have PPPoE software installed by default. This creates a chicken-and-egg problem, like you've described. This is how I get around that.
First, you need to download the needed packages to a computer with an internet connection. The packages needed are (with links for raspbian-wheezy): libpcap0.8, ppp and pppoeconf.
Then, you move the files to the Pi, the easiest way would be with a USB drive. Install the packages like this:
Code: Select all
$ sudo dpkg -i /path/to/usbdrive/libpcap0.8_1.3.0-1_armhf.deb
Once that's done, run
Code: Select all
$ sudo pppoeconf
and follow the instructions (mainly just press enter).
If you have any more questions, feel free to ask. I've done this several times on various debian images, always works (with some minor workarounds).
One of this days I'll have to find the time to add this info to the wiki. What would be really great, though, if pppoe were included in the images by default.
Posts: 5
Joined: Thu Jul 19, 2012 7:03 pm
by Mauste » Fri Jul 20, 2012 11:43 am
That solved my problem. Thank you very much.
Posts: 29
Joined: Thu Jul 19, 2012 1:15 pm
by Perl » Sat Jul 21, 2012 3:01 am
I'm just not getting PPP to work. I'm using the latest raspbian wheezy with
ppp installed

root@raspberrypi:/etc# uname -a
Linux raspberrypi 3.1.9+ #171 PREEMPT Tue Jul 17 01:08:22 BST 2012 armv6l GNU/Linux

/var/log/messages contains

Jul 21 02:58:32 raspberrypi pppd[2672]: pppd 2.4.5 started by root, uid 0
Jul 21 02:58:32 raspberrypi pppd[2672]: Using interface ppp0
Jul 21 02:58:32 raspberrypi pppd[2672]: Connect: ppp0 <--> /dev/ttyUSB0
Jul 21 02:58:32 raspberrypi pppd[2672]: Remote message: Welcome!
Jul 21 02:58:33 raspberrypi pppd[2672]: PAP authentication succeeded
Jul 21 02:58:33 raspberrypi pppd[2672]: kernel does not support PPP filtering
Jul 21 02:58:48 raspberrypi pppd[2672]: Terminating on signal 15
Posts: 4
Joined: Wed Jun 06, 2012 2:55 pm
by Mast » Sat Jul 21, 2012 8:36 am
Looking at my /var/log/messages, I get that filtering error too, but it still connects. Googling a bit I found this:
If you get a message saying that your kernel does not support ppp, do not recompile the kernel. This error message is a grab bag error message which the pppd program produces almost anytime something goes wrong.
So it's useless. Try "poff", then "pon dsl-provider" to restart pppd, then "plog". See if that gives something more meaningful.
Do you happen to be using a static IP address on your internal network (eth0)? And can you ping google.com?
Posts: 5
Joined: Thu Jul 19, 2012 7:03 pm
by chilly » Sun May 12, 2013 11:16 am
@Mast : I do not know if this thread is still alive.
I need help.
I have followed your instruction, also install corresponding files from your link.
However after I do the sudo pppoeconf, it shows DOS GUI with a progress bar in the middle, but after twice it goes, it displays a dialog that says

--- NOT CONNECTED ---
Sorry, I scanned 1 interface. but the Access Concentrator of your provider did not respond. Please check your network and modem cables. Another reason for the scan failure may also be another running pppoe process which controls the modem

I have tried it many times, including rewriting fresh raspbian image to memcard and installing those 3 files directly without anything else.

My modem is Huawei EC1261-2, vnedor ID 12d1 product id 1505
any assistance greatly appreciated, thanks
Posts: 1
Joined: Sun May 12, 2013 11:05 am
by corporal » Thu May 16, 2013 9:35 am
chilly wrote:... after I do the sudo pppoeconf, it shows DOS GUI with a progress bar in the middle, but after twice it goes, it displays a dialog that says

--- NOT CONNECTED ---
Sorry, I scanned 1 interface. but the Access Concentrator of your provider did not respond. Please check your network and modem cables. Another reason for the scan failure may also be another running pppoe process which controls the modem


Hi, same here.
I'm trying to install ppp in order to make a 3g dongle to work, following the instructions on this page:
http://shkspr.mobi/blog/2012/07/3g-inte ... i-success/

I would be grateful for any help, thx!
Posts: 1
Joined: Thu May 16, 2013 9:24 am
by Houser » Thu Oct 10, 2013 2:43 am
I used a normal ethernet cable to get online, and then ran
'sudo apt-get install wicd'
This made my wifi dongle work after clicking on start/Internet/wicd and setting the options. I could then unplug my Ethernet.
Posts: 6
Joined: Fri Oct 04, 2013 3:49 am